oprofile: Move more functionality to oprofile.inc, remove version 0.9.2
authorHolger Hans Peter Freyther <zecke@selfish.org>
Wed, 6 Jan 2010 05:06:53 +0000 (13:06 +0800)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Wed, 6 Jan 2010 05:55:58 +0000 (06:55 +0100)
* Remove version 0.9.2. It does not compile with a recent stdc++, the
  compiler is reporting other scary bits as well and it is quite old
  where all other versions are just dropins.
* Move everyting into the .inc file, remove the PACKAGES line and convert
  it to the INC_PR.
* All existing variants were compile tested.

recipes/oprofile/oprofile.inc
recipes/oprofile/oprofile_0.9.2.bb [deleted file]
recipes/oprofile/oprofile_0.9.3.bb
recipes/oprofile/oprofile_0.9.4.bb
recipes/oprofile/oprofile_0.9.5.bb

index d98610f..f346c10 100644 (file)
@@ -3,8 +3,15 @@ DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
 of profiling all running code at low overhead."
 LICENSE = "GPL"
 DEPENDS = "popt binutils"
+RDEPENDS += "binutils-symlinks"
+RRECOMMENDS += "kernel-vmlinux"
+INC_PR = "r11"
 
 S = "${WORKDIR}/oprofile-${PV}"
+SRC_URI = "\
+       ${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+       file://acinclude.m4 \
+       "
 
 inherit autotools
 
@@ -35,6 +42,11 @@ do_configure () {
 #  --with-qt-includes      where the Qt includes are.
 #  --with-qt-libraries     where the Qt library is installed.
 
+do_stage () {
+       # As of 0.9.4 there is a libopagent library to compile and link against.
+       autotools_stage_all
+}
+
 OPROFILE_ARCH = "${TARGET_ARCH}"
 OPROFILE_ARCH_i586 = "i386"
 # note this excludes the ppc64 directory 
@@ -42,3 +54,12 @@ OPROFILE_ARCH_i586 = "i386"
 OPROFILE_ARCH_powerpc = "ppc"
 
 FILES_${PN} = "${bindir} ${datadir}/oprofile/rtc ${datadir}/oprofile/stl.pat ${datadir}/oprofile/${OPROFILE_ARCH}"
+FILES_${PN} += "\
+       ${libdir}/oprofile/libopagent.so.* \
+"
+
+FILES_${PN}-dev += "\
+       ${libdir}/oprofile/lib*.so \
+       ${libdir}/oprofile/lib*.a \
+       ${libdir}/oprofile/lib*.la \
+"
diff --git a/recipes/oprofile/oprofile_0.9.2.bb b/recipes/oprofile/oprofile_0.9.2.bb
deleted file mode 100644 (file)
index c109e8c..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-require oprofile.inc
-
-PR = "r3"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
-          file://no_arm_mapping_syms.patch;patch=1 \
-           file://opcontrol_bashisms.patch;patch=1 \
-          file://acinclude.m4"
index bdb8d89..1b7cf3c 100644 (file)
@@ -1,15 +1,12 @@
 require oprofile.inc
 
-RDEPENDS += "binutils-symlinks"
-RRECOMMENDS += "kernel-vmlinux"
-PR = "r11"
+PR = "${INC_PR}.0"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+SRC_URI += "\
            file://armv6_fix.patch;patch=1 \
            file://oparchive_fix.patch;patch=1 \
            file://root_option.patch;patch=1 \
            file://opstart.patch;patch=1 \
            file://fix-arith.patch;patch=1;pnum=0 \
            file://gcc43x-fix.patch;patch=1 \
-           file://armv7a.diff;patch=1 \
-           file://acinclude.m4"
+           file://armv7a.diff;patch=1"
index a6475ea..e021efd 100644 (file)
@@ -1,25 +1,9 @@
 require oprofile.inc
 
-RDEPENDS += "binutils-symlinks"
-RRECOMMENDS += "kernel-vmlinux"
-PR = "r3"
+PR = "${INC_PR}.0"
 
-SRC_URI = "\
-       ${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+SRC_URI += "\
        file://opjitconv-execvp-fix.diff;patch=1 \
        file://0.9.4-armv7a.diff;patch=1 \
-       file://acinclude.m4 \
        "
 
-do_stage () {
-       # As of 0.9.4 there is a libopagent library to compile and link against.
-       autotools_stage_all
-}
-
-PACKAGES = "${PN}-dev ${PN}-doc ${PN}-dbg ${PN}"
-
-FILES_${PN}-dev += "\
-       ${libdir}/oprofile/lib*.so \
-       ${libdir}/oprofile/lib*.a \
-       ${libdir}/oprofile/lib*.la \
-"
index d896240..066eb05 100644 (file)
@@ -1,27 +1,4 @@
 require oprofile.inc
 
-RDEPENDS += "binutils-symlinks"
-RRECOMMENDS += "kernel-vmlinux"
-PR = "r3"
+PR = "${INC_PR}.0"
 
-SRC_URI = "\
-       ${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
-       file://acinclude.m4 \
-       "
-
-do_stage () {
-       # As of 0.9.4 there is a libopagent library to compile and link against.
-       autotools_stage_all
-}
-
-PACKAGES = "${PN}-dev ${PN}-doc ${PN}-dbg ${PN}"
-
-FILES_${PN} += "\
-       ${libdir}/oprofile/libopagent.so.* \
-"
-
-FILES_${PN}-dev += "\
-       ${libdir}/oprofile/lib*.so \
-       ${libdir}/oprofile/lib*.a \
-       ${libdir}/oprofile/lib*.la \
-"