automake: update to 1.11.1
authorGrazvydas Ignotas <notasas@gmail.com>
Tue, 30 Sep 2014 21:43:06 +0000 (00:43 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Tue, 30 Sep 2014 21:44:29 +0000 (00:44 +0300)
conf/distro/include/angstrom-2008-preferred-versions.inc
recipes/automake/automake-1.11.1/0001-py-compile-compile-only-optimized-byte-code.patch [new file with mode: 0644]
recipes/automake/automake-1.11.1/automake-dont-execute-perl.patch [new file with mode: 0644]
recipes/automake/automake.inc
recipes/automake/automake_1.11.1.bb

index ee908ff..074dd02 100644 (file)
@@ -2,7 +2,7 @@ ANGSTROM_QT_VERSION ?= "4.6.2"
 
 PREFERRED_VERSION_autoconf = "2.65"
 PREFERRED_VERSION_autoconf-native = "2.65"
-PREFERRED_VERSION_automake-native = "1.10.3"
+PREFERRED_VERSION_automake-native = "1.11.1"
 PREFERRED_VERSION_busybox      = "1.13.2"
 PREFERRED_VERSION_cairo                = "1.8.10"
 PREFERRED_VERSION_dbus                 = "1.2.22"
diff --git a/recipes/automake/automake-1.11.1/0001-py-compile-compile-only-optimized-byte-code.patch b/recipes/automake/automake-1.11.1/0001-py-compile-compile-only-optimized-byte-code.patch
new file mode 100644 (file)
index 0000000..1eca0a8
--- /dev/null
@@ -0,0 +1,42 @@
+upstream: OE-only
+
+From 4f84894b3df47ce797100f25d2d79f08bb27cd0d Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@opendreambox.org>
+Date: Thu, 14 Oct 2010 12:25:50 +0200
+Subject: [PATCH] py-compile: compile only optimized byte code
+
+---
+ lib/py-compile |   17 -----------------
+ 1 files changed, 0 insertions(+), 17 deletions(-)
+
+diff --git a/lib/py-compile b/lib/py-compile
+index 3f9d05b..101c814 100755
+--- a/lib/py-compile
++++ b/lib/py-compile
+@@ -101,23 +101,6 @@ else
+     filetrans="filepath = os.path.normpath('$destdir' + os.sep + path)"
+ fi
+-$PYTHON -c "
+-import sys, os, py_compile
+-
+-files = '''$files'''
+-
+-sys.stdout.write('Byte-compiling python modules...\n')
+-for file in files.split():
+-    $pathtrans
+-    $filetrans
+-    if not os.path.exists(filepath) or not (len(filepath) >= 3
+-                                            and filepath[-3:] == '.py'):
+-          continue
+-    sys.stdout.write(file)
+-    sys.stdout.flush()
+-    py_compile.compile(filepath, filepath + 'c', path)
+-sys.stdout.write('\n')" || exit $?
+-
+ # this will fail for python < 1.5, but that doesn't matter ...
+ $PYTHON -O -c "
+ import sys, os, py_compile
+-- 
+1.7.0.4
+
diff --git a/recipes/automake/automake-1.11.1/automake-dont-execute-perl.patch b/recipes/automake/automake-1.11.1/automake-dont-execute-perl.patch
new file mode 100644 (file)
index 0000000..52f0441
--- /dev/null
@@ -0,0 +1,19 @@
+We don't patch configure.ac as aclocal.m4 has a dependency upon it, which
+breaks compilation.
+
+diff -ur automake-1.11.1.orig/configure automake-1.11.1/configure
+--- automake-1.11.1.orig/configure     2009-12-09 04:45:46.000000000 +1030
++++ automake-1.11.1/configure  2010-12-01 14:01:54.000000000 +1030
+@@ -2303,12 +2303,6 @@
+ if test -z "$PERL"; then
+    as_fn_error "perl not found" "$LINENO" 5
+ fi
+-$PERL -e 'require 5.006;' || {
+-   as_fn_error "perl 5.6 or better is required; perl 5.8.2 or better
+-is recommended.  If you have several perl versions
+-installed, select the one Automake should use using
+-  ./configure PERL=/path/to/perl" "$LINENO" 5
+-}
+ # We require ithreads support, and version 5.7.2 for CLONE.
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $PERL supports ithreads" >&5
index e378c04..bc58162 100644 (file)
@@ -3,7 +3,9 @@ LICENSE = "GPL"
 HOMEPAGE = "http://www.gnu.org/software/automake/"
 SECTION = "devel"
 DEPENDS_virtclass-native = "autoconf-native"
-RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
+#DEPENDS_virtclass-native = "autoconf-native perl-native"
+RDEPENDS_automake-native = "autoconf-native perl-native"
+#RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
 RDEPENDS_automake += "\
     autoconf \
     perl \
@@ -29,25 +31,27 @@ RDEPENDS_automake += "\
     perl-module-text-parsewords \
     perl-module-vars "
 SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2;name=automake"
-INC_PR = "r3"
+INC_PR = "r5"
 AUTOMAKE_API = "${@".".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
 
 inherit autotools
 
 FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
 
-do_configure_prepend () {
-       if ${@['true', 'false'][bb.data.inherits_class('native', d)]}
-       then
-               export ac_cv_path_PERL="${ac_cv_path_PERL=${bindir}/perl}"
-       fi
+do_configure_append() {
 }
 
 do_install_append () {
        autotools_do_install
+       # replace paths to STAGING_BINDIR_NATIVE/perl with ${bindir}/perl
+       sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/*
        ln -sf aclocal-${AUTOMAKE_API} ${D}${bindir}/aclocal
        ln -sf automake-${AUTOMAKE_API} ${D}${bindir}/automake
        install -d ${D}${datadir}/aclocal
 }
 
+do_install_append_pn-automake(){
+       sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/*
+}
+
 BBCLASSEXTEND = "native"
index 9b363b9..b6ed09a 100644 (file)
@@ -1,4 +1,8 @@
 require automake.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.2"
 
-DEFAULT_PREFERENCE = "-1"
+SRC_URI += "file://0001-py-compile-compile-only-optimized-byte-code.patch;patch=1 \
+               file://automake-dont-execute-perl.patch;patch=1"
+
+SRC_URI[automake.md5sum] = "c2972c4d9b3e29c03d5f2af86249876f"
+SRC_URI[automake.sha256sum] = "5b159d3c0e0a1f87de71b68bcb9f1a1c49e9e71749c9b723f17e2e1e0295c7ae"