e-libs: yank do_install() in all -native packages or else our precously crafted foo...
authorMichael Lauer <mickey@vanille-media.de>
Mon, 8 Aug 2005 21:54:08 +0000 (21:54 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 8 Aug 2005 21:54:08 +0000 (21:54 +0000)
overridden with what becomes foo-config-native... grrrr!

packages/curl/curl-native_7.14.0.bb
packages/ecore/ecore-native_0.9.9.013.bb
packages/edb/edb-native_1.0.5.004.bb
packages/edje/edje-native_0.5.0.013.bb
packages/eet/eet-native_0.9.10.013.bb
packages/eet/eet_0.9.10.013.bb
packages/evas/evas-native_0.9.9.013.bb
packages/imlib2/imlib2-native_1.2.1.004.bb

index 7b99c7c..0fc2e14 100644 (file)
@@ -1,3 +1,7 @@
 include curl_${PV}.bb
 inherit native
 
+do_install() {
+       :
+}
+
index cd60c15..4ead109 100644 (file)
@@ -16,3 +16,7 @@ do_stage () {
        install -m 0644 ${S}/src/lib/ecore/Ecore_Data.h ${STAGING_INCDIR}/
        install -m 0644 ${S}/ecore.m4 ${STAGING_DATADIR}/aclocal/
 }
+
+do_install() {
+       :
+}
index b570683..59cb8da 100644 (file)
@@ -1,16 +1,14 @@
-DESCRIPTION = "EDB is a database convenience library wrapped around the \
-Berkeley DB 2.7.7 by Sleepycat Software."
-LICENSE = "BSD"
-HOMEPAGE = "http://www.enlightenment.org"
-MAINTAINER = "Carsten Haitzler (Rasterman) <raster@rasterman.com>"
-SECTION = "e/libs"
-PRIORITY = "optional"
 include edb_${PV}.bb
 inherit native
 DEPENDS = "zlib-native"
 
 do_stage () {
-  install -m 0755 tools/.libs/edb_ed ${STAGING_BINDIR}
-  oe_libinstall -C src libedb ${STAGING_LIBDIR}/
-  install -m 0644 ${S}/src/Edb.h ${STAGING_INCDIR}/
+       install -m 0755 tools/.libs/edb_ed ${STAGING_BINDIR}
+       oe_libinstall -C src libedb ${STAGING_LIBDIR}/
+       install -m 0644 ${S}/src/Edb.h ${STAGING_INCDIR}/
 }
+
+do_install() {
+       :
+}
+
index b3c24a6..dd0ca2b 100644 (file)
@@ -16,3 +16,8 @@ do_stage() {
                install -m 0755 src/bin/$i ${STAGING_BINDIR}
        done
 }
+
+do_install() {
+       :
+}
+
index b08b724..81f0a34 100644 (file)
@@ -1,10 +1,3 @@
-DESCRIPTION = "EET is a tiny library designed to write an \
-arbitary set of chunks of data to a file and optionally compress \
-each chunk (very much like a zip file) and allow fast \
-random-access reading of the file later on."
-HOMEPAGE = "http://www.enlightenment.org"
-MAINTAINER = "Carsten Haitzler (Rasterman) <raster@rasterman.com>"
-SECTION = "e/libs"
 PRIORITY = "optional"
 include eet_${PV}.bb
 inherit native
@@ -12,7 +5,11 @@ DEPENDS = "zlib-native jpeg-native"
 LICENSE = "BSD"
 
 do_stage () {
-  install -m 0755 src/bin/.libs/eet ${STAGING_BINDIR}
-  oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
-  install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
+       install -m 0755 src/bin/.libs/eet ${STAGING_BINDIR}
+       oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
+       install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+       :
 }
index 2d62a6e..c2a7296 100644 (file)
@@ -9,19 +9,14 @@ DEPENDS = "zlib jpeg"
 PR = "r0"
 LICENSE = "BSD"
 
-do_prepsources () {
-  make clean distclean || true
-}
-addtask prepsources after do_fetch before do_unpack
-
 SRC_URI = "http://enlightenment.freedesktop.org/files/eet-${PV}.tar.gz"
 S = "${WORKDIR}/eet-${PV}"
 
 inherit autotools pkgconfig binconfig
 
 do_stage () {
-  oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
-  install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
+       oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
+       install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
 }
 
 FILES_${PN} = "${libdir}/libeet*.so*"
index ce45eed..ea23901 100644 (file)
@@ -13,4 +13,7 @@ do_stage () {
         oe_libinstall -C src/lib libevas ${STAGING_LIBDIR}/
 }
 
-#FIXME: Conflicts with zlib-devel on the build machine. Remove it and it builds.
+do_install() {
+       :
+}
+
index e3a46c4..b4310c2 100644 (file)
@@ -4,3 +4,8 @@ DEPENDS = "freetype-native libpng-native jpeg-native"
 
 EXTRA_OECONF = "--disable-mmx \
                 --without-x"
+
+do_install() {
+       :
+}
+