groff-1.19.2: avoid running install-info when installing the package
authorRicardo Salveti de Araujo <ricardo.salveti@openbossa.org>
Sat, 31 Oct 2009 20:10:02 +0000 (20:10 +0000)
committerKhem Raj <raj.khem@gmail.com>
Sat, 27 Mar 2010 21:50:38 +0000 (14:50 -0700)
Otherwise the package will add the usr/share/info/dir file and can
conflict with other problematically packages.

Solution based on debian rules provided by the debian package.

Signed-off-by: Ricardo Salveti de Araujo <ricardo.salveti@openbossa.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/groff/groff_1.19.2.bb

index 5598263..03752fa 100644 (file)
@@ -1,18 +1,20 @@
 DESCRIPTION = "GNU roff"
 SECTION = "base"
 LICENSE = "GPL"
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "http://ftp.gnu.org/gnu/groff/groff-${PV}.tar.gz \
                   file://Makefile.in.patch;patch=1 \
                   file://Makefile.sub.patch;patch=1 \
                   file://groff.patch;patch=1"
 
+inherit autotools
+
 PARALLEL_MAKE = ""
 # prefix and exec-prefix are broken and the .in file is broken too
 # and can't be autoreconf'ed, so specify every dir
 EXTRA_OECONF="--without-x --prefix=${D} --exec-prefix=${D} --bindir=${D}${bindir} --datadir=${D}${datadir} --mandir=${D}${datadir}/man --infodir=${D}${datadir}/info --with-appresdir=${D}${datadir}"
-inherit autotools
+EXTRA_OEMAKE = "INSTALL_INFO=:"
 
 do_configure() {
        oe_runconf