libgsm0710mux: move configuration to fso-abyss; remove 3d7k which will never see...
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Fri, 26 Feb 2010 20:14:06 +0000 (21:14 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Fri, 26 Feb 2010 20:14:06 +0000 (21:14 +0100)
recipes/freesmartphone/fso-abyss/fso-abyss.conf [moved from recipes/freesmartphone/libgsm0710mux/abyss.conf with 100% similarity]
recipes/freesmartphone/fso-abyss/om-gta01/fso-abyss.conf [new file with mode: 0644]
recipes/freesmartphone/fso-abyss/om-gta02/fso-abyss.conf [new file with mode: 0644]
recipes/freesmartphone/fso-abyss_git.bb
recipes/freesmartphone/libgsm0710mux/om-3d7k/abyss.conf [deleted file]
recipes/freesmartphone/libgsm0710mux/om-gta01/abyss.conf [deleted file]
recipes/freesmartphone/libgsm0710mux/om-gta02/abyss.conf [deleted file]
recipes/freesmartphone/libgsm0710mux_git.bb

diff --git a/recipes/freesmartphone/fso-abyss/om-gta01/fso-abyss.conf b/recipes/freesmartphone/fso-abyss/om-gta01/fso-abyss.conf
new file mode 100644 (file)
index 0000000..971e3bb
--- /dev/null
@@ -0,0 +1,42 @@
+[logging]
+# Log level: DEBUG, INFO (default), WARNING, ERROR
+# Override via environment as FSO_LOG_LEVEL
+log_level = INFO
+# Where to log to: none (default), stderr, stderr:colors, file, syslog
+# Override via environment as FSO_LOG_TO
+log_to = file
+# Log Destination (valid only for log_to = file)
+# Override via environment as FSO_LOG_DESTINATION
+log_destination = /var/log/fso-abyss.log
+
+[libgsm0710mux]
+log_level = INFO
+log_to = file
+log_destination = /var/log/libgsm0710mux.log
+
+# Set to 1, when the first AllocChannel request should open a new MUX session
+muxer_autoopen = 1
+# Set to 1, when the last ReleaseChannel closes the MUX session
+muxer_autoclose = 1
+
+# Communication means
+device_type = serial
+# Communication port
+device_port = /dev/ttySAC0
+# Port speed
+device_speed = 115200
+# MUX mode, set to 0 for 07.10 basic multiplexing, to 1 for advanced mode
+device_mux_mode = 1
+# set maximum 07.10 frame size
+device_mux_framesize = 89
+
+# Set wakeup threshold for device (in seconds) or 0 to disable
+device_wakeup_threshold = 5
+# Set wakeup time for device (in milliseconds)
+device_wakeup_waitms = 250
+
+# DEBUG: Whether to ignore MUX mode
+session_debug_leave_mux_alone = 0
+# DEBUG: Whether to ignore FC mode
+session_debug_leave_fc_alone = 0
+
diff --git a/recipes/freesmartphone/fso-abyss/om-gta02/fso-abyss.conf b/recipes/freesmartphone/fso-abyss/om-gta02/fso-abyss.conf
new file mode 100644 (file)
index 0000000..971e3bb
--- /dev/null
@@ -0,0 +1,42 @@
+[logging]
+# Log level: DEBUG, INFO (default), WARNING, ERROR
+# Override via environment as FSO_LOG_LEVEL
+log_level = INFO
+# Where to log to: none (default), stderr, stderr:colors, file, syslog
+# Override via environment as FSO_LOG_TO
+log_to = file
+# Log Destination (valid only for log_to = file)
+# Override via environment as FSO_LOG_DESTINATION
+log_destination = /var/log/fso-abyss.log
+
+[libgsm0710mux]
+log_level = INFO
+log_to = file
+log_destination = /var/log/libgsm0710mux.log
+
+# Set to 1, when the first AllocChannel request should open a new MUX session
+muxer_autoopen = 1
+# Set to 1, when the last ReleaseChannel closes the MUX session
+muxer_autoclose = 1
+
+# Communication means
+device_type = serial
+# Communication port
+device_port = /dev/ttySAC0
+# Port speed
+device_speed = 115200
+# MUX mode, set to 0 for 07.10 basic multiplexing, to 1 for advanced mode
+device_mux_mode = 1
+# set maximum 07.10 frame size
+device_mux_framesize = 89
+
+# Set wakeup threshold for device (in seconds) or 0 to disable
+device_wakeup_threshold = 5
+# Set wakeup time for device (in milliseconds)
+device_wakeup_waitms = 250
+
+# DEBUG: Whether to ignore MUX mode
+session_debug_leave_mux_alone = 0
+# DEBUG: Whether to ignore FC mode
+session_debug_leave_fc_alone = 0
+
index dc8cbf8..e333546 100644 (file)
@@ -9,9 +9,32 @@ PR = "r0"
 
 SRC_URI = "\
   ${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master \
+  file://fso-abyss.conf \
 "
 S = "${WORKDIR}/git"
 
 inherit autotools
 
-FILES_${PN} += "${datadir}"
+do_install_append() {
+       install -d ${D}${sysconfdir}
+       install -m 0644 ${WORKDIR}/fso-abyss.conf ${D}${sysconfdir}/
+}
+
+PACKAGES =+ "${PN}-config"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+
+RRECOMMENDS_${PN} = "${PN}-config"
+
+FILES_${PN}-config = "\
+  ${sysconfdir}/fso-abyss.conf \
+"
+
+CONFFILES_${PN}-config = "\
+  ${sysconfdir}/fso-abyss.conf \
+"
+
+PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"
+
+
+
diff --git a/recipes/freesmartphone/libgsm0710mux/om-3d7k/abyss.conf b/recipes/freesmartphone/libgsm0710mux/om-3d7k/abyss.conf
deleted file mode 100644 (file)
index 4863014..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-[omuxerd]
-# set to 1, when the first AllocChannel request opens a session
-autoopen = 1
-# set to 1, when the last ReleaseChannel closes the session
-autoclose = 1
-# set to 1, when closing the session should close the program
-autoexit = 1
-
-[session]
-# set 0 for 07.10 basic multiplexing, 1 for advanced
-mode = 0
-# set maximum 07.10 frame size
-framesize = 98
-# configure modem port
-port = /dev/ttySAC1
-speed = 115200
diff --git a/recipes/freesmartphone/libgsm0710mux/om-gta01/abyss.conf b/recipes/freesmartphone/libgsm0710mux/om-gta01/abyss.conf
deleted file mode 100644 (file)
index 67da210..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-[omuxerd]
-autoopen = 1
-autoclose = 1
-autoexit = 1
-
-[session]
-mode = 1
-framesize = 98
-port = /dev/ttySAC0
-speed = 115200
-
-[device]
-wakeup_threshold = 6
-wakeup_waitms = 200
-
diff --git a/recipes/freesmartphone/libgsm0710mux/om-gta02/abyss.conf b/recipes/freesmartphone/libgsm0710mux/om-gta02/abyss.conf
deleted file mode 100644 (file)
index 67da210..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-[omuxerd]
-autoopen = 1
-autoclose = 1
-autoexit = 1
-
-[session]
-mode = 1
-framesize = 98
-port = /dev/ttySAC0
-speed = 115200
-
-[device]
-wakeup_threshold = 6
-wakeup_waitms = 200
-
index 6944687..71c7f6f 100644 (file)
@@ -8,29 +8,7 @@ PR = "r0"
 
 SRC_URI = "\
   ${FREESMARTPHONE_GIT}/libgsm0710mux;protocol=git;branch=master \
-  file://abyss.conf \
 "
 S = "${WORKDIR}/git"
 
 inherit autotools_stage pkgconfig vala
-
-do_install_append() {
-       install -d ${D}${sysconfdir}
-       install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
-}
-
-PACKAGES =+ "${PN}-config"
-
-FILES_${PN} += "${sysconfdir} ${datadir}"
-
-RRECOMMENDS_${PN} = "${PN}-config"
-
-FILES_${PN}-config = "\
-  ${sysconfdir}/abyss.conf \
-"
-
-CONFFILES_${PN}-config = "\
-  ${sysconfdir}/abyss.conf \
-"
-
-PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"