gnuchess: add launcher and icon, thanks to Graziano Sorbaioli
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 18 Mar 2010 13:40:24 +0000 (14:40 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Thu, 18 Mar 2010 14:04:53 +0000 (15:04 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/gnuchess/files/gnuchess.desktop [new file with mode: 0644]
recipes/gnuchess/files/gnuchess.png [new file with mode: 0644]
recipes/gnuchess/files/gnuchess.sh [new file with mode: 0644]
recipes/gnuchess/gnuchess_5.021.bb

diff --git a/recipes/gnuchess/files/gnuchess.desktop b/recipes/gnuchess/files/gnuchess.desktop
new file mode 100644 (file)
index 0000000..5b2eb40
--- /dev/null
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=GNU Chess
+Comment=Chess game of the GNU Project
+Encoding=UTF-8
+Version=4.2.7
+Type=Application
+Exec=/usr/bin/gnuchess.sh 
+Terminal=false
+Categories=Game;
+X-MB-SingleInstance=true
+Icon=gnuchess
+
diff --git a/recipes/gnuchess/files/gnuchess.png b/recipes/gnuchess/files/gnuchess.png
new file mode 100644 (file)
index 0000000..a0d2e5f
Binary files /dev/null and b/recipes/gnuchess/files/gnuchess.png differ
diff --git a/recipes/gnuchess/files/gnuchess.sh b/recipes/gnuchess/files/gnuchess.sh
new file mode 100644 (file)
index 0000000..2da7049
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+xboard -size Average -font 6x13 -coordFont 6x13 -clockFont 6x13 -fcp "/usr/bin/gnuchess -b- -e 100 -l- -f 1 -p-"
+
index 18c94bd..8d1afea 100644 (file)
@@ -3,11 +3,23 @@ SECTION = "console"
 PRIORITY = "optional"
 MAINTAINER = "Andreas Holzer <a.holzer@cheese.at>"
 LICENSE = "GPL"
-SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz" 
+PR = "r1"
+RSUGGESTS_${PN} = "xboard"
+SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz \
+           file://gnuchess.desktop \
+           file://gnuchess.png \
+           file://gnuchess.sh \
+" 
 S = "${WORKDIR}/chess-5.02/src"
 
 inherit autotools
 
 do_install() {
+        install -d ${D}${bindir}
+        install -d ${D}${datadir}/pixmaps/
+        install -d ${D}${datadir}/applications/
+        install -m 0755 ${WORKDIR}/gnuchess.sh ${D}${bindir}
+        install -m 0644 ${WORKDIR}/gnuchess.png  ${D}${datadir}/pixmaps/
+        install -m 0644 ${WORKDIR}/gnuchess.desktop  ${D}${datadir}/applications/
         install -D ${S}/gnuchess ${D}${bindir}/gnuchess
 }