xserver-xorg 1.7.3: add overlapped blit support for angstrom
authorKoen Kooi <koen@openembedded.org>
Tue, 29 Dec 2009 18:52:37 +0000 (19:52 +0100)
committerKoen Kooi <koen@openembedded.org>
Tue, 29 Dec 2009 18:59:12 +0000 (19:59 +0100)
* Needs support from pixman, so only enable this patch when you are sure your pixman supports it

recipes/xorg-xserver/xserver-xorg-1.7.3/hack-assume-pixman-supports-overlapped-blt.patch [new file with mode: 0644]
recipes/xorg-xserver/xserver-xorg_1.7.3.bb

diff --git a/recipes/xorg-xserver/xserver-xorg-1.7.3/hack-assume-pixman-supports-overlapped-blt.patch b/recipes/xorg-xserver/xserver-xorg-1.7.3/hack-assume-pixman-supports-overlapped-blt.patch
new file mode 100644 (file)
index 0000000..a947582
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/fb/fbcopy.c b/fb/fbcopy.c
+index 07eb663..ba394b7 100644
+--- a/fb/fbcopy.c
++++ b/fb/fbcopy.c
+@@ -91,8 +91,7 @@ fbCopyNtoN (DrawablePtr      pSrcDrawable,
+     while (nbox--)
+     {
+ #ifndef FB_ACCESS_WRAPPER /* pixman_blt() doesn't support accessors yet */
+-      if (pm == FB_ALLONES && alu == GXcopy && !reverse &&
+-          !upsidedown)
++      if (pm == FB_ALLONES && alu == GXcopy)
+       {
+           if (!pixman_blt ((uint32_t *)src, (uint32_t *)dst, srcStride, dstStride, srcBpp, dstBpp,
+                            (pbox->x1 + dx + srcXoff),
index 8f72741..6b28f76 100644 (file)
@@ -3,12 +3,15 @@ require xorg-xserver-common.inc
 DESCRIPTION = "the X.Org X server"
 DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
 PE = "2"
-PR = "r1"
+PR = "r2"
 
 SRC_URI += "file://sysroot_fix.patch;patch=1 \
             file://dolt-fix-1.7.0.patch;patch=1 \
             file://randr-support-1.7.0.patch;patch=1 \
            "
+
+SRC_URI_append_angstrom = " file://hack-assume-pixman-supports-overlapped-blt.patch;patch=1"
+
 do_install_prepend() {
         mkdir -p ${D}/${libdir}/X11/fonts
 }