gtk+: add some missed backport stuff
authorGrazvydas Ignotas <notasas@gmail.com>
Thu, 2 Oct 2014 00:59:44 +0000 (03:59 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Thu, 2 Oct 2014 00:59:44 +0000 (03:59 +0300)
recipes/gdk-pixbuf/gdk-pixbuf_2.30.8.bb
recipes/gtk+/gtk+_2.24.8.bb

index c3422d8..024147a 100644 (file)
@@ -73,6 +73,9 @@ python populate_packages_prepend () {
 }
 
 do_install_append_virtclass-native() {
+       GDK_PIXBUF_MODULEDIR=${D}${libdir}/gdk-pixbuf-2.0/2.10.0/loaders ${S}/gdk-pixbuf/gdk-pixbuf-query-loaders > ${D}${libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
+       sed -i -e 's#${D}##g' ${D}${libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
+
        find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
 
        create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \
index ab4a5b0..ba9fdf3 100644 (file)
@@ -12,7 +12,8 @@ SECTION = "libs"
 DEPENDS = "glib-2.0 pango atk jpeg libpng libxext libxcursor \
            gtk-doc-native docbook-utils-native libxrandr libgcrypt \
            libxdamage libxrender libxcomposite cairo gdk-pixbuf"
-DEPENDS_virtclass-native = "libpng-native atk-native pango-native cairo-native libxrender-native libxext-native libgcrypt-native"
+DEPENDS_virtclass-native = "libpng-native atk-native pango-native \
+          cairo-native libxrender-native libxext-native libgcrypt-native gdk-pixbuf-native"
 
 inherit autotools pkgconfig