packages/linux/linux-magicbox_2.6.19.2.bb: Add TARGET_VENDOR to the
authorStelios Koroneos <skoroneos@digital-opsis.com>
Wed, 23 May 2007 16:24:29 +0000 (16:24 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Wed, 23 May 2007 16:24:29 +0000 (16:24 +0000)
objcopy so that it supports distro's that use. It should make no
difference is TARGET_VENDOR is not set
it

packages/linux/linux-magicbox_2.6.19.2.bb

index f76d391..4e07abd 100644 (file)
@@ -1,7 +1,7 @@
 SECTION = "kernel"
 DESCRIPTION = "Linux kernel for Magicbox ver 1.1 and 2.0 router boards"
 LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
 DEPENDS = "u-boot"
 
 COMPATIBLE_MACHINE = "magicbox"
@@ -89,7 +89,7 @@ do_install_append () {
         install -d  ${DEPLOY_DIR}/images
         install -m 0755 arch/ppc/boot/images/zImage.elf ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
         install -m 0755 vmlinux ${DEPLOY_DIR}/images/
-        powerpc-${TARGET_OS}-objcopy -O binary -R .note -R .comment -S ${DEPLOY_DIR}/images/vmlinux ${DEPLOY_DIR}/images/linux.bin
+        powerpc${TARGET_VENDOR}-${TARGET_OS}-objcopy -O binary -R .note -R .comment -S ${DEPLOY_DIR}/images/vmlinux ${DEPLOY_DIR}/images/linux.bin
         gzip -f -9 ${DEPLOY_DIR}/images/linux.bin
         cp -a ${DEPLOY_DIR}/images/linux.bin.gz ${DEPLOY_DIR}/images/linux-${PV}-${MACHINE}-${DATETIME}.bin.gz        
         mkimage -A ppc -O linux -T kernel -C gzip -a 00000000 -e 00000000 -n "magicbox"-${PV} \