yasr_0.6.9.bb: New recipe
authorKhem Raj <raj.khem@gmail.com>
Mon, 16 Feb 2009 07:39:43 +0000 (23:39 -0800)
committerKhem Raj <raj.khem@gmail.com>
Mon, 16 Feb 2009 07:39:43 +0000 (23:39 -0800)
conf/checksums.ini
packages/yasr/files/yasr-0.6.9-gcc43.patch [new file with mode: 0644]
packages/yasr/files/yasr-0.6.9-remove-m4.patch [new file with mode: 0644]
packages/yasr/yasr_0.6.9.bb [new file with mode: 0644]

index 17ffc72..5b8e2ed 100644 (file)
@@ -25178,6 +25178,10 @@ sha256=5beb94529cc7ac79b17e354f9b03aea311f5af17be5d48bc39e6f1db5059f70f
 md5=43c606bbd27c500b0022471ed704ab78
 sha256=014e744f40c773bf225328bce1ca80f5dde4835c1f6671e989a4f8c4ed24555f
 
+[http://downloads.sourceforge.net/yasr/yasr-0.6.9.tar.gz]
+md5=daec224676fb2db5a1936b399f559473
+sha256=41f17cfab8e88824a8dc1476602a0944b9030a8f8da2538a7a6549e3534e3bdf
+
 [http://download.devbase.at/voip/yeaphone-0.1.tar.gz]
 md5=476552b3b88b651ba161d22c1db5314d
 sha256=2f596ef4c57e29708d6246949289341d9f9756d162bf49e89f0828180329aa51
diff --git a/packages/yasr/files/yasr-0.6.9-gcc43.patch b/packages/yasr/files/yasr-0.6.9-gcc43.patch
new file mode 100644 (file)
index 0000000..ee2b1a6
--- /dev/null
@@ -0,0 +1,26 @@
+diff -NrU5 yasr-0.6.9.orig/yasr/yasr.h yasr-0.6.9/yasr/yasr.h
+--- yasr-0.6.9.orig/yasr/yasr.h        2008-06-29 01:23:44.000000000 +0200
++++ yasr-0.6.9/yasr/yasr.h     2008-06-29 01:37:00.000000000 +0200
+@@ -306,22 +306,10 @@
+ extern void opt_say(int num, int flag);
+ extern void opt_set(int num, void *val);
+ extern void opt_queue_empty(int ll);
+ extern void opt_write(FILE * fp);
+-/* openpty.c prototypes */
+-extern int openpty(int *, int *, char *, struct termios *, struct winsize *);
+-
+-/* cfmakeraw.c prototypes */
+-extern void cfmakeraw(struct termios *);
+-
+-/* login_tty.c prototypes */
+-extern int login_tty(int);
+-
+-/* forkpty.c prototypes */
+-extern int forkpty(int *, char *, struct termios *, struct winsize *);
+-
+ /* tbc - Would it be more efficient to ensure that "blank" grids always held
+    ascii 0x20 rather than ascii 0x00? */
+ #define y_isblank(ch) ((ch & 0xdf) == 0)
+ #define cblank(r, c)  ((win->row[r][c] & 0xdf) == 0)
+ #define ttssend(x)    if (x) tts_send(x, strlen(x))
diff --git a/packages/yasr/files/yasr-0.6.9-remove-m4.patch b/packages/yasr/files/yasr-0.6.9-remove-m4.patch
new file mode 100644 (file)
index 0000000..fa05f07
--- /dev/null
@@ -0,0 +1,29 @@
+diff -Naur yasr-0.6.9.orig/Makefile.am yasr-0.6.9/Makefile.am
+--- yasr-0.6.9.orig/Makefile.am        2008-02-02 06:44:05.000000000 -0600
++++ yasr-0.6.9/Makefile.am     2009-02-06 08:37:07.000000000 -0600
+@@ -7,7 +7,6 @@
+ SUBDIRS = \
+       $(yasr_DDIRS) \
+-m4 \
+       po
+ pkgdata_DATA = \
+@@ -25,4 +24,3 @@
+       README-fr \
+       README-ru
+-ACLOCAL_AMFLAGS = -I m4
+diff -Naur yasr-0.6.9.orig/configure.in yasr-0.6.9/configure.in
+--- yasr-0.6.9.orig/configure.in       2008-02-02 07:09:04.000000000 -0600
++++ yasr-0.6.9/configure.in    2009-02-06 08:36:43.000000000 -0600
+@@ -59,8 +59,7 @@
+ AM_GNU_GETTEXT(external)
+ AM_GNU_GETTEXT_VERSION([0.17])
+-AC_OUTPUT([ m4/Makefile 
+-Makefile
++AC_OUTPUT([ Makefile 
+ yasr/Makefile
+ acclogin/Makefile
+ po/Makefile.in
diff --git a/packages/yasr/yasr_0.6.9.bb b/packages/yasr/yasr_0.6.9.bb
new file mode 100644 (file)
index 0000000..4d6fd28
--- /dev/null
@@ -0,0 +1,16 @@
+# Copyright (C) 2009 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Yet Another Screen Reader(yasr) is a \
+              general-purpose console screen reader"
+HOMEPAGE = "http://yasr.sf.net"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+SUGGESTS = "speech-dispatcher"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/yasr/yasr-${PV}.tar.gz \
+          file://yasr-0.6.9-gcc43.patch;patch=1 \
+          file://yasr-0.6.9-remove-m4.patch;patch=1 \
+         "
+
+inherit autotools