konqueror-embedded: don't use kde-config while configuring.
authorMichael Krelin <hacker@klever.net>
Fri, 15 Jun 2007 21:41:03 +0000 (21:41 +0000)
committerMichael Krelin <hacker@klever.net>
Fri, 15 Jun 2007 21:41:03 +0000 (21:41 +0000)
packages/konqueror/konqueror-embedded-20070212/dont-use-kde-config.patch [new file with mode: 0644]
packages/konqueror/konqueror-embedded_20070212.bb

diff --git a/packages/konqueror/konqueror-embedded-20070212/dont-use-kde-config.patch b/packages/konqueror/konqueror-embedded-20070212/dont-use-kde-config.patch
new file mode 100644 (file)
index 0000000..a5e8b84
--- /dev/null
@@ -0,0 +1,45 @@
+diff --git a/devscripts/acinclude.m4.in.qt2 b/devscripts/acinclude.m4.in.qt2
+index 500e75f..e8d9758 100644
+--- a/devscripts/acinclude.m4.in.qt2
++++ b/devscripts/acinclude.m4.in.qt2
+@@ -4937,31 +4937,11 @@ AC_DEFUN([KDE_SET_PREFIX],
+   AC_PREFIX_DEFAULT(${KDEDIR:-the kde prefix})
+   KDE_SET_DEFAULT_BINDIRS
+-  if test "x$prefix" = "xNONE"; then
+-    dnl no prefix given: look for kde-config in the PATH and deduce the prefix from it
+-    KDE_FIND_PATH(kde-config, KDECONFIG, [$kde_default_bindirs], [KDE_MISSING_PROG_ERROR(kde-config)], [], prepend)
+-  else
+-    dnl prefix given: look for kde-config, preferrably in prefix, otherwise in PATH
+-    kde_save_PATH="$PATH"
+-    PATH="$exec_prefix/bin:$prefix/bin:$PATH"
+-    KDE_FIND_PATH(kde-config, KDECONFIG, [$kde_default_bindirs], [KDE_MISSING_PROG_ERROR(kde-config)], [], prepend)
+-    PATH="$kde_save_PATH"
+-  fi
+-
+-  kde_libs_prefix=`$KDECONFIG --prefix`
+-  if test -z "$kde_libs_prefix" || test ! -x "$kde_libs_prefix"; then
+-       AC_MSG_ERROR([$KDECONFIG --prefix outputed the non existant prefix '$kde_libs_prefix' for kdelibs.
+-                    This means it has been moved since you installed it.
+-                    This won't work. Please recompile kdelibs for the new prefix.
+-                    ])
+-  fi
+-  kde_libs_htmldir=`$KDECONFIG --install html --expandvars`
+-  kde_libs_suffix=`$KDECONFIG --libsuffix`
+   AC_MSG_CHECKING([where to install])
+   if test "x$prefix" = "xNONE"; then
+     prefix=$kde_libs_prefix
+-    AC_MSG_RESULT([$prefix (as returned by kde-config)])
++    AC_MSG_RESULT([$prefix (as NOT returned by kde-config)])
+   else
+     dnl --prefix was given. Compare prefixes and warn (in configure.in.bot.end) if different
+     given_prefix=$prefix
+@@ -4973,7 +4953,6 @@ AC_DEFUN([KDE_SET_PREFIX],
+   exec_prefix=`echo "$exec_prefix" | sed 's,//*,/,g' | sed -e 's,/$,,'`
+   given_prefix=`echo "$given_prefix" | sed 's,//*,/,g' | sed -e 's,/$,,'`
+-  AC_SUBST(KDECONFIG)
+   AC_SUBST(kde_libs_prefix)
+   AC_SUBST(kde_libs_htmldir)
index 31eebaa..0c2107b 100644 (file)
@@ -11,6 +11,7 @@ PR = "r4"
 inherit autotools
 
 SRC_URI = "http://www.basyskom.de/uploads/175/35/kdenox_snapshot_Qt2_2007.02.12.tar.bz2 \
+          file://dont-use-kde-config.patch;patch=1 \
            file://konqe_new_opie.patch;patch=1 \
           file://konqe-kapplication.patch;patch=1"
 S = "${WORKDIR}/kdenox"