libxcb: look for xproto.xml in staging, not in the host environment
authorPhil Blundell <philb@gnu.org>
Fri, 12 Jun 2009 18:32:21 +0000 (19:32 +0100)
committerPhil Blundell <philb@gnu.org>
Fri, 12 Jun 2009 18:32:21 +0000 (19:32 +0100)
recipes/xcb/libxcb.inc
recipes/xcb/libxcb/configure.patch [new file with mode: 0644]

index 6e7bd5e..4029dec 100644 (file)
@@ -7,7 +7,8 @@ PARALLEL_MAKE = ""
 DEPENDS = "xcb-proto xproto libxau libxslt-native"
 # DEPENDS += "xsltproc-native gperf-native"
 
-SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2"
+SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
+        file://configure.patch;patch=1;pnum=0"
 
 PACKAGES =+ "libxcb-composite libxcb-damage libxcb-dpms libxcb-glx \
              libxcb-randr libxcb-record libxcb-render libxcb-res \
@@ -41,6 +42,8 @@ FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
 
 inherit autotools pkgconfig
 
+EXTRA_OECONF = "STAGING_DIR=${STAGING_DIR_HOST}"
+
 do_stage() {
        autotools_stage_all
 }
diff --git a/recipes/xcb/libxcb/configure.patch b/recipes/xcb/libxcb/configure.patch
new file mode 100644 (file)
index 0000000..2e39771
--- /dev/null
@@ -0,0 +1,11 @@
+--- configure.ac~      2006-11-23 15:33:01.000000000 +0000
++++ configure.ac       2009-06-12 19:10:47.000000000 +0100
+@@ -50,7 +50,7 @@
+ # Find the xcb-proto protocol descriptions
+ AC_MSG_CHECKING(XCBPROTO_XCBINCLUDEDIR)
+-XCBPROTO_XCBINCLUDEDIR=`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
++XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR}`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
+ AC_SUBST(XCBPROTO_XCBINCLUDEDIR)