ecore-native: disable curl again
authorKoen Kooi <koen@openembedded.org>
Mon, 29 Mar 2010 19:45:18 +0000 (21:45 +0200)
committerKoen Kooi <koen@openembedded.org>
Mon, 29 Mar 2010 19:45:37 +0000 (21:45 +0200)
* this avoids an error with curl internal checks that get triggered for some reason on 64 bit buildhosts

recipes/efl1/ecore_svn.bb

index 5262c0c..83b424f 100644 (file)
@@ -1,5 +1,5 @@
 require ecore.inc
-PR = "r9"
+PR = "r10"
 
 SRC_URI += "\
   file://iconv.patch;patch=1;maxrev=43996 \
@@ -7,7 +7,7 @@ SRC_URI += "\
   file://exit_uclibc.patch;patch=1 \
 "
 
-EXTRA_OECONF = "\
+ECORE_OECONF = "\
   --x-includes=${STAGING_INCDIR}/X11 \
   --x-libraries=${STAGING_LIBDIR} \
   --enable-simple-x11 \
@@ -24,7 +24,6 @@ EXTRA_OECONF = "\
   --enable-ecore-ipc \
   --enable-ecore-file \
   --enable-inotify \
-  --enable-curl \
   --disable-ecore-desktop \
   --disable-ecore-x-xcb \
   --disable-ecore-directfb \
@@ -36,12 +35,18 @@ EXTRA_OECONF = "\
   --disable-poll \
 "
 
-# List of options which were different in ecore-native, 
+EXTRA_OECONF = "${ECORE_OECONF} \
+                 --enable-curl \
+"
+
+EXTRA_OECONF_virtclass-native = "\
+                 ${ECORE_OECONF} \
+                 --disable-curl \
+"
+# List of options which were different in ecore-native,
 # I know it's SCM, but with missing -native.bb is much easier to check here
-#EXTRA_OECONF_virtclass-native = "\
 #                --disable-ecore-x \
 #                --enable-ecore-evas-fb \
 #                --disable-ecore-evas-x11-gl \
-#                --disable-curl \
 #                --disable-ecore-imf \
 #                --disable-ecore-imf_evas \