gpsd: Removed custom do_stage.
authorStanislav Brabec <utx@penguin.cz>
Wed, 4 Nov 2009 21:43:03 +0000 (21:43 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Wed, 4 Nov 2009 21:43:03 +0000 (21:43 +0000)
recipes/gpsd/gpsd.inc
recipes/gpsd/gpsd_2.38.bb

index 1022091..0bd2b20 100644 (file)
@@ -19,7 +19,7 @@ SRC_URI_append_om-gta01 = " \
            file://restart_gllin.sh \
 "
                           
-inherit autotools update-rc.d
+inherit autotools_stage update-rc.d
 
 INITSCRIPT_NAME = "gpsd"
 INITSCRIPT_PARAMS = "defaults 35"
@@ -39,12 +39,6 @@ do_install_prepend() {
     export HOST_SYS="${HOST_SYS}"
 }
 
-do_stage() {
-        oe_libinstall -so libgps ${STAGING_LIBDIR}
-        install -m 0644 ${S}/gps.h ${STAGING_INCDIR}
-        install -m 0644 ${S}/gpsd.h ${STAGING_INCDIR}
-}
-
 do_install_append() {
         install -d ${D}/${sysconfdir}/init.d
         install -d ${D}/dev
index 95260ff..fb7f57d 100644 (file)
@@ -1,5 +1,5 @@
 require gpsd.inc
 
-PR = "r0"
+PR = "r1"
 # make attempts to link gpspacket.so without waiting for all compiler tasks:
 PARALLEL_MAKE = ""