xorg-proto: let native packages depend on util-macros-native
authorHenning Heinold <heinold@inf.fu-berlin.de>
Thu, 1 Oct 2009 09:52:06 +0000 (11:52 +0200)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Fri, 2 Oct 2009 10:37:54 +0000 (12:37 +0200)
* adding xorg-proto-native.inc
* set DEPENDS and inherit native in it
* no version bump is needed

19 files changed:
recipes/xorg-proto/bigreqsproto-native_1.0.2.bb
recipes/xorg-proto/fixesproto-native_4.0.bb
recipes/xorg-proto/fontcacheproto-native_0.1.2.bb
recipes/xorg-proto/fontsproto-native_2.0.2.bb
recipes/xorg-proto/inputproto-native_1.4.2.bb
recipes/xorg-proto/inputproto-native_1.5.0.bb
recipes/xorg-proto/kbproto-native_1.0.3.bb
recipes/xorg-proto/renderproto-native_0.9.3.bb
recipes/xorg-proto/xcmiscproto-native_1.1.2.bb
recipes/xorg-proto/xextproto-native_7.0.2.bb
recipes/xorg-proto/xextproto-native_7.0.3.bb
recipes/xorg-proto/xextproto-native_7.0.5.bb
recipes/xorg-proto/xf86bigfontproto-native_1.1.2.bb
recipes/xorg-proto/xorg-proto-native.inc [new file with mode: 0644]
recipes/xorg-proto/xproto-native_7.0.10.bb
recipes/xorg-proto/xproto-native_7.0.11.bb
recipes/xorg-proto/xproto-native_7.0.12.bb
recipes/xorg-proto/xproto-native_7.0.13.bb
recipes/xorg-proto/xproto-native_7.0.15.bb

index e864171..acd4d7c 100644 (file)
@@ -1,7 +1,6 @@
 require bigreqsproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "bigreqsproto"
-
-inherit native
index 927e004..ddc26db 100644 (file)
@@ -1,7 +1,6 @@
 require fixesproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "fixesproto"
-
-inherit native
index f6df67f..58c13aa 100644 (file)
@@ -1,7 +1,6 @@
 require fontcacheproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "fontcacheproto"
-
-inherit native
index 4371a07..b572229 100644 (file)
@@ -1,9 +1,8 @@
 require fontsproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "fontsproto"
 
 S = "${WORKDIR}/fontsproto-${PV}"
-
-inherit native
index 11e0dae..8e4c94e 100644 (file)
@@ -1,7 +1,6 @@
 require inputproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "inputproto"
-
-inherit native
index 11e0dae..8e4c94e 100644 (file)
@@ -1,7 +1,6 @@
 require inputproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "inputproto"
-
-inherit native
index 68c677c..cdb7c0e 100644 (file)
@@ -1,7 +1,6 @@
 require kbproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "kbproto"
-
-inherit native
index 8d83c99..879b95f 100644 (file)
@@ -1,7 +1,6 @@
 require renderproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "renderproto"
-
-inherit native
index 417a2aa..3289d19 100644 (file)
@@ -1,7 +1,6 @@
 require xcmiscproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "xcmiscproto"
-
-inherit native
index ff2bc4f..12a7832 100644 (file)
@@ -1,7 +1,6 @@
 require xextproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "xextproto"
-
-inherit native
index ff2bc4f..12a7832 100644 (file)
@@ -1,7 +1,6 @@
 require xextproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "xextproto"
-
-inherit native
index cdf1f09..12a7832 100644 (file)
@@ -1,9 +1,6 @@
 require xextproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "xextproto"
-
-inherit native
-
-DEPENDS += "util-macros-native"
index b0ac594..3f4618e 100644 (file)
@@ -1,7 +1,6 @@
 require xf86bigfontproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "xf86bigfontproto"
-
-inherit native
diff --git a/recipes/xorg-proto/xorg-proto-native.inc b/recipes/xorg-proto/xorg-proto-native.inc
new file mode 100644 (file)
index 0000000..100aca2
--- /dev/null
@@ -0,0 +1,2 @@
+inherit native
+DEPENDS = "util-macros-native"
index 88ed38e..ff8729d 100644 (file)
@@ -1,7 +1,6 @@
 require xproto_${PV}.bb
+require xorg-proto-native.inc
 
 PR = "r1"
 
 XORG_PN = "xproto"
-
-inherit native
index baae28e..0e2e5f9 100644 (file)
@@ -1,5 +1,4 @@
 require xproto_${PV}.bb
+require xorg-proto-native.inc
 
 XORG_PN = "xproto"
-
-inherit native
index 5dde8a7..d478f74 100644 (file)
@@ -1,3 +1,2 @@
 require xproto_${PV}.bb
-
-inherit native
+require xorg-proto-native.inc
index 5dde8a7..d478f74 100644 (file)
@@ -1,3 +1,2 @@
 require xproto_${PV}.bb
-
-inherit native
+require xorg-proto-native.inc
index baecb29..d478f74 100644 (file)
@@ -1,5 +1,2 @@
 require xproto_${PV}.bb
-
-inherit native
-
-DEPENDS += "util-macros-native"
+require xorg-proto-native.inc