openobex_1.5.bb: fix missing openobex.m4 file in staging.
authorMike Westerhof <mwester@dls.net>
Mon, 11 May 2009 04:04:49 +0000 (23:04 -0500)
committerMike Westerhof <mwester@dls.net>
Mon, 11 May 2009 04:04:49 +0000 (23:04 -0500)
recipes/openobex/openobex_1.5.bb

index ab69cf1..faa6c06 100644 (file)
@@ -5,6 +5,7 @@ SECTION = "libs"
 PROVIDES = "openobex-apps"
 DEPENDS = "libusb-compat bluez4"
 LICENSE = "GPL"
+PR = "r1"
 
 SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/openobex-${PV}.tar.gz \
            file://disable-cable-test.patch;patch=1 \
@@ -15,6 +16,11 @@ inherit autotools_stage binconfig pkgconfig
 EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
                 --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
 
+do_stage_append() {
+       install -d ${STAGING_DATADIR}/aclocal
+       install -m 0644 ${S}/openobex.m4 ${STAGING_DATADIR}/aclocal
+}
+
 PACKAGES += "openobex-apps"
 FILES_${PN} = "${libdir}/lib*.so.*"
 FILES_${PN}-dev += "${bindir}/openobex-config"