linux-ezx: sync a1200 and e6 changes with openezx svn, add more RP patches
authorKoen Kooi <koen@openembedded.org>
Sat, 22 Sep 2007 07:41:55 +0000 (07:41 +0000)
committerKoen Kooi <koen@openembedded.org>
Sat, 22 Sep 2007 07:41:55 +0000 (07:41 +0000)
packages/linux/linux-ezx-2.6.21/patches/Makefile.OpenEZX
packages/linux/linux-ezx-2.6.21/patches/a1200-eoc.patch
packages/linux/linux-ezx-2.6.21/patches/a1200-ts.patch
packages/linux/linux-ezx-2.6.21/patches/e6-eoc.patch
packages/linux/linux-ezx-2.6.21/patches/e6-ts.patch
packages/linux/linux-ezx-2.6.21/patches/ezx-pm.patch
packages/linux/linux-ezx-2.6.21/patches/index.html
packages/linux/linux-ezx-2.6.21/patches/series
packages/linux/linux-ezx_2.6.21.bb

index 7e7e0f2..c6d90c6 100755 (executable)
@@ -8,12 +8,18 @@
 # in your environment.
 #
 
-PHONES = a780 e680 a1200 e2 e6
+PHONES = a780 e680 a1200 e6 e2
 
 CROSS_COMPILE ?= /home/wyrm/ezx/dev/cross/bin/arm-angstrom-linux-gnueabi-
 QUILT_PATCHES ?= patches
 
+LV ?= ezxdev   # replace LOCALVERSION string
+J ?= 2         # simultaneous jobs
+SIG ?= 0       # BOOL sign md5sums file
+
 DATE = $(shell date +%Y%m%d)
+DEPLOY_SERVER ?= people.openezx.org
+DEPLOY_DIR ?= public_html/images/$(DATE)/
 
 all: $(foreach p, $(PHONES), zImage-$(p) modules-$(p).tar.gz)
 
@@ -21,8 +27,27 @@ zImages: $(foreach p, $(PHONES), zImage-$(p))
 
 modules: $(foreach p, $(PHONES), modules-$(p).tar.gz)
 
+config: $(foreach p, $(PHONES), config-$(p))
+
+config-%: $(QUILT_PATCHES)/defconfig-%
+       cp $<  .config
+       make ARCH=arm oldconfig
+       cp .config $<
+
+deploy: release
+       ssh $(DEPLOY_SERVER) \
+               mkdir -p $(DEPLOY_DIR)
+       scp ezxrelease-$(DATE).tar $(DEPLOY_SERVER):$(DEPLOY_DIR)
+       ssh $(DEPLOY_SERVER) \
+               cd $(DEPLOY_DIR)\; \
+               tar -xf ezxrelease-$(DATE).tar\; \
+               rm -f ezxrelease-$(DATE).tar
+
 release: $(foreach p, $(PHONES), tag-$(p))
-       cat md5sums.tmp | gpg --clearsign > md5sums
+       cp md5sums.tmp md5sums
+       test "$(SIG)" = "1" && \
+               cat md5sums.tmp | gpg --clearsign > md5sums \
+       ; echo
        tar -rf ezxrelease.tar md5sums
        rm -f md5sums.tmp md5sums
        mv ezxrelease.tar ezxrelease-$(DATE).tar
@@ -30,22 +55,23 @@ release: $(foreach p, $(PHONES), tag-$(p))
 tag-%: zImage-% modules-%.tar.gz
        p=$(patsubst tag-%,%,$@) && \
        tag=$(shell cat include/config/kernel.release)-$(DATE) && \
-       cp zImage-$$p zImage-$$tag-$$p && \
-       cp modules-$$p.tar.gz modules-$$tag-$$p.tar.gz && \
+       mv zImage-$$p zImage-$$tag-$$p && \
+       mv modules-$$p.tar.gz modules-$$tag-$$p.tar.gz && \
        tar -rf ezxrelease.tar zImage-$$tag-$$p modules-$$tag-$$p.tar.gz && \
        md5sum zImage-$$tag-$$p modules-$$tag-$$p.tar.gz >> md5sums.tmp && \
        rm -f zImage-$$tag-$$p modules-$$tag-$$p.tar.gz
 
 zImage-%: $(QUILT_PATCHES)/defconfig-%
-       cp $< ./.config
-       make ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) zImage
+       cat $< | sed 's/LOCALVERSION=".*"$$/LOCALVERSION="-$(LV)"/' > .config
+       make -j$(J) ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) zImage
        mv arch/arm/boot/zImage $@
 
 modules-%.tar.gz: $(QUILT_PATCHES)/defconfig-%
-       cp $< ./.config
+       cat $< | sed 's/LOCALVERSION=".*"$$/LOCALVERSION="-$(LV)"/' > .config
        -find . -name "*.ko" -print0 | xargs -r0 rm
-       mkdir /tmp/$@
-       make ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) \
-               INSTALL_MOD_PATH=/tmp/$@ modules modules_install
-       tar -C /tmp/$@ -czf $@ .
-       rm -rf /tmp/$@
+       mkdir -p Makefile.OpenEZX-tmp/$@
+       make -j$(J) ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) modules
+       make -j1 ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) \
+               INSTALL_MOD_PATH=Makefile.OpenEZX-tmp/$@ modules_install
+       tar -C Makefile.OpenEZX-tmp/$@ -czf $@ .
+       rm -rf Makefile.OpenEZX-tmp/
index 577aa66..e614605 100644 (file)
@@ -1,7 +1,7 @@
 Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
 ===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c    2007-09-07 22:15:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-09 13:29:56.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c    2007-09-21 21:38:52.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-21 21:48:23.000000000 -0300
 @@ -25,6 +25,7 @@
  #include <asm/arch/mmc.h>
  
@@ -10,8 +10,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
  
  extern void ezx_lcd_power(int, struct fb_var_screeninfo *);
  extern void ezx_backlight_power(int);
-@@ -227,11 +228,69 @@
-       .resource       = pcap_ts_resources,
+@@ -203,8 +204,65 @@
+       },
  };
  
 +
@@ -72,11 +72,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
 +
  static struct platform_device *devices[] __initdata = {
        &a1200_pcap_device,
-       &pcap_ts_device,
 +      &a1200_eoc_device,
  };
  
-+
  static void __init a1200_init(void)
- {
-       set_pxa_fb_info(&a1200_fb_info);
index a8c8f2e..2327257 100755 (executable)
@@ -1,8 +1,8 @@
 Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
 ===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c    2007-09-07 11:54:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-07 11:55:10.000000000 -0300
-@@ -203,8 +203,33 @@
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c    2007-09-21 21:50:31.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-21 21:51:06.000000000 -0300
+@@ -260,9 +260,34 @@
        },
  };
  
@@ -32,6 +32,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
 +
  static struct platform_device *devices[] __initdata = {
        &a1200_pcap_device,
+       &a1200_eoc_device,
 +      &pcap_ts_device,
  };
  
index 79c60c8..f6e152c 100644 (file)
@@ -1,7 +1,7 @@
 Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
 ===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c       2007-09-07 22:15:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c    2007-09-09 13:29:56.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c       2007-09-21 21:38:52.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c    2007-09-21 21:49:42.000000000 -0300
 @@ -25,6 +25,7 @@
  #include <asm/arch/mmc.h>
  
@@ -10,8 +10,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
  
  extern void ezx_lcd_power(int, struct fb_var_screeninfo *);
  extern void ezx_backlight_power(int);
-@@ -227,11 +228,69 @@
-       .resource       = pcap_ts_resources,
+@@ -203,8 +204,65 @@
+       },
  };
  
 +
@@ -72,11 +72,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
 +
  static struct platform_device *devices[] __initdata = {
        &e6_pcap_device,
-       &pcap_ts_device,
 +      &e6_eoc_device,
  };
  
-+
  static void __init e6_init(void)
- {
-       set_pxa_fb_info(&e6_fb_info);
index 6472f77..a39b782 100644 (file)
@@ -1,8 +1,8 @@
 Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
 ===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c       2007-09-07 11:54:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c    2007-09-07 11:55:10.000000000 -0300
-@@ -203,8 +203,33 @@
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c       2007-09-21 21:50:31.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c    2007-09-21 21:51:40.000000000 -0300
+@@ -260,9 +260,34 @@
        },
  };
  
@@ -32,6 +32,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
 +
  static struct platform_device *devices[] __initdata = {
        &e6_pcap_device,
+       &e6_eoc_device,
 +      &pcap_ts_device,
  };
  
index ff3413f..05748e6 100755 (executable)
@@ -1,7 +1,7 @@
 Index: linux-2.6.21/arch/arm/mach-pxa/pxa27x.c
 ===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/pxa27x.c       2007-06-28 19:44:28.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/pxa27x.c    2007-06-28 19:44:58.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/pxa27x.c       2007-09-21 23:57:40.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/pxa27x.c    2007-09-21 23:57:49.000000000 -0300
 @@ -22,6 +22,10 @@
  #include <asm/arch/pxa-regs.h>
  #include <asm/arch/ohci.h>
@@ -29,8 +29,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/pxa27x.c
        }
 Index: linux-2.6.21/arch/arm/mach-pxa/pm.c
 ===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/pm.c   2007-06-28 19:44:28.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/pm.c        2007-06-28 19:44:58.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/pm.c   2007-09-21 23:57:40.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/pm.c        2007-09-21 23:57:49.000000000 -0300
 @@ -24,6 +24,10 @@
  #include <asm/arch/lubbock.h>
  #include <asm/mach/time.h>
@@ -58,8 +58,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/pm.c
        RESTORE(GPDR0); RESTORE(GPDR1); RESTORE(GPDR2);
 Index: linux-2.6.21/arch/arm/mach-pxa/ezx.c
 ===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx.c  2007-06-28 19:44:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx.c       2007-06-28 19:44:58.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx.c  2007-09-21 23:57:48.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx.c       2007-09-22 00:07:34.000000000 -0300
 @@ -19,6 +19,7 @@
  #include <asm/arch/pxa-regs.h>
  #include <asm/arch/ohci.h>
@@ -68,49 +68,33 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx.c
  
  #include "generic.h"
  
-@@ -122,8 +123,69 @@
+@@ -122,8 +123,53 @@
        &ezxbp_device,
  };
  
 +/* PM */
 +extern int bp_handshake_passed(void);
 +
-+#define POWER_OFF_TIMEOUT       (2*60*HZ)
-+
 +static void ezx_reboot_poweroff(char mode)
 +{
-+#ifdef CONFIG_EZX_BP
-+      unsigned long start = jiffies;
-+
-+      printk("Waiting for BP to turn off. This can take some time...\n");
 +      *(unsigned long *)(phys_to_virt(BPSIG_ADDR)) = NO_FLAG;
 +      cpu_proc_fin();
 +
-+      do {
-+              /*
-+               * Turn off gracefully. Wait BP turn off first, and then
-+               * properly turn off.
-+               */
-+              if (pxa_gpio_get_value(GPIO_BB_WDI) == 0) {
-+                      *(unsigned long *)(phys_to_virt(BPSIG_ADDR)) = WDI_FLAG;
++#ifdef CONFIG_EZX_BP
++      if (pxa_gpio_get_value(GPIO_BB_WDI) == 0) {
++              *(unsigned long *)(phys_to_virt(BPSIG_ADDR)) = WDI_FLAG;
 +
-+                      /* reset BP */
-+                      pxa_gpio_set_value(GPIO_BB_RESET, 0);
-+                      mdelay(1);
-+                      pxa_gpio_set_value(GPIO_BB_RESET, 1);
++              /* reset BP */
++              pxa_gpio_set_value(GPIO_BB_RESET, 0);
++              mdelay(1);
++              pxa_gpio_set_value(GPIO_BB_RESET, 1);
 +
-+                      if (mode == 'z')
-+                              arch_reset('h');
-+                      break;
-+              }
-+              /* Just turn it off! */
-+              if (!bp_handshake_passed() || !pxa_gpio_get_value(GPIO_BB_WDI2)
-+                              || (jiffies - start) >= POWER_OFF_TIMEOUT) {
-+                      break;
++              if (mode == 'z') {
++                      arch_reset('h');
++                      while(1);
 +              }
-+      } while(1);
++      }
 +#endif
-+
 +      if (mode == 'z')
 +              /* Panic! Ask PCAP to turn both processors off */
 +              pxa_gpio_set_value(GPIO_WDI_AP, 0);
index 4d57380..bbbb40d 100644 (file)
@@ -1,9 +1,10 @@
-<html><head><title>Revision 2047: /trunk/src/kernel-2.6/patches</title></head>
+<html><head><title>Revision 2059: /trunk/src/kernel-2.6/patches</title></head>
 <body>
- <h2>Revision 2047: /trunk/src/kernel-2.6/patches</h2>
+ <h2>Revision 2059: /trunk/src/kernel-2.6/patches</h2>
  <ul>
   <li><a href="../">..</a></li>
   <li><a href="Makefile.OpenEZX">Makefile.OpenEZX</a></li>
+  <li><a href="a1200-eoc.patch">a1200-eoc.patch</a></li>
   <li><a href="a1200-mci.patch">a1200-mci.patch</a></li>
   <li><a href="a1200-pcap.patch">a1200-pcap.patch</a></li>
   <li><a href="a1200-ts.patch">a1200-ts.patch</a></li>
@@ -15,6 +16,7 @@
   <li><a href="a780-pcap.patch">a780-pcap.patch</a></li>
   <li><a href="a780-ts.patch">a780-ts.patch</a></li>
   <li><a href="a780-vibrator.patch">a780-vibrator.patch</a></li>
+  <li><a href="asoc-fix-loopback.patch">asoc-fix-loopback.patch</a></li>
   <li><a href="asoc-pxa-ssp.patch">asoc-pxa-ssp.patch</a></li>
   <li><a href="defconfig-a1200">defconfig-a1200</a></li>
   <li><a href="defconfig-a780">defconfig-a780</a></li>
   <li><a href="defconfig-e6">defconfig-e6</a></li>
   <li><a href="defconfig-e680">defconfig-e680</a></li>
   <li><a href="dmesg-a780.log">dmesg-a780.log</a></li>
+  <li><a href="e6-eoc.patch">e6-eoc.patch</a></li>
+  <li><a href="e6-mci.patch">e6-mci.patch</a></li>
+  <li><a href="e6-pcap.patch">e6-pcap.patch</a></li>
+  <li><a href="e6-ts.patch">e6-ts.patch</a></li>
   <li><a href="e680-emu.patch">e680-emu.patch</a></li>
   <li><a href="e680-kbd.patch">e680-kbd.patch</a></li>
   <li><a href="e680-leds.patch">e680-leds.patch</a></li>
   <li><a href="ezx-core.patch">ezx-core.patch</a></li>
   <li><a href="ezx-emu.patch">ezx-emu.patch</a></li>
   <li><a href="ezx-enable-stuart.patch">ezx-enable-stuart.patch</a></li>
+  <li><a href="ezx-eoc.patch">ezx-eoc.patch</a></li>
   <li><a href="ezx-mtd-map.patch">ezx-mtd-map.patch</a></li>
   <li><a href="ezx-pcap.patch">ezx-pcap.patch</a></li>
   <li><a href="ezx-pm.patch">ezx-pm.patch</a></li>
   <li><a href="ezx-serial-bug-workaround.patch">ezx-serial-bug-workaround.patch</a></li>
+  <li><a href="i2c-core-fix-a1200.patch">i2c-core-fix-a1200.patch</a></li>
+  <li><a href="mtdfix.patch">mtdfix.patch</a></li>
   <li><a href="mux-fix-init-errorpath.patch">mux-fix-init-errorpath.patch</a></li>
   <li><a href="mux-fix-makefile.patch">mux-fix-makefile.patch</a></li>
   <li><a href="mux-fix-tty-driver.patch">mux-fix-tty-driver.patch</a></li>
@@ -53,6 +62,7 @@
   <li><a href="patch-2.6.21.4">patch-2.6.21.4</a></li>
   <li><a href="pcap-ts.patch">pcap-ts.patch</a></li>
   <li><a href="pxa-kbd.patch">pxa-kbd.patch</a></li>
+  <li><a href="pxa27x-udc-fix-a1200.patch">pxa27x-udc-fix-a1200.patch</a></li>
   <li><a href="pxa27x-udc-support.2.patch">pxa27x-udc-support.2.patch</a></li>
   <li><a href="series">series</a></li>
  </ul>
index ecdc30b..aa95fcb 100755 (executable)
@@ -1,4 +1,5 @@
 patch-2.6.21.4
+mtdfix.patch
 
 ezx-core.patch
 # ezx-core TODO: should be ezx-common
@@ -25,10 +26,12 @@ ezx-pcap.patch
 a780-pcap.patch
 e680-pcap.patch
 a1200-pcap.patch
+e6-pcap.patch
 
 a780-mci.patch
 e680-mci.patch
 a1200-mci.patch
+e6-mci.patch
 
 pxa27x-udc-support.2.patch
 
@@ -36,23 +39,18 @@ ezx-emu.patch
 # ezx-emu TODO:
 # userspace interface for controling emu
 # read adc to find which accessory is plugged
-
 a780-emu.patch
 e680-emu.patch
 
+ezx-eoc.patch
+a1200-eoc.patch
+e6-eoc.patch
+
 ezx-mtd-map.patch
-# ezx-mtd-map TODO:
-# at least the original partition should go on the ezx-phone.c file
 
 ezx-serial-bug-workaround.patch
-# ezx-serial-bug TODO:
-# does anyone have a phone with this bug?
 
 pxa-kbd.patch
-# pxa-kbd TODO:
-# test multi-key presses
-# ask Harald about driver status/sending mainline
-
 a780-kbd.patch
 e680-kbd.patch
 
@@ -60,6 +58,7 @@ pcap-ts.patch
 a780-ts.patch
 e680-ts.patch
 a1200-ts.patch
+e6-ts.patch
 
 ezx-backlight.patch
 
@@ -83,6 +82,11 @@ mux-fix-tty-driver.patch
 mux-linux-2.6.21-fix.patch
 #mux-ifdef-ezx-features.patch
 #mux_debug.patch
+
+asoc-pxa-ssp.patch
+asoc-fix-loopback.patch
+ezx-asoc.patch
+
 # mux_cli TODO:
 # merge patches
 # try to understand the code and cleanup (painful)
@@ -92,6 +96,8 @@ mux-linux-2.6.21-fix.patch
 #      can NOT run as module (yet)
 #              pxa-ohci, ts0710_mux, ts0710_mux_usb, ezx-bp
 
+# the folowing break too much stuff on other phones.
+# i2c-core-fix-a1200.patch (see ezx-eoc.c)
+# pxa27x-udc-fix-a1200.patch (see ezx-a1200.c)
+
 # incomplete
-asoc-pxa-ssp.patch
-ezx-asoc.patch
index 21cbb1e..cb7d745 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "2.6 Linux Development Kernel for the Motorola GSM phones A780 and
 AUTHOR = "The OpenEZX Team <openezx-devel@lists.openezx.org>"
 HOMEPAGE = "http://www.openezx.org"
 EZX = "ezxdev"
-PR = "${EZX}-r18"
+PR = "${EZX}-r19"
 
 require linux.inc
 
@@ -13,7 +13,16 @@ SRC_URI = " \
     file://logo_linux_clut224.ppm \
     \
     file://patches/patch-2.6.21.4;patch=1 \
+    ${RPSRC}/lzo_kernel-r0.patch;patch=1 \
+    ${RPSRC}/lzo_jffs2-r0.patch;patch=1 \
+    ${RPSRC}/lzo_crypto-r1.patch;patch=1 \
+    ${RPSRC}/lzo_jffs2_lzomode-r0.patch;patch=1 \
+    ${RPSRC}/lzo_jffs2_sysfs-r0.patch;patch=1 \
+    ${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
     ${RPSRC}/pxa27x_overlay-r5.patch;patch=1 \
+    ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
+    ${RPSRC}/mmcsd_large_cards-r0.patch;patch=1;status=hack \
+    ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1;status=hack \
     file://patches/ezx-core.patch;patch=1 \
     file://patches/ezx-bp.patch;patch=1 \
     file://patches/ezx-pm.patch;patch=1 \
@@ -28,6 +37,9 @@ SRC_URI = " \
     file://patches/e6-mci.patch;patch=1 \
     file://patches/pxa27x-udc-support.2.patch;patch=1 \
     file://patches/ezx-emu.patch;patch=1 \
+    file://patches/ezx-eoc.patch;patch=1 \ 
+    file://patches/a1200-eoc.patch;patch=1 \
+    file://patches/e6-eoc.patch;patch=1 \
     file://patches/a780-emu.patch;patch=1 \
     file://patches/e680-emu.patch;patch=1 \
     file://patches/ezx-mtd-map.patch;patch=1 \
@@ -40,9 +52,6 @@ SRC_URI = " \
     file://patches/e680-ts.patch;patch=1 \
     file://patches/a1200-ts.patch;patch=1 \
     file://patches/e6-ts.patch;patch=1 \
-    file://patches/ezx-eoc.patch;patch=1 \
-    file://patches/a1200-eoc.patch;patch=1 \
-    file://patches/e6-eoc.patch;patch=1 \
     file://patches/a780-flip.patch;patch=1 \
     file://patches/e680-locksw.patch;patch=1 \
     file://patches/a780-leds.patch;patch=1 \