powertop: fix CFLAGS in .inc and add a git version
authorKoen Kooi <koen@openembedded.org>
Sun, 5 Dec 2010 12:32:20 +0000 (13:32 +0100)
committerGrazvydas Ignotas <notasas@gmail.com>
Thu, 17 Jul 2014 23:24:47 +0000 (02:24 +0300)
Signed-off-by: Koen Kooi <koen@openembedded.org>
recipes/powertop/powertop.inc
recipes/powertop/powertop_git.bb [new file with mode: 0644]

index 931abad..e5eb4e7 100644 (file)
@@ -9,7 +9,7 @@ SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.ta
           file://ldflags.patch;patch=1 \
          "
 
-CFLAGS = "${LDFLAGS}"
+CFLAGS += "${LDFLAGS}"
 
 do_configure() {
     # We do not build ncurses with wide char support
diff --git a/recipes/powertop/powertop_git.bb b/recipes/powertop/powertop_git.bb
new file mode 100644 (file)
index 0000000..7cfe90f
--- /dev/null
@@ -0,0 +1,19 @@
+# requires kernel 2.6.31+ headers with perf_event_open syscall
+DEFAULT_PREFERENCE = "-1"
+
+require recipes/powertop/powertop.inc
+
+SRCREV = "e9e22ba99bfe0e2f42d52acfd00f434b9d905083"
+PV = "1.13"
+PR = "${INC_PR}.0"
+PR_append = "+gitr${SRCPV}"
+
+SRC_URI = "git://gitorious.org/meego-developer-tools/powertop.git;protocol=git"
+S = "${WORKDIR}/git"
+
+CFLAGS += "-DVERSION=\\"${PV}\\" -Wall -Wshadow -W -Wformat -Wimplicit-function-declaration -Wimplicit-int"
+
+do_configure() {
+    # We do not build ncurses with wide char support
+    sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}