merge of '848c6e3f16104e7b87568edf06d0d9cc79b5e860'
authorRod Whitby <rod@whitby.id.au>
Tue, 25 Mar 2008 00:51:35 +0000 (00:51 +0000)
committerRod Whitby <rod@whitby.id.au>
Tue, 25 Mar 2008 00:51:35 +0000 (00:51 +0000)
     and 'aff156eb3c821fe61a4b7788e1da432c621d1383'

23 files changed:
classes/e.bbclass
conf/machine/nokia800.conf
packages/busybox/busybox-1.9.1/defconfig
packages/busybox/files/50telnet [new file with mode: 0644]
packages/busybox/files/login.failsafe [new file with mode: 0644]
packages/db/db-native_4.2.52.bb
packages/db/db-native_4.3.29.bb
packages/db/db3_3.2.9.bb
packages/db/db4-native.inc [new file with mode: 0644]
packages/db/db4.inc [new file with mode: 0644]
packages/db/db_4.2.52.bb
packages/db/db_4.3.29.bb
packages/dpkg/dpkg_1.13.22.bb
packages/dpkg/dpkg_1.13.25.bb
packages/e17/e-wm_cvs.bb
packages/glibc/glibc.inc
packages/openmoko-projects/diversity-daemon_svn.bb
packages/pointercal/files/nokia770/.mtn2git_empty [new file with mode: 0644]
packages/pointercal/files/nokia770/pointercal [new file with mode: 0644]
packages/pointercal/files/nokia800/pointercal [new file with mode: 0644]
packages/update-alternatives/update-alternatives-dpkg-1.13.22/.mtn2git_empty [new file with mode: 0644]
packages/update-alternatives/update-alternatives-dpkg-1.13.22/paths.patch [new file with mode: 0644]
packages/update-alternatives/update-alternatives-dpkg.inc

index 84d85f5..3fb2355 100644 (file)
@@ -1,6 +1,7 @@
 HOMEPAGE = "http://www.enlightenment.org"
 SECTION = "e/apps"
-SRC_URI = "http://download.enlightenment.org/snapshots/2007-06-17/${PN}-${PV}.tar.gz"
+SRC_URI = "${E_CVS};module=e17/apps/${SRCNAME}"
+S = "${WORKDIR}/${SRCNAME}"
 
 inherit autotools pkgconfig binconfig
 
@@ -9,27 +10,10 @@ do_prepsources () {
 }
 addtask prepsources after do_fetch before do_unpack
 
-export CURL_CONFIG             = "${STAGING_BINDIR_CROSS}/curl-config"
-export EDB_CONFIG              = "${STAGING_BINDIR_CROSS}/edb-config"
-export EET_CONFIG              = "${STAGING_BINDIR_CROSS}/eet-config"
-export EVAS_CONFIG             = "${STAGING_BINDIR_CROSS}/evas-config"
-export ECORE_CONFIG            = "${STAGING_BINDIR_CROSS}/ecore-config"
-export EMBRYO_CONFIG           = "${STAGING_BINDIR_CROSS}/embryo-config"
-export ENGRAVE_CONFIG          = "${STAGING_BINDIR_CROSS}/engrave-config"
-export ENLIGHTENMENT_CONFIG    = "${STAGING_BINDIR_CROSS}/enlightenment-config"
-export EPSILON_CONFIG          = "${STAGING_BINDIR_CROSS}/epsilon-config"
-export EPEG_CONFIG             = "${STAGING_BINDIR_CROSS}/epeg-config"
-export ESMART_CONFIG           = "${STAGING_BINDIR_CROSS}/esmart-config"
-export FREETYPE_CONFIG         = "${STAGING_BINDIR_CROSS}/freetype-config"
-export IMLIB2_CONFIG           = "${STAGING_BINDIR_CROSS}/imlib2-config"
+export CURL_CONFIG = "${STAGING_BINDIR_CROSS}/curl-config"
+export FREETYPE_CONFIG = "${STAGING_BINDIR_CROSS}/freetype-config"
 
-#do_compile_prepend() {
-#      find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
-#      find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
-#}
-
-PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev"
-FILES_${PN} += "${libdir}/lib*.so.*"
+PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev ${PN}-lib"
+FILES_${PN}-lib = "${libdir}/lib*.so.*"
 FILES_${PN}-themes = "${datadir}/${PN}/themes ${datadir}/${PN}/data ${datadir}/${PN}/fonts ${datadir}/${PN}/pointers ${datadir}/${PN}/images ${datadir}/${PN}/users ${datadir}/${PN}/images ${datadir}/${PN}/styles"
 FILES_${PN}-dev += "${includedir} ${libdir}/lib*.so"
-
index 144df2e..aa35383 100644 (file)
@@ -1,5 +1,5 @@
 #@TYPE: Machine
-#@NAME: Nokia 770 internet tablet
+#@NAME: Nokia 800 internet tablet
 #@DESCRIPTION: Machine configuration for the Nokia 800
 TARGET_ARCH = "arm"
 PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te armv6"
index 770ef6e..33d3091 100644 (file)
@@ -633,7 +633,7 @@ CONFIG_ROUTE=y
 CONFIG_TELNET=y
 # CONFIG_FEATURE_TELNET_TTYPE is not set
 CONFIG_FEATURE_TELNET_AUTOLOGIN=y
-# CONFIG_TELNETD is not set
+CONFIG_TELNETD=y
 # CONFIG_FEATURE_TELNETD_STANDALONE is not set
 CONFIG_TFTP=y
 CONFIG_FEATURE_TFTP_GET=y
diff --git a/packages/busybox/files/50telnet b/packages/busybox/files/50telnet
new file mode 100644 (file)
index 0000000..3fb4a90
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh
+# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 Koen Kooi
+
+# This starts telnetd if the password for 'root' is empty. This is needed for devices without a screen or serial console (wifi router, NAS, etc). 
+
+start() {
+       if awk -F: '/^root:/ && ($2 != "") && ($2 !~ /\!/) {exit 1}' /etc/passwd 2>/dev/null 
+       then 
+               telnetd -l /bin/login.failsafe
+       fi
+}
+
+stop() {
+       killall telnetd
+}
diff --git a/packages/busybox/files/login.failsafe b/packages/busybox/files/login.failsafe
new file mode 100644 (file)
index 0000000..e7c12a2
--- /dev/null
@@ -0,0 +1,19 @@
+#!/bin/sh
+# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 Koen Kooi
+
+grep '^root:[^!]' /etc/passwd >&- 2>&-
+[ "$?" = "0" ]  &&  
+{
+    echo "Login failed."
+    exit 0
+} || {
+cat << EOF
+ === IMPORTANT ============================
+  Use 'passwd' to set your login password
+  this will disable telnet and enable SSH
+ ------------------------------------------
+EOF
+}
+
+exec /bin/sh --login
index 567ddff..0e6381b 100644 (file)
@@ -1,27 +1,2 @@
-# This wrapper builds a native version of the SleepyCat
-# Berkeley DB for those packages which need it (e.g.
-# perl).
-SECTION = "libs"
-VIRTUAL_NAME = "virtual/db-native"
-CONFLICTS = "db3-native"
-#PR tracks the non-native package
-
-inherit native
-
 require db_${PV}.bb
-
-PACKAGES = ""
-
-do_stage() {
-         # The .h files get installed read-only, the autostage
-         # function just uses cp -pPR, so do this by hand
-         rm -rf ${STAGE_TEMP}
-         mkdir -p ${STAGE_TEMP}
-         oe_runmake DESTDIR="${STAGE_TEMP}" install_include
-         cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
-         rm -rf ${STAGE_TEMP}
-         oe_libinstall -so -C .libs libdb-4.2 ${STAGING_LIBDIR}
-         ln -sf libdb-4.2.so ${STAGING_LIBDIR}/libdb.so
-         ln -sf libdb-4.2.a ${STAGING_LIBDIR}/libdb.a
-}
-
+require db4-native.inc
index aac4e20..0e6381b 100644 (file)
@@ -1,17 +1,2 @@
-# This wrapper builds a native version of the SleepyCat
-# Berkeley DB for those packages which need it (e.g.
-# perl).
-SECTION = "libs"
-VIRTUAL_NAME = "virtual/db-native"
-CONFLICTS = "db3-native"
-#PR tracks the non-native package
-
-inherit native
-
 require db_${PV}.bb
-
-do_package() {
-:
-}
-
-PACKAGES = ""
+require db4-native.inc
index 7edba4f..872ceea 100644 (file)
@@ -1,8 +1,8 @@
 SECTION = "libs"
 DESCRIPTION = "Berkeley DB v3."
-HOMEPAGE = "http://www.sleepycat.com"
-LICENSE = "BSD Sleepycat"
-PR = "r2"
+HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
+LICENSE = "BSD"
+PR = "r3"
 VIRTUAL_NAME ?= "virtual/db"
 CONFLICTS = "db"
 
@@ -11,7 +11,7 @@ CONFLICTS = "db"
 # a build to select the desired one.
 PROVIDES += "${VIRTUAL_NAME}"
 
-SRC_URI = "http://download-west.oracle.com/berkeley-db/db-${PV}.tar.gz \
+SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz \
           file://autofoo.patch;patch=1"
 S = "${WORKDIR}/db-${PV}/dist"
 B = "${WORKDIR}/db-${PV}/build_unix"
diff --git a/packages/db/db4-native.inc b/packages/db/db4-native.inc
new file mode 100644 (file)
index 0000000..cc83d86
--- /dev/null
@@ -0,0 +1,28 @@
+# This wrapper builds a native version of the Oracal
+# Berkeley DB for those packages which need it (e.g.
+# perl).
+
+VIRTUAL_NAME = "virtual/db-native"
+CONFLICTS = "db3-native"
+#PR tracks the non-native package
+
+inherit native
+
+do_package() {
+:
+}
+
+PACKAGES = ""
+
+do_stage() {
+         # The .h files get installed read-only, the autostage
+         # function just uses cp -pPR, so do this by hand
+         rm -rf ${STAGE_TEMP}
+         mkdir -p ${STAGE_TEMP}
+         oe_runmake DESTDIR="${STAGE_TEMP}" install_include
+         cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
+         rm -rf ${STAGE_TEMP}
+         oe_libinstall -so -C .libs libdb-${PVM} ${STAGING_LIBDIR}
+         ln -sf libdb-${PVM}.so ${STAGING_LIBDIR}/libdb.so
+         ln -sf libdb-${PVM}.a ${STAGING_LIBDIR}/libdb.a
+}
diff --git a/packages/db/db4.inc b/packages/db/db4.inc
new file mode 100644 (file)
index 0000000..12d4ad2
--- /dev/null
@@ -0,0 +1,96 @@
+# Version 4 of the Berkeley DB from Oracle
+#
+# At present this package only installs the DB code
+# itself (shared libraries, .a in the dev package),
+# documentation and headers.
+#
+# The headers have the same names as those as v3
+# of the DB, only one version can be used *for dev*
+# at once - DB3 and DB4 can both be installed on the
+# same system at the same time if really necessary.
+
+
+DESCRIPTION = "Berkeley DB v4."
+HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
+SECTION = "libs"
+LICENSE = "BSD"
+VIRTUAL_NAME ?= "virtual/db"
+CONFLICTS = "db3"
+
+SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
+
+inherit autotools
+
+# Put virtual/db in any appropriate provider of a
+# relational database, use it as a dependency in
+# place of a specific db and use:
+#
+# PREFERRED_PROVIDER_virtual/db
+#
+# to select the correct db in the build (distro) .conf
+PROVIDES += "${VIRTUAL_NAME}"
+
+# bitbake isn't quite clever enough to deal with db,
+# the distribution sits in the expected directory, but all
+# the builds must occur from a sub-directory.  The following
+# persuades bitbake to go to the right place
+S = "${WORKDIR}/db-${PV}/dist"
+B = "${WORKDIR}/db-${PV}/build_unix"
+
+# The executables go in a separate package - typically there
+# is no need to install these unless doing real database
+# management on the system.
+PACKAGES += " ${PN}-bin"
+
+# Package contents
+FILES_${PN} = "${libdir}/libdb-4*so*"
+FILES_${PN}-bin = "${bindir}/*"
+# The dev package has the .so link (as in db3) and the .a's -
+# it is therefore incompatible (cannot be installed at the
+# same time) as the db3 package
+FILES_${PN}-dev = "${includedir} ${libdir}/*"
+
+EXTRA_OECONF = "${DB4_CONFIG}"
+
+# Override the MUTEX setting here, the POSIX library is
+# the default - "POSIX/pthreads/library".
+# Don't ignore the nice SWP instruction on the ARM:
+# These enable the ARM assembler mutex code, this won't
+# work with thumb compilation...
+ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
+MUTEX = ""
+MUTEX_arm = "${ARM_MUTEX}"
+MUTEX_armeb = "${ARM_MUTEX}"
+EXTRA_OECONF += "${MUTEX}"
+
+# Cancel the site stuff - it's set for db3 and destroys the
+# configure.
+CONFIG_SITE = ""
+do_configure() {
+       ( cd ${WORKDIR}/db-${PV}/dist ; gnu-configize ) 
+       oe_runconf
+}
+
+
+do_install_append() {
+       # The docs end up in /usr/docs - not right.
+       if test -d "${D}/${prefix}/docs"
+       then
+               mkdir -p "${D}/${datadir}"
+               test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
+               mv "${D}/${prefix}/docs" "${D}/${docdir}"
+       fi
+}
+
+do_stage() {
+       # The .h files get installed read-only, the autostage
+       # function just uses cp -pPR, so do this by hand
+       rm -rf ${STAGE_TEMP}
+       mkdir -p ${STAGE_TEMP}
+       oe_runmake DESTDIR="${STAGE_TEMP}" install_include
+       cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
+       rm -rf ${STAGE_TEMP}
+       oe_libinstall -so -C .libs libdb-${PVM} ${STAGING_LIBDIR}
+       ln -sf libdb-${PVM}.so ${STAGING_LIBDIR}/libdb.so
+       ln -sf libdb-${PVM}.a ${STAGING_LIBDIR}/libdb.a
+}
index 94d875e..ae9591d 100644 (file)
@@ -1,97 +1,11 @@
-# Version 4 of the Berkeley DB from Sleepycat
-#
-# At present this package only installs the DB code
-# itself (shared libraries, .a in the dev package),
-# documentation and headers.
-#
-# The headers have the same names as those as v3
-# of the DB, only one version can be used *for dev*
-# at once - DB3 and DB4 can both be installed on the
-# same system at the same time if really necessary.
-SECTION = "libs"
-DESCRIPTION = "Berkeley DB v4."
-HOMEPAGE = "http://www.sleepycat.com"
-LICENSE = "BSD Sleepycat"
-VIRTUAL_NAME ?= "virtual/db"
-CONFLICTS = "db3"
-PR = "r7"
+PR = "r8"
 
-SRC_URI = "http://downloads.sleepycat.com/db-${PV}.tar.gz"
-#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
-#TODO SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
-
-inherit autotools
-
-# Put virtual/db in any appropriate provider of a
-# relational database, use it as a dependency in
-# place of a specific db and use:
-#
-# PREFERRED_PROVIDER_virtual/db
-#
-# to select the correct db in the build (distro) .conf
-PROVIDES += "${VIRTUAL_NAME}"
+#major version number
+PVM = "4.2"
 
-# bitbake isn't quite clever enough to deal with sleepycat,
-# the distribution sits in the expected directory, but all
-# the builds must occur from a sub-directory.  The following
-# persuades bitbake to go to the right place
-S = "${WORKDIR}/db-${PV}/dist"
-B = "${WORKDIR}/db-${PV}/build_unix"
+require db4.inc
 
-# The executables go in a separate package - typically there
-# is no need to install these unless doing real database
-# management on the system.
-PACKAGES += " ${PN}-bin"
-
-# Package contents
-FILES_${PN} = "${libdir}/libdb-4*so*"
-FILES_${PN}-bin = "${bindir}/*"
-# The dev package has the .so link (as in db3) and the .a's -
-# it is therefore incompatible (cannot be installed at the
-# same time) as the db3 package
-FILES_${PN}-dev = "${includedir} ${libdir}/*"
+#TODO SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
 
 #configuration - set in local.conf to override
 DB4_CONFIG ?= " --disable-cryptography --disable-queue --disable-replication --disable-verify --enable-hash"
-EXTRA_OECONF = "${DB4_CONFIG}"
-
-# Override the MUTEX setting here, the POSIX library is
-# the default - "POSIX/pthreads/library".
-# Don't ignore the nice SWP instruction on the ARM:
-# These enable the ARM assembler mutex code, this won't
-# work with thumb compilation...
-ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
-MUTEX = ""
-MUTEX_arm = "${ARM_MUTEX}"
-MUTEX_armeb = "${ARM_MUTEX}"
-EXTRA_OECONF += "${MUTEX}"
-
-# Cancel the site stuff - it's set for db3 and destroys the
-# configure.
-CONFIG_SITE = ""
-do_configure() {
-       oe_runconf
-}
-
-do_stage() {
-       # The .h files get installed read-only, the autostage
-       # function just uses cp -pPR, so do this by hand
-       rm -rf ${STAGE_TEMP}
-       mkdir -p ${STAGE_TEMP}
-       oe_runmake DESTDIR="${STAGE_TEMP}" install_include
-       cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
-       rm -rf ${STAGE_TEMP}
-       oe_libinstall -so -C .libs libdb-4.2 ${STAGING_LIBDIR}
-       ln -sf libdb-4.2.so ${STAGING_LIBDIR}/libdb.so
-       ln -sf libdb-4.2.a ${STAGING_LIBDIR}/libdb.a
-}
-
-do_install_append() {
-       # The docs end up in /usr/docs - not right.
-       if test -d "${D}/${prefix}/docs"
-       then
-               mkdir -p "${D}/${datadir}"
-               test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
-               mv "${D}/${prefix}/docs" "${D}/${docdir}"
-       fi
-}
index 026b45b..d5733be 100644 (file)
@@ -1,99 +1,12 @@
-# Version 4 of the Berkeley DB from Sleepycat
-#
-# At present this package only installs the DB code
-# itself (shared libraries, .a in the dev package),
-# documentation and headers.
-#
-# The headers have the same names as those as v3
-# of the DB, only one version can be used *for dev*
-# at once - DB3 and DB4 can both be installed on the
-# same system at the same time if really necessary.
-SECTION = "libs"
-DESCRIPTION = "Berkeley DB v4."
-HOMEPAGE = "http://www.sleepycat.com"
-LICENSE = "BSD Sleepycat"
-VIRTUAL_NAME ?= "virtual/db"
-CONFLICTS = "db3"
-PR = "r9"
+PR = "r10"
 
-SRC_URI = "http://downloads.sleepycat.com/db-${PV}.tar.gz"
-#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
-SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
-
-inherit autotools
-
-# Put virtual/db in any appropriate provider of a
-# relational database, use it as a dependency in
-# place of a specific db and use:
-#
-# PREFERRED_PROVIDER_virtual/db
-#
-# to select the correct db in the build (distro) .conf
-PROVIDES += "${VIRTUAL_NAME}"
+# major version number
+PVM = "4.3"
 
-# bitbake isn't quite clever enough to deal with sleepycat,
-# the distribution sits in the expected directory, but all
-# the builds must occur from a sub-directory.  The following
-# persuades bitbake to go to the right place
-S = "${WORKDIR}/db-${PV}/dist"
-B = "${WORKDIR}/db-${PV}/build_unix"
+require db4.inc
 
-# The executables go in a separate package - typically there
-# is no need to install these unless doing real database
-# management on the system.
-PACKAGES += " ${PN}-bin"
-
-# Package contents
-FILES_${PN} = "${libdir}/libdb-4.*.so*"
-FILES_${PN}-bin = "${bindir}/*"
-# The dev package has the .so link (as in db3) and the .a's -
-# it is therefore incompatible (cannot be installed at the
-# same time) as the db3 package
-FILES_${PN}-dev = "${includedir} ${libdir}/*"
+SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
 
 #configuration - set in local.conf to override
 # All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
 DB4_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-statistics --disable-verify --enable-compat185"
-EXTRA_OECONF = "${DB4_CONFIG}"
-
-# Override the MUTEX setting here, the POSIX library is
-# the default - "POSIX/pthreads/library".
-# Don't ignore the nice SWP instruction on the ARM:
-# These enable the ARM assembler mutex code, this won't
-# work with thumb compilation...
-ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
-MUTEX = ""
-MUTEX_arm = "${ARM_MUTEX}"
-MUTEX_armeb = "${ARM_MUTEX}"
-EXTRA_OECONF += "${MUTEX}"
-
-# Cancel the site stuff - it's set for db3 and destroys the
-# configure.
-CONFIG_SITE = ""
-do_configure() {
-       ( cd ${WORKDIR}/db-${PV}/dist ; gnu-configize ) 
-       oe_runconf
-}
-
-do_stage() {
-       # The .h files get installed read-only, the autostage
-       # function just uses cp -pPR, so do this by hand
-       rm -rf ${STAGE_TEMP}
-       mkdir -p ${STAGE_TEMP}
-       oe_runmake DESTDIR="${STAGE_TEMP}" install_include
-       cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
-       rm -rf ${STAGE_TEMP}
-       oe_libinstall -so -C .libs libdb-4.3 ${STAGING_LIBDIR}
-       ln -sf libdb-4.3.so ${STAGING_LIBDIR}/libdb.so
-       ln -sf libdb-4.3.a ${STAGING_LIBDIR}/libdb.a
-}
-
-do_install_append() {
-       # The docs end up in /usr/docs - not right.
-       if test -d "${D}/${prefix}/docs"
-       then
-               mkdir -p "${D}/${datadir}"
-               test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
-               mv "${D}/${prefix}/docs" "${D}/${docdir}"
-       fi
-}
index 0d6ae5c..fb301a6 100644 (file)
@@ -8,4 +8,5 @@ EXTRA_OECONF = "--without-static-progs \
                --with-start-stop-daemon \
                --with-zlib \
                --with-bz2lib \
-               --without-sgml-doc"
+               --without-sgml-doc \
+               PERL=/usr/bin/perl"
index deccb32..a0bb1dc 100644 (file)
@@ -8,4 +8,5 @@ EXTRA_OECONF = "--without-static-progs \
                --with-start-stop-daemon \
                --with-zlib \
                --with-bz2lib \
-               --without-sgml-doc"
+               --without-sgml-doc \
+               PERL=/usr/bin/perl"
index 364e553..9cd4ab7 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "The Enlightenment Window Mananger Version 17"
 DEPENDS = "eet evas ecore edje efreet"
 LICENSE = "MIT BSD"
 PV = "0.16.999.042+cvs${SRCDATE}"
-PR = "r1"
+PR = "r0"
 
 inherit e update-alternatives
 
@@ -53,6 +53,10 @@ FILES_${PN}-dbg += "\
   ${libdir}/enlightenment/preload/.debug/ \
 "
 
+FILES_${PN}-dev += "\
+  ${libdir}/enlightenment/preload/*.?a \
+"
+
 ALTERNATIVE_PATH = "${bindir}/enlightenment_start"
 ALTERNATIVE_NAME = "x-window-manager"
 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
index 10c2796..40e0f8f 100644 (file)
@@ -12,6 +12,8 @@ PROVIDES += "virtual/libintl virtual/libiconv"
 
 inherit autotools
 
+LEAD_SONAME = "libc.so"
+
 GLIBC_EXTRA_OECONF ?= ""
 INHIBIT_DEFAULT_DEPS = "1"
 
index dd58249..8ffcdc5 100644 (file)
@@ -1,6 +1,6 @@
-DESCRIPTION = "Diveristy Daemon"
+DESCRIPTION = "Diversity Daemon"
 HOMEPAGE = "http://diversity.projects.openmoko.org/"
-SECTION = "net/misc"
+SECTION = "network/misc"
 LICENSE = "GPL"
 DEPENDS = "glib-2.0 dbus dbus-glib eds-dbus libjana curl"
 RDEPENDS_${PN} = "eds-dbus openmoko-dialer2"
@@ -8,7 +8,6 @@ PV = "0.0+svnr${SRCREV}"
 PR = "r2"
 
 SRC_URI = "svn://svn.projects.openmoko.org/svnroot/diversity/trunk;module=diversity-daemon;proto=https"
-
 S = "${WORKDIR}/diversity-daemon"
 
 inherit autotools pkgconfig
diff --git a/packages/pointercal/files/nokia770/.mtn2git_empty b/packages/pointercal/files/nokia770/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/pointercal/files/nokia770/pointercal b/packages/pointercal/files/nokia770/pointercal
new file mode 100644 (file)
index 0000000..20edf46
--- /dev/null
@@ -0,0 +1 @@
+-15355 20 56077944 28 -9469 35056912 65536
\ No newline at end of file
diff --git a/packages/pointercal/files/nokia800/pointercal b/packages/pointercal/files/nokia800/pointercal
new file mode 100644 (file)
index 0000000..4dafc67
--- /dev/null
@@ -0,0 +1 @@
+14693 91 -4137352 7 -9660 35213352 65536
diff --git a/packages/update-alternatives/update-alternatives-dpkg-1.13.22/.mtn2git_empty b/packages/update-alternatives/update-alternatives-dpkg-1.13.22/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/update-alternatives/update-alternatives-dpkg-1.13.22/paths.patch b/packages/update-alternatives/update-alternatives-dpkg-1.13.22/paths.patch
new file mode 100644 (file)
index 0000000..a23bf9a
--- /dev/null
@@ -0,0 +1,26 @@
+diff -ruN dpkg-1.13.22.orig/scripts/update-alternatives.pl dpkg-1.13.22/scripts/update-alternatives.pl
+--- dpkg-1.13.22.orig/scripts/update-alternatives.pl   2006-06-21 01:46:12.000000000 -0300
++++ dpkg-1.13.22/scripts/update-alternatives.pl    2007-08-02 19:36:47.000000000 -0300
+@@ -1,7 +1,7 @@
+ #!/usr/bin/perl --
+ $admindir= "/var/lib/dpkg"; # This line modified by Makefile
+-$dpkglibdir= "../utils"; # This line modified by Makefile
++$dpkglibdir= "/usr/lib/dpkg"; # This line modified by Makefile
+ $version= '0.93.80'; # This line modified by Makefile
+ push (@INC, $dpkglibdir);
+ require 'dpkg-gettext.pl';
+@@ -129,6 +129,12 @@
+         &checkmanymodes;
+         @ARGV >= 4 || &badusage(_g("--install needs <link> <name> <path> <priority>"));
+         ($alink,$name,$apath,$apriority,@ARGV) = @ARGV;
++  if (! -e $apath) { 
++      $apath = substr($alink,0,rindex($alink,"/")+1).$apath;
++  }
++  if (! -e $apath) { 
++      &quit(sprintf(_g("Error: file not found: %s"), $apath));
++  }
+         $apriority =~ m/^[-+]?\d+/ || &badusage(_g("priority must be an integer"));
+         $mode= 'install';
+     } elsif (m/^--(remove|set)$/) {
+
index cffcf83..e3cdb53 100644 (file)
@@ -1,19 +1,14 @@
 LICENSE = "GPL"
 SECTION = "base"
-SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz"
+SRC_URI += "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz"
 S = "${WORKDIR}/dpkg-${PV}"
 PACKAGE_ARCH = "all"
 
-do_patch () {
-    cat ${S}/scripts/update-alternatives.pl | \
-        sed -n -e '
-    /^\$admindir=.*staging/{
-        x
-        s/^.*$/$D=$ENV{"D"} || ""\;/;
-        p;
-        x;
-        s,^\$admindir=.*staging.*$,$admindir="$D${localstatedir}/dpkg"\;,;
-    };
-    s,^\$altdir=.*$,$altdir="$D${sysconfdir}/alternatives"\;,;
-    p;' > ${S}/scripts/update-alternatives
+SRC_URI += "file://paths.patch;patch=1"
+
+do_patch_append () {
+       import shutil
+       update_alternatives_src = bb.data.getVar('S', d, 1)
+       shutil.move("%s/scripts/update-alternatives.pl" % (update_alternatives_src,),
+                   "%s/scripts/update-alternatives" % (update_alternatives_src,))
 }