mediatomb: update to 0.9.1
authorKoen Kooi <koen@openembedded.org>
Tue, 29 May 2007 13:42:33 +0000 (13:42 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 29 May 2007 13:42:33 +0000 (13:42 +0000)
packages/mediatomb/mediatomb_0.9.1.bb [new file with mode: 0644]

diff --git a/packages/mediatomb/mediatomb_0.9.1.bb b/packages/mediatomb/mediatomb_0.9.1.bb
new file mode 100644 (file)
index 0000000..f3ea9f5
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "MediaTomb - UPnP AV MediaServer for Linux"
+HOMEPAGE = "http://mediatomb.cc/"
+LICENSE = "GPLv2"
+DEPENDS = "sqlite3 libexif js zlib file id3lib"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mediatomb/mediatomb-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-mysql \
+                --disable-rpl-malloc \
+               --enable-sqlite3 \
+                --enable-libjs \
+               --enable-libmagic \
+               --enable-id3lib \
+               --enable-libexif \
+                --disable-largefile \
+                --with-sqlite3-h=${STAGING_INCDIR} \
+                --with-sqlite3-libs=${STAGING_LIBDIR} \
+                --with-magic-h=${STAGING_INCDIR} \
+                --with-magic-libs=${STAGING_LIBDIR} \
+                --with-exif-h=${STAGING_INCDIR} \
+                --with-exif-libs=${STAGING_LIBDIR} \
+                --with-zlib-h=${STAGING_INCDIR} \
+                --with-zlib-libs=${STAGING_LIBDIR} \
+                --with-js-h=${STAGING_INCDIR}/js \
+                --with-js-libs=${STAGING_LIBDIR} \
+                --with-id3lib-h=${STAGING_INCDIR} \
+                --with-id3lib-libs=${STAGING_LIBDIR}"