omap3-sgx-modules: backport spinlock fix from omap3630
authorGrazvydas Ignotas <notasas@gmail.com>
Mon, 24 Jan 2011 13:43:46 +0000 (15:43 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Mon, 24 Jan 2011 13:43:46 +0000 (15:43 +0200)
recipes/powervr-drivers/omap3-sgx-modules/spinlock_3430.patch [new file with mode: 0644]
recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb

diff --git a/recipes/powervr-drivers/omap3-sgx-modules/spinlock_3430.patch b/recipes/powervr-drivers/omap3-sgx-modules/spinlock_3430.patch
new file mode 100644 (file)
index 0000000..18df302
--- /dev/null
@@ -0,0 +1,16 @@
+diff -urwp GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c
+--- GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c    2011-01-22 23:30:40.725170013 +0200
++++ GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c    2010-09-08 12:03:13.000000000 +0300
+@@ -107,10 +149,10 @@ static IMG_VOID PowerLockUnwrap(SYS_SPEC
+       {
+               PVR_ASSERT(PowerLockWrappedOnCPU(psSysSpecData));
+-              spin_unlock(&psSysSpecData->sPowerLock);
+-
+               atomic_set(&psSysSpecData->sPowerLockCPU, -1);
++              spin_unlock(&psSysSpecData->sPowerLock);
++
+               put_cpu();
+       }
+ }
index 348d8c9..b9686ac 100644 (file)
@@ -14,12 +14,13 @@ BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
 
 inherit module
 
-MACHINE_KERNEL_PR_append = "h"
+MACHINE_KERNEL_PR_append = "i"
 
 SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
            file://0002-Compile-fixes-for-recent-kernels.patch;patch=1 \
            file://0001-OMAP3-SGX-TI-4.00.00.01-2.6.37-rc1-use-semaphore-ove.patch;patch=1 \
            file://fix-2.6.27.patch;patch=1 \
+           file://spinlock_3430.patch;patch=1 \
 "
 
 SRC_URI[md5sum] = "a027002dcd7164df467b1a315788d5fd"