fuse: update to 2.5.3 and improve packaging:
authorKoen Kooi <koen@openembedded.org>
Mon, 8 May 2006 10:35:37 +0000 (10:35 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 8 May 2006 10:35:37 +0000 (10:35 +0000)
* the fuse-module package now ships the udev rules as well
* the fuse package has been split in libfuse2 and fuse-utils

packages/fuse/fuse-module_2.5.3.bb [new file with mode: 0644]
packages/fuse/fuse_2.5.3.bb [new file with mode: 0644]

diff --git a/packages/fuse/fuse-module_2.5.3.bb b/packages/fuse/fuse-module_2.5.3.bb
new file mode 100644 (file)
index 0000000..ae52ad0
--- /dev/null
@@ -0,0 +1,35 @@
+HOMEPAGE = "http://fuse.sf.net"
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+LICENSE = "GPL"
+
+
+DEPENDS = "fakeroot-native"
+RRECOMMEND = "fuse"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz"
+S = "${WORKDIR}/fuse-${PV}"
+
+inherit autotools pkgconfig module
+EXTRA_OECONF = "  --with-kernel=${STAGING_KERNEL_DIR}"
+
+do_configure() {
+cd ${S} ; oe_runconf
+}
+
+do_compile(){
+LDFLAGS=""
+cd ${S}/kernel
+oe_runmake
+}
+
+fakeroot do_install() {
+LDFLAGS=""
+install -d ${D}${sysconfdir}/udev/rules.d/
+install -m 644 util/udev.rules ${D}${sysconfdir}/udev/rules.d/
+cd ${S}/kernel
+oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} = "/dev ${base_libdir}/modules ${sysconfdir}"
diff --git a/packages/fuse/fuse_2.5.3.bb b/packages/fuse/fuse_2.5.3.bb
new file mode 100644 (file)
index 0000000..229b38f
--- /dev/null
@@ -0,0 +1,30 @@
+HOMEPAGE = "http://fuse.sf.net"
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+LICENSE_${PN} = "LGPL"
+
+DEPENDS = "fakeroot-native"
+RRECOMMENDS_${PN} = "fuse-module"
+
+#package utils in a sperate package and stop debian.bbclass renaming it to libfuse-utils, we want it to be fuse-utils 
+PACKAGES += "fuse-utils"
+FILES_${PN} = "${libdir}/*.so*"
+FILES_${PN}-dev += "${libdir}/*.la"
+FILES_fuse-utils = "${bindir} ${base_sbindir}"
+DEBIAN_NOAUTONAME_fuse-utils = "1"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/fuse/${P}.tar.gz"
+
+inherit autotools pkgconfig
+EXTRA_OECONF = " --disable-kernel-module"
+
+fakeroot do_install() {
+oe_runmake install DESTDIR=${D}
+}
+
+fakeroot do_stage() {
+autotools_stage_all
+}
+
+