xserver-common: Add 1.32 - still with DEFAULT_PREFERENCE -1 but expexted to work.
authorFlorian Boor <florian@kernelconcepts.de>
Mon, 28 Sep 2009 09:00:57 +0000 (11:00 +0200)
committerFlorian Boor <florian@kernelconcepts.de>
Mon, 28 Sep 2009 09:00:57 +0000 (11:00 +0200)
recipes/xserver-common/xserver-common_1.32.bb [new file with mode: 0644]

diff --git a/recipes/xserver-common/xserver-common_1.32.bb b/recipes/xserver-common/xserver-common_1.32.bb
new file mode 100644 (file)
index 0000000..6336864
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
+PR = "r0"
+
+PACKAGE_ARCH = "all"
+DEFAULT_PREFERENCE = "-1"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh \
+                   file://89xdgautostart.sh"
+
+do_install_append() {
+       install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+       install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
+       sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/Xserver
+}