jacl 1.4.1: New recipe (from Jalimo SVN).
authorRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 12:16:00 +0000 (14:16 +0200)
committerRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 12:16:00 +0000 (14:16 +0200)
jacl-native 1.4.1: Dito.

recipes/jacl/jacl-native_1.4.1.bb [new file with mode: 0644]
recipes/jacl/jacl_1.4.1.bb [new file with mode: 0644]

diff --git a/recipes/jacl/jacl-native_1.4.1.bb b/recipes/jacl/jacl-native_1.4.1.bb
new file mode 100644 (file)
index 0000000..b0a0638
--- /dev/null
@@ -0,0 +1,4 @@
+require jacl_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/jacl/jacl_1.4.1.bb b/recipes/jacl/jacl_1.4.1.bb
new file mode 100644 (file)
index 0000000..7c66c3e
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Tcl interpreter for Java"
+LICENSES = "BSD"
+
+HOMEPAGE = "http://sourceforge.net/projects/tcljava"
+
+SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/jacl${PV}"
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+  mkdir -p build
+
+  javac -sourcepath src/tcljava:src/jacl -d build `find src/tcljava src/jacl -name "*.java"`
+
+  fastjar -C build -c -f ${JARFILENAME} .
+}