uclibc, alsa, monotone-5, util-linux: enable thumb on ucslugc, disable it on these...
authorJohn Bowler <jbowler@nslu2-linux.org>
Fri, 9 Sep 2005 22:47:04 +0000 (22:47 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Fri, 9 Sep 2005 22:47:04 +0000 (22:47 +0000)
This commit causes thumb build for everything in ucslugc-packages except
these packages and libgcc (from gcc).  libgcc and uclibc still need some
work, the other packages reveal compiler bugs (monotone), source bugs
(alsa) or missing configuration (thumb arch support in util-linux) and so
are disabled for the moment.

conf/distro/ucslugc.conf
packages/alsa/alsa-lib_1.0.8.bb
packages/monotone/monotone-5_0.22.bb
packages/uclibc/uclibc_0.9.28.bb
packages/util-linux/util-linux_2.12q.bb

index b71352d..1ce5493 100644 (file)
@@ -15,7 +15,7 @@ TARGET_OS = "linux-uclibc"
 
 # Select thumb-interwork and (TBD) thumb
 ARM_INTERWORK = ":thumb-interwork"
-#ARM_INSTRUCTION_SET = ":thumb"
+ARM_INSTRUCTION_SET = ":thumb"
 
 USE_NLS ?= "no"
 USE_NLS_glib-2.0 = "yes"
index a58b21f..49ee525 100644 (file)
@@ -4,6 +4,12 @@ SECTION = "libs/multimedia"
 LICENSE = "GPL"
 PR = "r1"
 
+# configure.in sets -D__arm__ on the command line for any arm system
+# (not just those with the ARM instruction set), this should be removed,
+# (or replaced by a permitted #define).
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = ""
+
 SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
 
 inherit autotools pkgconfig
index c646fc2..6de29e5 100644 (file)
@@ -1,3 +1,8 @@
+# Release 0.22 reveals bugs in g++ for thumb (g++ generates
+# relocations which the linker cannot represent)
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = ""
+
 include monotone.inc
 
 PR = "r0"
index 246e9bc..8805f9f 100644 (file)
@@ -1,5 +1,5 @@
 DEFAULT_PREFERENCE = "1"
-PR = "r1"
+PR = "r2"
 
 include uclibc.inc
 
@@ -12,6 +12,9 @@ SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2"
 
 S = "${WORKDIR}/uClibc-${PV}"
 
+# At present the thumb implementation is non-functional
+ARM_INSTRUCTION_SET = ""
+
 #*** PATCHES ***
 #
 # The nokernelheadercheck patch removes the check on the include
index 152e5fe..93b96cb 100644 (file)
@@ -1,3 +1,7 @@
+# fdisk gets a #error unknown architecture when compiling for ARM thumb
+#FIXME: remove this
+ARM_INSTRUCTION_SET = ""
+
 include util-linux.inc
 
 PR = "r2"