gnuplot: fix QA errors, unify, add opie terminal, closes #2299
authorJunqian Gordon Xu <xjqian@gmail.com>
Fri, 16 Nov 2007 12:41:47 +0000 (12:41 +0000)
committerKoen Kooi <koen@openembedded.org>
Fri, 16 Nov 2007 12:41:47 +0000 (12:41 +0000)
MAINTAINERS
packages/gnuplot/files/gnuplot.desktop
packages/gnuplot/gnuplot-4.2.0/term.patch [new file with mode: 0644]
packages/gnuplot/gnuplot.inc [new file with mode: 0644]
packages/gnuplot/gnuplot_4.0.0.bb
packages/gnuplot/gnuplot_4.2.0.bb

index 1e6b982..0b039be 100644 (file)
@@ -90,6 +90,12 @@ Person:     Joaquim Duran
 Mail:       joaquinduran@adtelecom.es
 Recipes:    gtk+, gtkmm
 
+Person:     Junqian Gordon Xu 'xjqian'
+Mail:       xjqian@gmail.com
+Machines:   tosa, borzoi, nokia770
+Distros:    Ångström
+Recipes:    gnuplot
+
 Person:     Justin Patrin
 Mail:       papercrane@reversefold.com
 Website:    http://www.reversefold.com
index f108e3f..f67df9e 100644 (file)
@@ -2,7 +2,7 @@
 Name=Gnuplot
 Comment=Plot data and function graphs
 Exec=x-terminal-emulator -e gnuplot
-Terminal=0
+Terminal=false
 Type=Application
-Icon=gnuplot.png
-Categories=Scientific
+Icon=gnuplot
+Categories=Science;
diff --git a/packages/gnuplot/gnuplot-4.2.0/term.patch b/packages/gnuplot/gnuplot-4.2.0/term.patch
new file mode 100644 (file)
index 0000000..41aa8e7
--- /dev/null
@@ -0,0 +1,20 @@
+--- gnuplot-4.2.0/src/term.h.old       2007-11-16 01:21:09.000000000 -0600
++++ gnuplot-4.2.0/src/term.h   2007-11-16 01:22:45.000000000 -0600
+@@ -70,6 +70,7 @@
+  */
+ #ifdef SHORT_TERMLIST
+ # include "dumb.trm"          /* dumb terminal */
++# include "qtopia.trm"         /* QTopia terminal */
+ # ifdef GP_ENH_EST
+ #  include "estimate.trm"     /* used for enhanced text processing */
+@@ -436,6 +437,9 @@
+ /* TeXDraw drawing package for LaTeX */
+ #include "texdraw.trm"
++/* Qtopia */
++#include "qtopia.trm"
++
+ /* METAFONT */
+ #include "metafont.trm"
diff --git a/packages/gnuplot/gnuplot.inc b/packages/gnuplot/gnuplot.inc
new file mode 100644 (file)
index 0000000..9f1eebf
--- /dev/null
@@ -0,0 +1,37 @@
+DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
+(text or binary) and function plotting utility."
+HOMEPAGE = "http://www.gnuplot.info/"
+SECTION = "console/scientific"
+LICENSE = "BSD-4"
+PRIORITY = "optional"
+DEPENDS = "pango cairo virtual/libx11 libpng gd readline"
+
+inherit autotools
+
+acpaths = ""
+
+EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
+               --without-plot \
+               --with-png=${STAGING_LIBDIR}/.. \
+               --with-gd=${STAGING_LIBDIR}/.. \
+               --without-lisp-files \
+               --without-tutorial"
+
+do_compile_prepend() {
+       install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
+}
+
+do_install_append() {
+       install -d ${D}${datadir}/applications/
+       install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
+       install -d ${D}${datadir}/pixmaps/
+       install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
+}
+
+PACKAGES =+ "${PN}-x11-dbg ${PN}-x11"
+DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
+SECTION_${PN}-x11 = "x11/scientific"
+FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
+
+FILES_${PN} += "${datadir}/texmf"
+FILES_${PN}-x11-dbg += "${libexecdir}/gnuplot/*/.debug"
index 150fc8d..6e1be52 100644 (file)
@@ -1,10 +1,6 @@
-DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
-(text or binary) and function plotting utility."
-SECTION = "console/scientific"
-LICENSE = "BSD-4"
-PRIORITY = "optional"
-DEPENDS = "virtual/libx11 libpng gd readline"
-PR = "r3"
+require gnuplot.inc
+
+PR = "r4"
 
 SRC_URI = "ftp://ftp.gnuplot.info/pub/gnuplot/gnuplot-${PV}.tar.gz \
           file://subdirs.patch;patch=1 \
@@ -14,29 +10,3 @@ SRC_URI = "ftp://ftp.gnuplot.info/pub/gnuplot/gnuplot-${PV}.tar.gz \
           file://term.patch;patch=1 \
           file://gnuplot.desktop \
           file://gnuplot.png"
-
-inherit autotools
-
-PACKAGES =+ "${PN}-x11"
-DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
-SECTION_${PN}-x11 = "x11/scientific"
-FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps"
-
-acpaths = ""
-EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
-               --without-plot \
-               --with-png=${STAGING_LIBDIR}/.. \
-               --with-gd=${STAGING_LIBDIR}/.. \
-               --without-lisp-files \
-               --without-tutorial"
-
-do_compile_prepend() {
-       install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
-}
-
-do_install_append() {
-       install -d ${D}${datadir}/applications/
-       install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
-       install -d ${D}${datadir}/pixmaps/
-       install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
-}
index d750aac..1df0c9f 100644 (file)
@@ -1,40 +1,10 @@
-DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
-(text or binary) and function plotting utility."
-SECTION = "console/scientific"
-LICENSE = "BSD-4"
-PRIORITY = "optional"
-DEPENDS = "pango cairo virtual/libx11 libpng gd readline"
-PR = "r0"
+require gnuplot.inc
+
+PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz \
+           http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz \
           file://subdirs.patch;patch=1 \
+           file://term.patch;patch=1 \
           file://gnuplot.desktop \
           file://gnuplot.png"
-
-inherit autotools
-
-acpaths = ""
-EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
-               --without-plot \
-               --with-png=${STAGING_LIBDIR}/.. \
-               --with-gd=${STAGING_LIBDIR}/.. \
-               --without-lisp-files \
-               --without-tutorial"
-
-do_install_append() {
-       install -d ${D}${datadir}/applications/
-       install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
-       install -d ${D}${datadir}/pixmaps/
-       install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
-}
-
-
-PACKAGES =+ "${PN}-x11-dbg ${PN}-x11"
-DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
-SECTION_${PN}-x11 = "x11/scientific"
-FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
-
-FILES_${PN} += "${datadir}/texmf"
-FILES_${PN}-x11-dbg += "${libexecdir}/gnuplot/*/.debug"
-
-