libogg: update to version 1.1.4
authorHenning Heinold <heinold@inf.fu-berlin.de>
Wed, 25 Nov 2009 19:07:25 +0000 (20:07 +0100)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Mon, 30 Nov 2009 01:00:13 +0000 (02:00 +0100)
* switch to INC_PR and use the reworked autotools functions
* bump PR

conf/checksums.ini
recipes/libogg/libogg.inc [new file with mode: 0644]
recipes/libogg/libogg_1.0.bb
recipes/libogg/libogg_1.1.3.bb
recipes/libogg/libogg_1.1.4.bb [new file with mode: 0644]
recipes/libogg/libogg_1.1.bb

index 43dfb5a..a881d6b 100644 (file)
@@ -15682,6 +15682,10 @@ sha256=920fa2a0924d66884825d36a2e843de069cfdf1af01945d05da25999bbd6396c
 md5=eaf7dc6ebbff30975de7527a80831585
 sha256=bae29e79fbc50bbedf1235852094b71c8c910a1ef0cd42fe4163b7b545630b65
 
+[http://downloads.xiph.org/releases/ogg/libogg-1.1.4.tar.gz]
+md5=10200ec22543841d9d1c23e0aed4e5e9
+sha256=9354c183fd88417c2860778b60b7896c9487d8f6e58b9fec3fdbf971142ce103
+
 [http://www.vorbis.com/files/1.0.1/unix/libogg-1.1.tar.gz]
 md5=461d7097bf47864b872085a94ff94e10
 sha256=01453d561255b5fcb361997904752860e4f8c6b9742f290578a44615fcc94356
diff --git a/recipes/libogg/libogg.inc b/recipes/libogg/libogg.inc
new file mode 100644 (file)
index 0000000..f8eed60
--- /dev/null
@@ -0,0 +1,11 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+
+INC_PR = "r4"
+
+inherit autotools
+
+SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
index 7af1468..d5bad18 100644 (file)
@@ -1,18 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r1"
+require libogg.inc
 
-SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
 
-inherit autotools pkgconfig
-
-do_stage () {
-       oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
-       install -d ${STAGING_INCDIR}/ogg
-       (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
-       install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
index 0a6e827..d5bad18 100644 (file)
@@ -1,17 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
+require libogg.inc
 
-SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
 
-inherit autotools pkgconfig
-
-do_stage () {
-       oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
-       install -d ${STAGING_INCDIR}/ogg
-       (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
-       install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libogg_1.1.4.bb b/recipes/libogg/libogg_1.1.4.bb
new file mode 100644 (file)
index 0000000..d5bad18
--- /dev/null
@@ -0,0 +1,4 @@
+require libogg.inc
+
+PR = "${INC_PR}.0"
+
index 687b4de..0baec12 100644 (file)
@@ -1,19 +1,6 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r3"
+require libogg.inc
 
-SRC_URI = "http://www.vorbis.com/files/1.0.1/unix/libogg-${PV}.tar.gz \
-file://m4.patch;patch=1"
+PR = "${INC_PR}.0"
 
-inherit autotools pkgconfig
+SRC_URI += "file://m4.patch;patch=1"
 
-do_stage () {
-       oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
-       install -d ${STAGING_INCDIR}/ogg
-       (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
-       install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}