task-shr: new task for SHR distribution
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:08:23 +0000 (09:08 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:57:21 +0000 (09:57 +0100)
recipes/tasks/task-shr-feed.bb [new file with mode: 0644]
recipes/tasks/task-shr-minimal.bb [new file with mode: 0644]
recipes/tasks/task-shr.bb [new file with mode: 0644]

diff --git a/recipes/tasks/task-shr-feed.bb b/recipes/tasks/task-shr-feed.bb
new file mode 100644 (file)
index 0000000..08d15ad
--- /dev/null
@@ -0,0 +1,242 @@
+DESCRIPTION = "SHR Feed"
+PR = "r25"
+PV = "1.0"
+LICENSE = "GPL"
+
+inherit task
+
+RDEPENDS_${PN} += "\
+               python-elementary \
+               openmoko-agpsui \
+               mc \
+               mplayer \
+               x11vnc \
+               omview \
+               openvpn \
+               navit \
+               pythm \
+               fbreader \
+               omoney \
+               enotes \
+               epdfview \
+               pyphonelog \
+               pingus \
+               openmoocow \
+               dosbox \
+               vagalume \
+               python-pygame \
+               mokoko \
+               exhibit \
+               edje-viewer \
+               obexpush \
+               obexftp \
+               mtpaint \
+               telepathy-python \
+               intone-video \
+               ipkg-link \
+               ipkg-utils \
+               mysql \
+               gpe-calendar \
+               gpe-todo \
+               gpe-scap \
+               gpe-sketchbook \
+               gpe-filemanager \
+               gpe-gallery \
+               gpe-timesheet \
+               gpe-contacts \
+               fltk-chess \
+               remoko \
+#              shr-config \
+               shr-today \
+                shr-theme-neo \
+               shr-theme-niebiee \
+               shr-theme-sixteen \
+# gry should be in image already
+#              shr-theme-gry \
+               shr-splash \
+               shr-splash-theme-simple \
+               shr-splash-theme-dontpanic \
+               shr-splash-theme-handy \
+               openbmap-logger \
+               pisi \
+               ffalarms \
+               libnotify \
+               accelges \
+               ebrainy \
+               sms-sentry \
+               cellhunter \
+               dillo2 \
+               usbmode \
+               pyefl-sudoku \
+               tasks \
+               dates \
+               omnewrotate \
+               xchat \
+               python-pyid3lib \
+#              libframeworkd-phonegui-efl2 \
+               intone \
+               vim \
+               vpnc \
+               emacs \
+               mcabber \
+               gdb \
+               oh-puzzles \
+               links-x11 \
+               e-wm-illume-dict-pl \
+               callrec \
+               dictator \
+               midori \
+               numptyphysics \
+               pidgin \
+               libpurple-protocol-msn \
+               libpurple-protocol-icq \
+               vagalume \
+               ppp \
+               bluez-hcidump \
+               kbdd \
+               kexec-tools \
+               claws-mail \
+               claws-plugin-mailmbox \
+#              claws-plugin-gtkhtml2-viewer \
+               claws-plugin-rssyl \
+               mc \
+               iotop \
+               xprop \
+               xev \
+               xwininfo \
+               tcpdump \
+               lsof \
+               zsh \
+               gzip \
+               zip \
+               microcom \
+               minicom \
+               leafpad \
+               abiword \
+               aspell \
+               enchant \
+               joe \
+               nano \
+               ntpclient \
+               ntp \
+               tor \
+               vnc \
+#              gpsdrive \
+               wxwidgets \
+               x11vnc \
+               xf86-video-glamo \
+#              libswt3.4-gtk-java \
+               cacao \
+#              jamvm \
+               dbus-x11 \
+               bluez-utils-alsa \
+               python-pybluez \
+               xournal \
+               evince \
+#              asterisk \
+               git \
+               ruby \
+               orrery \
+               synergy \
+               irssi \
+               zhone \
+               paroli \
+               cu \
+               net-tools \
+               iproute2 \
+               iputils \
+               i2c-tools \
+               psmisc \
+               debianutils \
+               tcptraceroute \
+               task-proper-tools \
+               wmiconfig \
+               netkit-telnet \
+               bind-utils \
+               bubble-keyboard \
+               intuition \
+               gridpad \
+#              essential-dialer \
+               font-adobe-100dpi \
+               font-adobe-75dpi \
+               font-adobe-utopia-100dpi \
+               font-adobe-utopia-75dpi \
+#              font-adobe-utopia-type1 \
+               font-arabic-misc \
+               font-bh-100dpi \
+               font-bh-75dpi \
+               font-bh-lucidatypewriter-100dpi \
+               font-bh-lucidatypewriter-75dpi \
+#              font-bh-ttf \
+#              font-bh-type1 \
+               font-bitstream-100dpi \
+               font-bitstream-75dpi \
+               font-bitstream-speedo \
+#              font-bitstream-type1 \
+               font-cronyx-cyrillic \
+               font-cursor-misc \
+               font-daewoo-misc \
+               font-dec-misc \
+#              font-ibm-type1 \
+               font-isas-misc \
+               font-jis-misc \
+               font-micro-misc \
+               font-misc-cyrillic \
+#              font-misc-ethiopic \
+#              font-misc-meltho \
+               font-misc-misc \
+               font-mutt-misc \
+               font-schumacher-misc \
+               font-screen-cyrillic \
+               font-sony-misc \
+               font-sun-misc \
+               font-winitzki-cyrillic \
+#              font-xfree86-type1 \
+#              msn-pecan \
+               erminig \
+               qwo \
+               fso-apm \
+               fso-abyss \
+               fsousaged \
+               fsodeviced \
+               fsonetworkd \
+               fsotimed \
+               opimd-utils \
+               omgps \
+               shr-launcher \
+               e-tasks \
+               elmdentica \
+               shr-installer \
+               eject \
+               illume-keyboard-german \
+               illume-keyboard-arabic \
+               illume-keyboard-browse \
+               illume-keyboard-danish \
+               illume-keyboard-default-alt \
+               illume-keyboard-dutch \
+               illume-keyboard-dvorak \
+               illume-keyboard-french \
+               illume-keyboard-hebrew \
+               illume-keyboard-numeric-alt \
+               illume-keyboard-russian-terminal \
+               illume-keyboard-russian \
+               python-xlib \
+               xcompmgr \
+               man \
+               man-pages \
+               aceofpenguins-launcher \
+               om-neon \
+               ipython \
+               phoneme-advanced-foundation \
+               eve \
+               python-pybluez \
+               x11perf \
+               pyring \
+               bt-configure \
+               bt-gps \
+               advancedcaching \
+               glamo-dri-tests \
+               reiserfsprogs \
+               blipomoko \
+               imagemagick \
+"
diff --git a/recipes/tasks/task-shr-minimal.bb b/recipes/tasks/task-shr-minimal.bb
new file mode 100644 (file)
index 0000000..9b5ae8c
--- /dev/null
@@ -0,0 +1,149 @@
+DESCRIPTION = "SHR Lite Image Feed"
+PR = "r15"
+PV = "2.0"
+LICENSE = "GPL"
+
+inherit task
+
+def get_rdepends(bb, d):
+    enabled = bb.data.getVar("ENABLE_BINARY_LOCALE_GENERATION", d, 1)
+
+    # If locale is disabled, bail out
+    if not enabled:
+        return
+
+    locales = bb.data.getVar("GLIBC_GENERATE_LOCALES", d, 1)
+    if not locales or locales == "all":
+        locales = bb.data.getVar("IMAGE_LINGUAS", d, 1);
+
+    libc = bb.data.getVar('LIBC', d, 1)
+    import re
+
+    rdepends = ""
+    if not locales or locales == "all":
+        # if locales aren't specified, or user has written "all"
+        import os
+        ipkdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
+
+        regexp1 = re.compile(libc+"-binary-localedata-.*") # search pattern
+        regexp2 = re.compile("_.*") # we want to remove all version info and file extension
+
+        for root, subFolders, files in os.walk(ipkdir):
+            for file in files:
+                if regexp1.search(file):
+                    file = regexp2.sub("", file)
+                    rdepends = "%s %s" % (rdepends, file)
+
+    else:
+        # if locales are specified
+        regexp1 = re.compile("\\..*") # We want to turn en_US.UTF-8 into en_US
+        regexp2 = re.compile("_")     # We want to turn en_US into en-US
+
+
+        for locale in locales.split(" "):
+            locale = regexp1.sub("", locale)
+            locale = regexp2.sub("-", locale)
+            locale = str.lower(locale)
+            rdepends = "%s %s-binary-localedata-%s" % (rdepends, libc, locale)
+    return rdepends
+
+
+
+
+PACKAGES += "\
+       ${PN}-base \
+       ${PN}-cli \
+       ${PN}-fso \
+       ${PN}-audio \
+       ${PN}-x \
+       ${PN}-apps \
+       ${PN}-gtk \
+"
+
+
+
+RDEPENDS_${PN}-base = "\
+  netbase \
+  sysfsutils \
+  modutils-initscripts \
+  module-init-tools-depmod \
+  rsync \
+  screen \
+  fbset \
+  fbset-modes \
+  openssh-sftp-server \
+  cron \
+  logrotate\
+  util-linux-ng-fdisk \
+  shr-splash \
+"
+
+RDEPENDS_${PN}-cli = "\
+  screen \
+  nano \
+  iptables \
+  mtd-utils \
+  s3c24xx-gpio \
+  mickeydbus \
+  mickeyterm \
+"
+
+RDEPENDS_${PN}-fso = "\
+  fsoraw \
+  opimd-utils-cli \
+  python-codecs \
+  python-gst \
+"
+
+
+RDEPENDS_${PN}-audio = "\
+  alsa-utils-aplay \
+  alsa-utils-amixer \
+"
+
+RDEPENDS_${PN}-audio_append_om-gta01 = "\
+  alsa-scenarii-shr \
+"
+
+RDEPENDS_${PN}-audio_append_om-gta02 =  "\
+  alsa-scenarii-shr \
+"
+
+RDEPENDS_${PN}-x = "\
+  glibc-utils \
+  glibc-charmap-utf-8 \
+  e-wm-config-illume-shr \
+  shr-theme-gry \
+  etk-theme-shr \
+  ${@get_rdepends(bb, d)} \
+  libx11-locale \
+  libmokoui2 \
+  xcursor-transparent-theme \
+"
+
+RDEPENDS_${PN}-apps = "\
+  fso-abyss \
+  phoneui-apps-messages \
+  phoneui-apps-contacts \
+  phoneui-apps-dialer \
+  phonefsod \
+  phoneuid \
+  libphone-ui \
+  libphone-ui-shr \
+  ffalarms \
+  shr-settings \
+  shr-theme \
+  shr-today \
+  calc \
+"
+
+
+RDEPENDS_${PN}-gtk = "\
+  openmoko-icon-theme-standard2 \
+  shr-theme-gtk-e17lookalike \
+  vala-terminal \
+  tangogps \
+  pyphonelog \
+  matchbox-keyboard-im \
+"
+
diff --git a/recipes/tasks/task-shr.bb b/recipes/tasks/task-shr.bb
new file mode 100644 (file)
index 0000000..25e1b17
--- /dev/null
@@ -0,0 +1,35 @@
+DESCRIPTION = "SHR Fat Image Feed"
+PR = "r3"
+PV = "2.0"
+LICENSE = "GPL"
+
+inherit task
+
+PACKAGES = "\
+  ${PN}-gtk \
+  ${PN}-apps \
+  ${PN}-games \
+"
+
+RDEPENDS_${PN}-gtk = "\
+  gpe-scap \
+  pidgin \
+  libpurple-protocol-msn \
+  libpurple-protocol-icq \
+  vagalume \
+  gpe-sketchbook \ 
+"
+
+RDEPENDS_${PN}-apps += "\
+   task-shr-minimal-apps \
+       opimd-utils-notes \
+       mokonnect \
+       midori \
+       intone \
+"
+
+RDEPENDS_${PN}-games += "\
+       mokomaze \
+       numptyphysics \
+"
+