psplash: yet another hack for new kernel
authorGrazvydas Ignotas <notasas@gmail.com>
Wed, 15 Feb 2012 16:23:42 +0000 (18:23 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Wed, 15 Feb 2012 16:23:42 +0000 (18:23 +0200)
also first-boot-logo-hide hack amended because I'm lazy

recipes/psplash/psplash-omap3pandora/psplash-init
recipes/psplash/psplash-omap3pandora_svn.bb

index 30ad603..9d07e21 100644 (file)
@@ -1,10 +1,21 @@
 #!/bin/sh 
 
+# nasty pandora hack for Zaxxon #7549: switch to 16bpp now because:
+# - X startup will glitch due to similar mode change hack in slim-init
+# - SGX may init in 32bpp mode and after switch to 16bpp,
+#   it will still render at 32bpp (yet another bug..)
+fbset -depth 16
+
 if grep -qE '\s?psplash=false\s?' /proc/cmdline; then
        echo "Boot splashscreen disabled"
        exit 0;
 fi
 
+if [ -e /etc/rcS.d/S98configure ]; then
+       echo "First boot, splashscreen disabled"
+       exit 0;
+fi
+
 . /etc/init.d/functions
 . /etc/default/psplash
 
index debc4bc..292bafe 100755 (executable)
@@ -1,7 +1,7 @@
 require psplash.inc
 require psplash-ua.inc
 
-PR = "${INC_PR}.30"
+PR = "${INC_PR}.31"
 
 ALTERNATIVE_PRIORITY = "30"
 ALTERNATIVE_PRIORITY_omap3pandora = "5"