icommand-bluez 0.7: New recipe (from Jalimo SVN).
authorRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 12:32:58 +0000 (14:32 +0200)
committerRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 12:32:58 +0000 (14:32 +0200)
recipes/icommand/files/makefile.patch [new file with mode: 0644]
recipes/icommand/icommand-bluez_0.7.bb [new file with mode: 0644]

diff --git a/recipes/icommand/files/makefile.patch b/recipes/icommand/files/makefile.patch
new file mode 100644 (file)
index 0000000..3377f46
--- /dev/null
@@ -0,0 +1,42 @@
+Index: Release/makefile
+===================================================================
+--- Release.orig/makefile      2008-02-21 14:39:13.000000000 +0100
++++ Release/makefile   2008-02-21 15:31:48.000000000 +0100
+@@ -4,6 +4,8 @@
+ -include ../makefile.init
++CC?=gcc
++
+ RM := rm -rf
+ # All of the sources participating in the build are defined here
+@@ -28,7 +30,7 @@
+ libicmdbluez.so: $(OBJS) $(USER_OBJS)
+       @echo 'Building target: $@'
+       @echo 'Invoking: GCC C Linker'
+-      gcc -shared -o"libicmdbluez.so" $(OBJS) $(USER_OBJS) $(LIBS)
++      $(CC) $(LDFLAGS) -shared -o"libicmdbluez.so" $(OBJS) $(USER_OBJS) $(LIBS)
+       @echo 'Finished building target: $@'
+       @echo ' '
+Index: Release/subdir.mk
+===================================================================
+--- Release.orig/subdir.mk     2008-02-21 14:39:13.000000000 +0100
++++ Release/subdir.mk  2008-02-21 15:30:36.000000000 +0100
+@@ -12,12 +12,14 @@
+ C_DEPS += \
+ ./icmdbluez.d 
++CC?=gcc
++
+ # Each subdirectory must supply rules for building sources it contributes
+ %.o: ../%.c
+       @echo 'Building file: $<'
+       @echo 'Invoking: GCC C Compiler'
+-      gcc -I/usr/include/bluetooth -I/usr/lib/jvm/java-6-sun/include -I/usr/lib/jvm/java-6-sun/include/linux -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
++      $(CC) $(CFLAGS) $(INCLUDES) -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
+       @echo 'Finished building: $<'
+       @echo ' '
diff --git a/recipes/icommand/icommand-bluez_0.7.bb b/recipes/icommand/icommand-bluez_0.7.bb
new file mode 100644 (file)
index 0000000..70d78f0
--- /dev/null
@@ -0,0 +1,34 @@
+DESCRIPTION = "iCommand bluez binding"
+LICENSE = "LGPL"
+SECTION = "libs"
+HOMEPAGE = "http://sourceforge.net/projects/nxtcommand/"
+AUTHOR = "Brian Bagnall <bbagnall at users.sourceforge.net>"
+
+inherit java
+
+SRC_URI = "\
+    svn://nxtcommand.svn.sourceforge.net/svnroot/nxtcommand;module=icommand-projects/trunk/icommand-bluez;rev=134;proto=https \
+    file://makefile.patch;patch=1 \
+    "
+
+DEPENDS = "bluez-libs"
+
+S = "${WORKDIR}/icommand-projects/trunk/icommand-bluez/Release"
+
+do_compile() {
+  oe_runmake -f makefile clean
+  oe_runmake -f makefile all \
+    INCLUDES="-I${STAGING_INCDIR}/classpath " \
+    LIBS="-lbluetooth"
+}
+
+do_install() {
+  oe_libinstall -so libicmdbluez  ${D}${libdir_jni}
+}
+
+PACKAGES = "${PN}-jni ${PN}-jni-dbg"
+
+RDEPENDS_${PN}-jni = "bluez-libs"
+
+FILES_${PN}-jni = "${libdir_jni}/lib*.so"
+FILES_${PN}-jni-dbg = "${libdir_jni}/.debug/lib*.so"