bluez: fix problems with CONFFILES, rfcomm.conf goes into -compat
authorKoen Kooi <koen@openembedded.org>
Wed, 19 Sep 2007 07:59:01 +0000 (07:59 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 19 Sep 2007 07:59:01 +0000 (07:59 +0000)
packages/bluez/bluez-utils3.inc
packages/bluez/bluez-utils_3.18.bb
packages/bluez/bluez-utils_3.19.bb

index ddf90a2..8f78729 100644 (file)
@@ -76,6 +76,7 @@ do_install_append() {
        rmdir ${D}${bindir} ${D}${sbindir}
        chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
        install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
+        install -m 0644 ${S}/rfcomm/rfcomm.conf ${D}${sysconfdir}/bluetooth/
         install -m 0755 ${S}/daemon/.libs/passkey-agent ${D}${base_bindir}/
 }
 
@@ -86,14 +87,6 @@ INITSCRIPT_PARAMS = "defaults 23 19"
 
 PACKAGES =+ "${PN}-compat"
 
-CONFFILES_${PN} = " \
-                   ${sysconfdir}/bluetooth/hcid.conf \
-                   ${sysconfdir}/default/bluetooth \
-                  "
-
-CONFFILES_${PN}-compat = " \
-                          ${sysconfdir}/bluetooth/rfcomm.conf \
-                        " 
 
 FILES_${PN} = " \
                ${base_sbindir}/hcid \
index c0a4f46..48f147a 100644 (file)
@@ -18,6 +18,12 @@ EXTRA_OECONF = " \
                 --enable-test \
                " 
 
+CONFFILES_${PN} = " \
+                   ${sysconfdir}/bluetooth/hcid.conf \
+                   ${sysconfdir}/default/bluetooth \
+                  "
+
+CONFFILES_${PN}-compat = " \
+                          ${sysconfdir}/bluetooth/rfcomm.conf \
+                         "
 
-CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
-       ${sysconfdir}/default/bluetooth"
\ No newline at end of file
index c0a4f46..48f147a 100644 (file)
@@ -18,6 +18,12 @@ EXTRA_OECONF = " \
                 --enable-test \
                " 
 
+CONFFILES_${PN} = " \
+                   ${sysconfdir}/bluetooth/hcid.conf \
+                   ${sysconfdir}/default/bluetooth \
+                  "
+
+CONFFILES_${PN}-compat = " \
+                          ${sysconfdir}/bluetooth/rfcomm.conf \
+                         "
 
-CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
-       ${sysconfdir}/default/bluetooth"
\ No newline at end of file