libwww-perl: direct PERL_ARCHLIB to STAGING_LIBDIR_NATIVE, instead of the host env
authorJunqian Gordon Xu <xjqian@gmail.com>
Mon, 4 Aug 2008 17:37:56 +0000 (17:37 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Mon, 4 Aug 2008 17:37:56 +0000 (17:37 +0000)
* CAVEAT: perl/5.8.8 has to be hard coded, needs to be updated with each new perl version

packages/perl/libwww-perl_5.808.bb

index 2bea48a..2bc9b76 100644 (file)
@@ -3,10 +3,14 @@ SECTION = "libs"
 LICENSE = "Artistic"
 DEPENDS = "liburi-perl-native"
 RDEPENDS = "liburi-perl"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/libwww-perl-${PV}.tar.gz"
 
 S = "${WORKDIR}/libwww-perl-${PV}"
 
 inherit cpan
+
+do_configure_append() {
+    sed -i -e "s|PERL_ARCHLIB = /usr/lib/perl/5.8|PERL_ARCHLIB = ${STAGING_LIBDIR_NATIVE}/perl/5.8.8|" Makefile
+}