add dtn, from the Delay Tolerant Networking Research Group
authorMichael Lauer <mickey@vanille-media.de>
Sat, 12 Jan 2008 15:22:07 +0000 (15:22 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sat, 12 Jan 2008 15:22:07 +0000 (15:22 +0000)
yes, this includes python-dtn (of course :)

packages/dtnrg/.mtn2git_empty [new file with mode: 0644]
packages/dtnrg/dtn_2.5.0.bb [new file with mode: 0644]

diff --git a/packages/dtnrg/.mtn2git_empty b/packages/dtnrg/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
new file mode 100644 (file)
index 0000000..a1111f1
--- /dev/null
@@ -0,0 +1,58 @@
+DESCRIPTION = "Delay Tolerant Networking Package"
+HOMEPAGE = "http://www.dtnrg.org/wiki"
+SECTION = "libs"
+DEPENDS = "db openssl python-native xerces-c"
+LICENSE = "Apache"
+SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+  --with-python=${STAGING_BINDIR_NATIVE}/python \
+  --with-db=${STAGING_DIR} \
+  --with-tcl=${STAGING_DIR} \
+  --without-google-perftools \
+  --without-bluez \
+  --without-bonjour \
+  --with-expat=${STAGING_DIR} \
+  --with-xerces-c=${STAGING_DIR} \
+  --without-tclreadline \
+  --with-zlib=${STAGING_DIR} \
+  --without-xsd-tool \
+  --with-db=${STAGING_DIR} \
+  --enable-ecl \
+  --enable-edp \
+  --without-mysql \
+  --without-postgres \
+  --with-openssl=${STAGING_DIR} \
+"
+
+def python_dir(d):
+        import os, bb
+        staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
+        if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
+        if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
+        if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
+        raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
+
+PYTHON_DIR = "${@python_dir(d)}"
+
+export BUILD_SYS
+export HOST_SYS
+
+do_configure_prepend() {
+       for i in aclocal/*.ac oasys/aclocal/*.ac; do
+               install -m 0644 $i ${STAGING_DATADIR}/aclocal/`basename $i`.m4
+       done
+       autotools_do_configure
+}
+
+do_install_append() {
+       cd applib/python
+       INCDIR=../.. LIBDIR=.. VERSION=${PV} python setup.py install --prefix=${D}/${prefix} --install-data=${D}/${datadir}
+}
+
+PACKAGES += "${PN}-python"
+FILES_${PN}-python = "${libdir}/${PYTHON_DIR}"
+RDEPENDS_${PN}-python = "python-core"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"