gcc: remove stale 4.2.0 snapshot
authorKoen Kooi <koen@openembedded.org>
Fri, 1 Jun 2007 08:25:11 +0000 (08:25 +0000)
committerKoen Kooi <koen@openembedded.org>
Fri, 1 Jun 2007 08:25:11 +0000 (08:25 +0000)
packages/gcc/gcc-4.2-20060513/.mtn2git_empty [deleted file]
packages/gcc/gcc-4.2-20060513/arm-nolibfloat.patch [deleted file]
packages/gcc/gcc-4.2-20060513/arm-softfloat.patch [deleted file]
packages/gcc/gcc-4.2-20060513/armeb-fix.patch [deleted file]
packages/gcc/gcc-4.2-20060513/ldflags.patch [deleted file]
packages/gcc/gcc-4.2-20060513/zecke-no-host-includes.patch [deleted file]
packages/gcc/gcc-4.2-20060513/zecke-xgcc-cpp.patch [deleted file]
packages/gcc/gcc-cross_4.2-20060513.bb [deleted file]
packages/gcc/gcc_4.2-20060513.bb [deleted file]

diff --git a/packages/gcc/gcc-4.2-20060513/.mtn2git_empty b/packages/gcc/gcc-4.2-20060513/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/gcc/gcc-4.2-20060513/arm-nolibfloat.patch b/packages/gcc/gcc-4.2-20060513/arm-nolibfloat.patch
deleted file mode 100644 (file)
index c4897c0..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-# Dimitry Andric <dimitry@andric.com>, 2004-05-01
-#
-# * Removed the extra -lfloat option from LIBGCC_SPEC, since it isn't needed
-#   anymore.  (The required functions are now in libgcc.)
-# 
-# Fixes errors like
-# arm-softfloat-linux-gnu/3.4.0/../../../../arm-softfloat-linux-gnu/bin/ld: cannot find -lfloat
-# collect2: ld returned 1 exit status
-# make[2]: *** [arm-softfloat-linux-gnu/gcc-3.4.0-glibc-2.3.2/build-glibc/iconvdata/ISO8859-1.so] Error 1
-# when building glibc-2.3.3 with gcc-3.4.0 for arm-softfloat
-
-Index: gcc-4.0.2/gcc/config/arm/linux-elf.h
-===================================================================
---- gcc-4.0.2.orig/gcc/config/arm/linux-elf.h  2005-03-04 16:14:01.000000000 +0000
-+++ gcc-4.0.2/gcc/config/arm/linux-elf.h       2005-11-11 18:02:54.000000000 +0000
-@@ -56,7 +56,7 @@
-    %{shared:-lc} \
-    %{!shared:%{profile:-lc_p}%{!profile:-lc}}"
--#define LIBGCC_SPEC "%{msoft-float:-lfloat} %{mfloat-abi=soft*:-lfloat} -lgcc"
-+#define LIBGCC_SPEC "-lgcc"
- /* Provide a STARTFILE_SPEC appropriate for GNU/Linux.  Here we add
-    the GNU/Linux magical crtbegin.o file (see crtstuff.c) which
diff --git a/packages/gcc/gcc-4.2-20060513/arm-softfloat.patch b/packages/gcc/gcc-4.2-20060513/arm-softfloat.patch
deleted file mode 100644 (file)
index c86c83e..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: gcc-4.0.2/gcc/config/arm/t-linux
-===================================================================
---- gcc-4.0.2.orig/gcc/config/arm/t-linux      2004-05-15 12:41:35.000000000 +0000
-+++ gcc-4.0.2/gcc/config/arm/t-linux   2005-11-11 16:07:53.000000000 +0000
-@@ -4,7 +4,10 @@
- LIBGCC2_DEBUG_CFLAGS = -g0
- LIB1ASMSRC = arm/lib1funcs.asm
--LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx
-+LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx \
-+    _negdf2 _addsubdf3 _muldivdf3 _cmpdf2 _unorddf2 _fixdfsi _fixunsdfsi \
-+    _truncdfsf2 _negsf2 _addsubsf3 _muldivsf3 _cmpsf2 _unordsf2 \
-+    _fixsfsi _fixunssfsi _floatdidf _floatdisf
- # MULTILIB_OPTIONS = mhard-float/msoft-float
- # MULTILIB_DIRNAMES = hard-float soft-float
diff --git a/packages/gcc/gcc-4.2-20060513/armeb-fix.patch b/packages/gcc/gcc-4.2-20060513/armeb-fix.patch
deleted file mode 100644 (file)
index 42bb4ea..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
---- gcc-4.0-20050305/gcc/config/arm/linux-elf.h.orig   2005-03-23 18:44:54.822707377 +0100
-+++ gcc-4.0-20050305/gcc/config/arm/linux-elf.h        2005-03-23 18:46:18.228560206 +0100
-@@ -31,19 +31,33 @@
- /* Do not assume anything about header files.  */
- #define NO_IMPLICIT_EXTERN_C
-+/*
-+ * 'config.gcc' defines TARGET_BIG_ENDIAN_DEFAULT as 1 for
-+ * arm*b-*-linux* (big endian) configurations.
-+ */
-+#if TARGET_BIG_ENDIAN_DEFAULT
-+#define TARGET_ENDIAN_DEFAULT ARM_FLAG_BIG_END
-+#define TARGET_ENDIAN_OPTION "mbig-endian"
-+#define TARGET_LINKER_EMULATION "armelfb_linux"
-+#else
-+#define TARGET_ENDIAN_DEFAULT 0
-+#define TARGET_ENDIAN_OPTION "mlittle-endian"
-+#define TARGET_LINKER_EMULATION "armelf_linux"
-+#endif
-+
- #undef  TARGET_DEFAULT_FLOAT_ABI
- #define TARGET_DEFAULT_FLOAT_ABI ARM_FLOAT_ABI_HARD
- #undef  TARGET_DEFAULT
--#define TARGET_DEFAULT (0)
-+#define TARGET_DEFAULT (TARGET_ENDIAN_DEFAULT)
- #define SUBTARGET_CPU_DEFAULT TARGET_CPU_arm6
--#define SUBTARGET_EXTRA_LINK_SPEC " -m armelf_linux -p"
-+#define SUBTARGET_EXTRA_LINK_SPEC " -m " TARGET_LINKER_EMULATION " -p"
- #undef  MULTILIB_DEFAULTS
- #define MULTILIB_DEFAULTS \
--      { "marm", "mlittle-endian", "mhard-float", "mno-thumb-interwork" }
-+      { "marm", TARGET_ENDIAN_OPTION, "mhard-float", "mno-thumb-interwork" }
- /* The GNU C++ standard library requires that these macros be defined.  */
- #undef CPLUSPLUS_CPP_SPEC
-@@ -90,7 +104,7 @@
-    %{rdynamic:-export-dynamic} \
-    %{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2} \
-    -X \
--   %{mbig-endian:-EB}" \
-+   %{mbig-endian:-EB} %{mlittle-endian:-EL}" \
-    SUBTARGET_EXTRA_LINK_SPEC
- #define TARGET_OS_CPP_BUILTINS()              \
---- gcc-4.0-20050305/gcc/config.gcc.orig       2005-03-23 18:46:23.318105335 +0100
-+++ gcc-4.0-20050305/gcc/config.gcc    2005-03-23 18:47:41.592546386 +0100
-@@ -650,6 +650,11 @@
-       ;;
- arm*-*-linux*)                        # ARM GNU/Linux with ELF
-       tm_file="dbxelf.h elfos.h linux.h arm/elf.h  arm/linux-gas.h arm/linux-elf.h arm/aout.h arm/arm.h"
-+      case $target in
-+      arm*b-*-linux*)
-+              tm_defines="${tm_defines} TARGET_BIG_ENDIAN_DEFAULT=1"
-+              ;;
-+      esac
-       tmake_file="${tmake_file} arm/t-arm arm/t-linux"
-       extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
-       gnu_ld=yes
diff --git a/packages/gcc/gcc-4.2-20060513/ldflags.patch b/packages/gcc/gcc-4.2-20060513/ldflags.patch
deleted file mode 100644 (file)
index 9576f60..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- /tmp/Makefile.in   2006-02-23 20:56:01.399758728 +0100
-+++ gcc-4.1-20060217/Makefile.in       2006-02-23 20:56:16.874406224 +0100
-@@ -334,7 +334,7 @@
- CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
- LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
- LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
--LDFLAGS_FOR_TARGET = 
-+LDFLAGS_FOR_TARGET = @LDFLAGS@ 
- PICFLAG_FOR_TARGET = 
- # ------------------------------------
---- /tmp/Makefile.tpl  2006-02-23 20:50:34.077519272 +0100
-+++ gcc-4.1-20060217/Makefile.tpl      2006-02-23 21:04:31.092273688 +0100
-@@ -337,7 +337,7 @@
- CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
- LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
- LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
--LDFLAGS_FOR_TARGET = 
-+LDFLAGS_FOR_TARGET = @LDFLAGS@ 
- PICFLAG_FOR_TARGET = 
- # ------------------------------------
diff --git a/packages/gcc/gcc-4.2-20060513/zecke-no-host-includes.patch b/packages/gcc/gcc-4.2-20060513/zecke-no-host-includes.patch
deleted file mode 100644 (file)
index 6afb10d..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-Index: gcc-4.0.2/gcc/c-incpath.c
-===================================================================
---- gcc-4.0.2.orig/gcc/c-incpath.c     2005-01-23 16:05:27.000000000 +0100
-+++ gcc-4.0.2/gcc/c-incpath.c  2006-05-15 21:23:02.000000000 +0200
-@@ -350,6 +350,26 @@
-   p->construct = 0;
-   p->user_supplied_p = user_supplied_p;
-+#ifdef CROSS_COMPILE
-+    /* A common error when cross compiling is including
-+    host headers. This code below will try to fail fast
-+    for cross compiling. Currently we consider /usr/include,
-+    /opt/include and /sw/include as harmful.  */
-+      {
-+              /* printf("Adding Path: %s\n", p->name ); */
-+              if( strstr(p->name, "/usr/include" ) == p->name ) {
-+                      fprintf(stderr, _("CROSS COMPILE Badness: /usr/include in INCLUDEPATH: %s\n"), p->name);
-+                      abort();
-+              } else if( strstr(p->name, "/sw/include") == p->name ) {
-+                      fprintf(stderr, _("CROSS COMPILE Badness: /sw/include in INCLUDEPATH: %s\n"), p->name);
-+                      abort();
-+              } else if( strstr(p->name, "/opt/include") == p->name ) {
-+                      fprintf(stderr, _("CROSS COMPILE Badness: /opt/include in INCLUDEPATH: %s\n"), p->name);
-+                      abort();
-+               }
-+      }
-+#endif
-+
-   add_cpp_dir_path (p, chain);
- }
diff --git a/packages/gcc/gcc-4.2-20060513/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2-20060513/zecke-xgcc-cpp.patch
deleted file mode 100644 (file)
index ba7d725..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: gcc-4.0.2/Makefile.in
-===================================================================
---- gcc-4.0.2.orig/Makefile.in 2006-08-06 13:17:09.000000000 +0200
-+++ gcc-4.0.2/Makefile.in      2006-08-06 13:18:35.000000000 +0200
-@@ -197,6 +197,7 @@
-       AS="$(AS_FOR_TARGET)"; export AS; \
-       CC="$(CC_FOR_TARGET)"; export CC; \
-       CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
-+      CPP="$(CC_FOR_TARGET) -E"; export CCP; \
-       CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
-       CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
-       CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \
diff --git a/packages/gcc/gcc-cross_4.2-20060513.bb b/packages/gcc/gcc-cross_4.2-20060513.bb
deleted file mode 100644 (file)
index 4e380c5..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-require gcc_${PV}.bb
-# path mangling, needed by the cross packaging
-require gcc-paths-cross.inc
-inherit cross
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
-# NOTE: split PR.  If the main .oe changes something that affects its *build*
-# remember to increment this one too.
-PR = "r1"
-
-DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
-PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
-
-# cross build
-require gcc3-build-cross.inc
-# cross packaging
-require gcc-package-cross.inc
-
-EXTRA_OECONF += "--with-mpfr=${STAGING_DIR}/${BUILD_SYS}"
diff --git a/packages/gcc/gcc_4.2-20060513.bb b/packages/gcc/gcc_4.2-20060513.bb
deleted file mode 100644 (file)
index 85fe468..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-PR = "r0"
-DESCRIPTION = "The GNU cc and gcc C compilers."
-HOMEPAGE = "http://www.gnu.org/software/gcc/"
-SECTION = "devel"
-LICENSE = "GPL"
-DEFAULT_PREFERENCE = "-1"
-
-inherit autotools gettext
-
-require gcc-package.inc
-
-SRC_URI = "http://ftp.nluug.nl/languages/gcc/snapshots/${PV}/gcc-${PV}.tar.bz2 \
-       file://arm-nolibfloat.patch;patch=1 \
-       file://arm-softfloat.patch;patch=1 \
-       file://zecke-xgcc-cpp.patch;patch=1 \
-       file://ldflags.patch;patch=1"
-
-SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-
-require gcc4-build.inc
-EXTRA_OECONF += "--disable-libssp"
-
-FORTRAN = ""
-HAS_GFORTRAN = ""
-HAS_G2C = "no"
-
-