matchbox-panel-0.9.3: fix uninitialised variable causing SIGBUS
authorGraham Gower <graham.gower@gmail.com>
Thu, 8 Oct 2009 17:16:41 +0000 (17:16 +0000)
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Fri, 9 Oct 2009 13:12:29 +0000 (15:12 +0200)
As reported here:
http://lists.o-hand.com/matchbox/0289.html

I've not experienced the bug for over a month since applying this change.

Signed-off-by: Graham Gower <graham.gower@gmail.com>
Signed-off-by: Holger Hans Peter Freyther <zecke@selfish.org>
Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
recipes/matchbox-panel/matchbox-panel-0.9.3/matchbox-panel-uninitialised-crash.patch [new file with mode: 0644]
recipes/matchbox-panel/matchbox-panel_0.9.3.bb

diff --git a/recipes/matchbox-panel/matchbox-panel-0.9.3/matchbox-panel-uninitialised-crash.patch b/recipes/matchbox-panel/matchbox-panel-0.9.3/matchbox-panel-uninitialised-crash.patch
new file mode 100644 (file)
index 0000000..6177501
--- /dev/null
@@ -0,0 +1,10 @@
+--- matchbox-panel-0.9.3/src/panel_app.c.orig
++++ matchbox-panel-0.9.3/src/panel_app.c
+@@ -249,6 +249,7 @@
+   papp = NEW(MBPanelApp);
+   
++  papp->name   = NULL;
+   papp->next   = NULL;
+   papp->win    = win;
+   papp->panel  = panel;
index 5559122..3d50f5f 100644 (file)
@@ -1,5 +1,6 @@
 require matchbox-panel.inc
-PR ="r4"
+PR ="r5"
 SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz \
           file://mb-applet-battery-repaint-093.patch;patch=1 \
-          file://mb-applet-system-monitor-crash.patch;patch=1"
+          file://mb-applet-system-monitor-crash.patch;patch=1 \
+          file://matchbox-panel-uninitialised-crash.patch;patch=1"