shr-theme-o2: new recipes for o2 theme
authorJesus McCloud <bernd.pruenster@gmail.com>
Fri, 19 Mar 2010 12:50:49 +0000 (12:50 +0000)
committerMartin Jansa <Martin.Jansa@gmail.com>
Fri, 19 Mar 2010 14:03:31 +0000 (15:03 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/shr/elementary-theme-o2_git.bb [new file with mode: 0644]
recipes/shr/phoneui-shr-theme-o2_git.bb [new file with mode: 0644]
recipes/shr/shr-theme-o2.bb [new file with mode: 0644]

diff --git a/recipes/shr/elementary-theme-o2_git.bb b/recipes/shr/elementary-theme-o2_git.bb
new file mode 100644 (file)
index 0000000..45e37e6
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "o2 theme for the elementary toolkit - it looks like om2007.2"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RSUGGESTS = "phoneui-shr-theme-o2"
+LICENSE = "unknown"
+
+SRCREV = "b5eb3134850c277ad8ae1a960b03ff4a509278a8"
+PV = "0.1-${EFL_SRCREV}+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master \
+          "
+
+S = "${WORKDIR}/git/elementary/${PN}"
+
+do_compile() {
+       ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/o2.edc -o ${S}/o2.edj
+}
+
+do_install() {
+        install -d ${D}${datadir}/elementary/themes/
+        install -m 0644 ${S}/o2.edj ${D}${datadir}/elementary/themes/
+}
+
+FILES_${PN} = "${datadir}/elementary/themes/"
diff --git a/recipes/shr/phoneui-shr-theme-o2_git.bb b/recipes/shr/phoneui-shr-theme-o2_git.bb
new file mode 100644 (file)
index 0000000..a671d8b
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "o2 theme for libphone-ui-shr - it looks like om2007.2"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+SECTION = "e/utils"
+LICENSE = "unknown"
+DEPENDS = "edje-native"
+RDEPENDS = "libphone-ui-shr"
+RSUGGESTS = "elementary-theme-o2"
+SRCREV = "b5eb3134850c277ad8ae1a960b03ff4a509278a8"
+PV = "0.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/phoneui-shr/${PN}"
+
+do_compile() {
+        ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/o2.edc -o ${S}/o2.edj
+}
+do_install() {
+        install -d ${D}${datadir}/libphone-ui-shr/
+        install -m 0644 ${S}/o2.edj ${D}${datadir}/libphone-ui-shr/
+        install -m 0644 ${S}/config ${D}${datadir}/libphone-ui-shr/
+}
+
+FILES_${PN} = "${datadir}/libphone-ui-shr/"
+CONFFILES_${PN} = "${datadir}/libphone-ui-shr/config"
diff --git a/recipes/shr/shr-theme-o2.bb b/recipes/shr/shr-theme-o2.bb
new file mode 100644 (file)
index 0000000..6c03d12
--- /dev/null
@@ -0,0 +1,10 @@
+DESCRIPTION = "o2 theme suit for shr - it looks like om2007.2"
+SECTION = "x11/data"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS = "phoneui-shr-theme-o2 elementary-theme-o2"
+LICENSE = "unknown"
+
+PV = "0.1"
+
+ALLOW_EMPTY = "1"