boost 1.33.0: make it compile w/ linux-gnueabi
authorMichael Lauer <mickey@vanille-media.de>
Wed, 29 Mar 2006 14:34:12 +0000 (14:34 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 29 Mar 2006 14:34:12 +0000 (14:34 +0000)
packages/boost/boost_1.33.0.bb

index 2c81f37..db30f95 100644 (file)
@@ -10,7 +10,7 @@ SECTION = "libs"
 DEPENDS = "boost-jam-native zlib"
 PRIORITY = "optional"
 LICENSE = "Boost Software License"
-PR = "r0"
+PR = "r1"
 
 # need debian package naming for the libs
 inherit debian
@@ -128,6 +128,10 @@ BJAM_OPTS    = '${BJAM_TOOLS} \
                ${BJAM_EXTRA}'
 
 
+do_configure_prepend() {
+       cp -f boost/config/platform/linux.hpp boost/config/platform/linux-gnueabi.hpp
+}
+
 do_compile() {
        set -ex
        bjam ${BJAM_OPTS} --prefix=${prefix} \