Merge oe-devel@oe-devel.bkbits.net:packages
authorChris Larson <clarson@kergoth.com>
Fri, 3 Dec 2004 21:21:40 +0000 (21:21 +0000)
committerChris Larson <clarson@kergoth.com>
Fri, 3 Dec 2004 21:21:40 +0000 (21:21 +0000)
into odin.sc.ti.com:/home/kergoth/code/packages

2004/12/03 15:21:29-06:00 ti.com!kergoth
Update the PACKAGE_ARCH bits to suck a bit less.

BKrev: 41b0d8e4rsL0NS7oeNg9h5Mf9Y9g4A

16 files changed:
classes/base.oeclass
conf/oe.conf
gpe-session-scripts/gpe-session-scripts_0.61.oe
gpe-session-scripts/gpe-session-scripts_0.62.oe
meta/task-bootstrap.oe
mplayer/mplayer_1.0pre3try2.oe
opie-button-settings/opie-button-settings_1.1.7.oe
opie-button-settings/opie-button-settings_cvs.oe
opie-taskbar/opie-taskbar_1.1.7.oe
opie-taskbar/opie-taskbar_cvs.oe
qte/qte_2.3.7.oe
qte/qte_2.3.8-snapshot.oe
sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.oe
sharp-binary-only/sharp-sdmmc-support_2.4.18-rmk7-pxa3-embedix.oe
sysvinit/sysvinit_2.85.oe
sysvinit/sysvinit_2.86.oe

index 22447b3..caa40a9 100644 (file)
@@ -248,12 +248,8 @@ python do_showdata() {
        oe.data.emit_env(sys.__stdout__, d, True)
        # emit the metadata which isnt valid shell
        for e in d.keys():
-               if oe.data.getVarFlag(e, 'python', d):
-                       sys.__stdout__.write("\npython %s () {\n%s}\n" % (e, oe.data.getVar(e, d, 1)))
-               elif oe.data.getVarFlag(e, 'func', d):
-                       sys.__stdout__.write("\n%s () {\n%s}\n" % (e, oe.data.getVar(e, d, 1)))
-               else:
-                       sys.__stdout__.write("%s=%s\n" % (e, oe.data.getVar(e, d, 1)))
+           if oe.data.getVarFlag(e, 'python', d):
+               sys.__stdout__.write("\npython %s () {\n%s}\n" % (e, oe.data.getVar(e, d, 1)))
 }
 
 addtask listtasks
@@ -659,23 +655,20 @@ python __anonymous () {
 
 python () {
        import oe, os
-       machine = oe.data.getVar('MACHINE', d, 1)
-       if not machine:
-               # can't specialise if MACHINE not defined
-               return
+       mach_arch = oe.data.getVar('MACHINE_ARCH', d, 1)
        old_arch = oe.data.getVar('PACKAGE_ARCH', d, 1)
-       if (old_arch == machine):
+       if (old_arch == mach_arch):
                # Nothing to do
                return
        paths = []
        for p in [ "${FILE_DIRNAME}/${PF}", "${FILE_DIRNAME}/${P}", "${FILE_DIRNAME}/${PN}", "${FILE_DIRNAME}/files", "${FILE_DIRNAME}" ]:
-               paths.append(oe.data.expand(os.path.join(p, machine), d))
+               paths.append(oe.data.expand(os.path.join(p, mach_arch), d))
        for s in oe.data.getVar('SRC_URI', d, 1).split():
                local = oe.data.expand(oe.fetch.localpath(s, d), d)
                for mp in paths:
                        if local.startswith(mp):
-#                              oe.note("overriding PACKAGE_ARCH from %s to %s" % (old_arch, machine))
-                               oe.data.setVar('PACKAGE_ARCH', machine, d)
+#                              oe.note("overriding PACKAGE_ARCH from %s to %s" % (old_arch, mach_arch))
+                               oe.data.setVar('PACKAGE_ARCH', mach_arch, d)
                                return
 }
 
index 5e186c3..11b5631 100644 (file)
@@ -45,7 +45,7 @@ TARGET_PREFIX = "${TARGET_SYS}-"
 TARGET_CC_ARCH = ""
 
 PACKAGE_ARCH = "${HOST_ARCH}"
-MACHINE_ARCH = "${MACHINE}"
+MACHINE_ARCH = "${@[oe.data.getVar('PACKAGE_ARCH', d, 1), oe.data.getVar('MACHINE', d, 1)][bool(oe.data.getVar('MACHINE', d, 1))]}"
 
 ##################################################################
 # Date/time variables.
index 41c6501..acd5158 100644 (file)
@@ -20,3 +20,5 @@ do_install_append() {
        fi
 }
 
+# This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
+PACKAGE_ARCH := "${MACHINE_ARCH}"
index 4aa0ce0..de53292 100644 (file)
@@ -25,3 +25,5 @@ do_install_append() {
        fi
 }
 
+# This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
+PACKAGE_ARCH := "${MACHINE_ARCH}"
index 9554110..9199ed9 100644 (file)
@@ -2,6 +2,10 @@ DESCRIPTION = "Core packages required for a basic installation"
 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
 PR = "r10"
 
+# The BOOTSTRAP_EXTRA_ variables are often manipulated by the
+# MACHINE .conf files, so adjust PACKAGE_ARCH accordingly.
+PACKAGE_ARCH := "${MACHINE_ARCH}"
+
 ALLOW_EMPTY = 1
 PACKAGES = "${PN}"
 
index 3d43658..009d258 100644 (file)
@@ -14,9 +14,9 @@ DEPENDS_corgi += "sharp-aticore"
 DEPENDS_shepherd += "sharp-aticore"
 DEPENDS_husky += "sharp-aticore"
 
-PACKAGE_ARCH_corgi = "${MACHINE}"
-PACKAGE_ARCH_shepherd = "${MACHINE}"
-PACKAGE_ARCH_husky = "${MACHINE}"
+PACKAGE_ARCH_corgi := "${MACHINE_ARCH}"
+PACKAGE_ARCH_shepherd := "${MACHINE_ARCH}"
+PACKAGE_ARCH_husky := "${MACHINE_ARCH}"
 
 SRC_URI_append_corgi = "file://mplayer-w100_1.0pre3.1.modified.diff;patch=1 \
                         file://Makefile-vidix.patch;patch=0 "
index f2313f7..f9796c2 100644 (file)
@@ -29,4 +29,4 @@ FILES_opie-button-settings-pics = "${palmtopdir}/pics/devicebuttons/z*"
 FILES_opie-button-settings-pics_h3600 = "${palmtopdir}/pics/devicebuttons/ipaq*"
 FILES_opie-button-settings-pics_h3900 = "${palmtopdir}/pics/devicebuttons/ipaq*"
 FILES_opie-button-settings-pics_simpad = "${palmtopdir}/pics/devicebuttons/simpad*"
-PACKAGE_ARCH_opie-button-settings-pics = "${MACHINE_ARCH}"
+PACKAGE_ARCH_opie-button-settings-pics := "${MACHINE_ARCH}"
index 8e1ef8b..bd4b1dc 100644 (file)
@@ -28,4 +28,4 @@ FILES_opie-button-settings-pics = "${palmtopdir}/pics/devicebuttons/z*"
 FILES_opie-button-settings-pics_h3600 = "${palmtopdir}/pics/devicebuttons/ipaq*"
 FILES_opie-button-settings-pics_h3900 = "${palmtopdir}/pics/devicebuttons/ipaq*"
 FILES_opie-button-settings-pics_simpad = "${palmtopdir}/pics/devicebuttons/simpad*"
-PACKAGE_ARCH_opie-button-settings-pics = "${MACHINE_ARCH}"
+PACKAGE_ARCH_opie-button-settings-pics := "${MACHINE_ARCH}"
index 460bbd7..dbcb23c 100644 (file)
@@ -131,5 +131,4 @@ do_install_append_tosa () {
 
 FILES_opie-taskbar_append = " /etc /etc/profile.d ${palmtopdir}/apps ${palmtopdir}/pics"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
+PACKAGE_ARCH := "${MACHINE_ARCH}"
index 1c89d32..469c36b 100644 (file)
@@ -128,5 +128,4 @@ do_install_append_tosa () {
 
 FILES_opie-taskbar_append = " /etc ${palmtopdir}/apps ${palmtopdir}/pics"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
+PACKAGE_ARCH := "${MACHINE_ARCH}"
index c6ae045..104c4b3 100644 (file)
@@ -164,7 +164,7 @@ ${sbindir}/update-qtfontdir
 PACKAGES = "libqte2 qte-font-fixed qte-font-helvetica-small qte-font-helvetica-large \
                        qte-font-smoothtimes qte-font-smallsmooth qte-font-unicode qte-font-lcd \
                        qte-font-japanese qte-font-micro qte-font-courier"
-PACKAGE_ARCH_libqte2 = "${MACHINE_ARCH}"
+PACKAGE_ARCH_libqte2 := "${MACHINE_ARCH}"
 
 FILES_${PN} = ""
 FILES_libqte2 = "${palmtopdir}/lib/libqte.so* /usr/sbin/update-qtfontdir"
index 4ddfa97..137b504 100644 (file)
@@ -166,7 +166,7 @@ PACKAGES = "libqte2 qte-font-fixed qte-font-helvetica-small qte-font-helvetica-l
       qte-font-unicode qte-font-lcd qte-font-japanese qte-font-micro \
       qte-font-courier"
 
-PACKAGE_ARCH_libqte2 = "${MACHINE_ARCH}"
+PACKAGE_ARCH_libqte2 := "${MACHINE_ARCH}"
 
 FILES_${PN} = ""
 FILES_libqte2 = "${palmtopdir}/lib/libqte.so* /usr/sbin/update-qtfontdir"
index ef2bab7..fd31c3b 100644 (file)
@@ -23,8 +23,4 @@ do_install() {
 
 FILES_${PN} = "/"
 
-python () {
-       mach = oe.data.getVar('MACHINE', d, 1)
-       if mach:
-               oe.data.setVar('PACKAGE_ARCH', oe.data.getVar('MACHINE_ARCH', d, 1), d)
-}
+PACKAGE_ARCH := "${MACHINE_ARCH}"
index a56b6a4..66bb84a 100644 (file)
@@ -28,8 +28,4 @@ do_install() {
 
 FILES_${PN} = "/"
 
-python () {
-       mach = oe.data.getVar('MACHINE', d, 1)
-       if mach:
-               oe.data.setVar('PACKAGE_ARCH', oe.data.getVar('MACHINE_ARCH', d, 1), d)
-}
+PACKAGE_ARCH := "${MACHINE_ARCH}"
index b1c2c01..149e186 100644 (file)
@@ -10,11 +10,9 @@ FILES_${PN} = "/sbin ${bindir} ${sysconfdir}"
 FILES_sysv-rc = "${sbindir}"
 PR = "r1"
 
-python () {
-       mach = oe.data.getVar('MACHINE', d, 1)
-       if mach:
-               oe.data.setVar('PACKAGE_ARCH', oe.data.getVar('MACHINE_ARCH', d, 1), d)
-}
+# USE_VT and SERIAL_CONSLE are generally defined by the MACHINE .conf.
+# Set PACKAGE_ARCH appropriately.
+PACKAGE_ARCH := "${MACHINE_ARCH}"
 
 USE_VT ?= "1"
 
index da081f4..4c698c7 100644 (file)
@@ -7,11 +7,9 @@ HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
 FILES_${PN} += "/sbin /bin"
 PR = "r0"
 
-python () {
-       mach = oe.data.getVar('MACHINE', d, 1)
-       if mach:
-               oe.data.setVar('PACKAGE_ARCH', oe.data.getVar('MACHINE_ARCH', d, 1), d)
-}
+# USE_VT and SERIAL_CONSLE are generally defined by the MACHINE .conf.
+# Set PACKAGE_ARCH appropriately.
+PACKAGE_ARCH := "${MACHINE_ARCH}"
 
 USE_VT ?= "1"