xfce4-session: crash workaround
authorGrazvydas Ignotas <notasas@gmail.com>
Sat, 11 Oct 2014 16:23:23 +0000 (19:23 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 11 Oct 2014 16:23:23 +0000 (19:23 +0300)
recipes/xfce-base/xfce4-session_4.6.2.bb

index 634d336..f7ee613 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "xfce4-session is a session manager for Xfce 4 Desktop Environment
 DEPENDS = "libwnck libxfcegui4 libxfce4util dbus iceauth xfce-utils"
 SECTION = "x11"
 
-PR = "r2"
+PR = "r3"
 
 inherit xfce46
 
@@ -20,5 +20,14 @@ FILES_${PN}-dbg += "${libdir}/xfce4/splash/engines/.debug/*.a"
 FILES_${PN}-dev += "${libdir}/xfce4/splash/engines/*.la"
 FILES_${PN}-dev += "${libdir}/xfce4/splash/engines/*.a"
 
+pkg_postinst_${PN} () {
+#!/bin/sh
+# old cache seems to be incompatible and causes
+# xfce4-session to crash, must delete..
+  rm -rf $HOME/Applications/Cache
+  user=`cat /tmp/currentuser 2> /dev/null`
+  test -n "$user" && rm -rf /home/$user/Applications/Cache
+}
+
 SRC_URI[md5sum] = "9d9890130e45e0e9476591ed9ba2c9d5"
 SRC_URI[sha256sum] = "725e269254c34c530acb670f5ccd0fd69b57cbe9f2176abd8499fc5d6dcd30a8"