gnome-mplayer: Add INC_PR support to recipes, add 0.9.9 and bump svn to latest SVN...
authorDavid-John Willis <John.Willis@Distant-earth.com>
Wed, 17 Feb 2010 20:19:26 +0000 (20:19 +0000)
committerKoen Kooi <koen@openembedded.org>
Thu, 18 Feb 2010 14:26:23 +0000 (15:26 +0100)
* Also mark SVN and def_pref=-1 so people default to the latest stable 0.9.9 as that is the same code as the old SVN recipe.

recipes/gnome-mplayer/gnome-mplayer.inc
recipes/gnome-mplayer/gnome-mplayer_0.5.3.bb
recipes/gnome-mplayer/gnome-mplayer_0.9.5.bb
recipes/gnome-mplayer/gnome-mplayer_0.9.8.bb
recipes/gnome-mplayer/gnome-mplayer_0.9.9.bb [new file with mode: 0644]
recipes/gnome-mplayer/gnome-mplayer_svn.bb

index 07445ce..dc364ff 100644 (file)
@@ -8,7 +8,9 @@ RDEPENDS = "mplayer"
 
 inherit gnome
 
-SRC_URI = "http://gnome-mplayer.googlecode.com/files/${P}.tar.gz"
+INC_PR = "r10"
+
+SRC_URI = "http://gnome-mplayer.googlecode.com/files/${P}.tar.gz;name=gnomemplayer"
 
 PACKAGES =+ "${PN}-nautilus-extension"
 FILES_${PN}-nautilus-extension = "${libdir}/nautilus/extension*/*.so"
@@ -20,4 +22,3 @@ FILES_${PN} += "${datadir}/icons  ${datadir}/gnome-control-center/"
 do_install_append() {
     sed -i "s/OnlyShowIn=GNOME;//" ${D}${datadir}/applications/gnome-mplayer.desktop
 }   
-
index 95b4617..2ccb2ae 100644 (file)
@@ -4,4 +4,4 @@ SRC_URI += "file://gnome-mplayer-svn.diff;patch=1;pnum=0 \
             file://default.patch;patch=1 \
 "
 
-PR = "r9"
+PR = "${INC_PR}.0"
diff --git a/recipes/gnome-mplayer/gnome-mplayer_0.9.9.bb b/recipes/gnome-mplayer/gnome-mplayer_0.9.9.bb
new file mode 100644 (file)
index 0000000..556a9a3
--- /dev/null
@@ -0,0 +1,9 @@
+require gnome-mplayer.inc
+
+SRC_URI += "file://default.patch;patch=1 \
+"
+
+SRC_URI[gnomemplayer.md5sum] = "335918da07a62941778444e126ae5ede"
+SRC_URI[gnomemplayer.sha256sum] = "8180f8de085879280be4a6356ae70acd749f37eea48c943870d3caa145d2826d"
+
+PR = "${INC_PR}.0"
index 5f8e9ec..97ed70e 100644 (file)
@@ -1,12 +1,16 @@
 require gnome-mplayer.inc
 
-SRCREV = "1634"
-PV = "0.9.8+svnr${SRCPV}"
-PR = "r1"
+SRCREV = "1652"
+PV = "0.9.9+svnr${SRCPV}"
+PR = "${INC_PR}.0"
 S = "${WORKDIR}/trunk"
 
 SRC_URI = "svn://gnome-mplayer.googlecode.com/svn/;module=trunk;proto=http \
+           file://default.patch;patch=1 \
 "
 
+# Untested
+DEFAULT_PREFERENCE = "-1"
+
 #hack, should use CXX to link:
 LDFLAGS_append = " -lstdc++ "