frameworkd: add a postinst script to echo a note about the need
authorKlaus Kurzmann <mok@fluxnetz.de>
Tue, 26 Jan 2010 19:10:17 +0000 (20:10 +0100)
committerKlaus Kurzmann <mok@fluxnetz.de>
Tue, 26 Jan 2010 19:10:17 +0000 (20:10 +0100)
to run the conversion script needed for new opimd

Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
recipes/freesmartphone/frameworkd_git.bb

index 926fcf6..c4fbdf3 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "console/network"
 DEPENDS = "python-cython-native python-pyrex-native"
 LICENSE = "GPL"
 PV = "0.9.5.9+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
 
 inherit distutils update-rc.d
 
@@ -30,6 +30,12 @@ do_install_append() {
        install -m 0644 ${WORKDIR}/frameworkd.conf ${D}${sysconfdir}
 }
 
+pkg_postinst_${PN} () {
+       echo "NOTE: if you have old contacts without field types and the"
+       echo "      tel: prefix instead please use the remove-tel script"
+       echo "      from http://wiki.shr-project.org/trac/wiki/new-opimd"
+}
+
 RDEPENDS_${PN} += "\
   fsousaged \
 "