qi-ubi: add ubifs rootfs params also for gta01, move SRCREV to recipe
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 10 Mar 2010 08:21:37 +0000 (09:21 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Thu, 11 Mar 2010 10:41:55 +0000 (11:41 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
conf/distro/include/sane-srcrevs.inc
recipes/qi/files/0002-gta02-add-kernel-params-to-boot-from-ubifs-ubi0-om-g.patch [deleted file]
recipes/qi/files/rootfstype.ubifs.patch [new file with mode: 0644]
recipes/qi/qi-ubi_git.bb
recipes/qi/qi_git.bb

index 5c77f28..b51dab1 100644 (file)
@@ -252,8 +252,6 @@ QEMUSRCREV ?= "4242"
 SRCREV_pn-qemu ?= "${QEMUSRCREV}"
 SRCREV_pn-qemu-native ?= "${QEMUSRCREV}"
 SRCREV_pn-qemu-sdk ?= "${QEMUSRCREV}"
-SRCREV_pn-qi ?= "c38b062a609f1442e6a9e13005cfbdfd59a5ac0d"
-SRCREV_pn-qi-ubi ?= "c38b062a609f1442e6a9e13005cfbdfd59a5ac0d"
 SRCREV_pn-qtwebkit-performance-utilities ?= "27a630a74518ebb7810ed5886182e676b36c07a5"
 SRCREV_pn-qtwebkit-performance-utilities-e ?= "27a630a74518ebb7810ed5886182e676b36c07a5"
 SRCREV_pn-remoko ?= "121"
diff --git a/recipes/qi/files/0002-gta02-add-kernel-params-to-boot-from-ubifs-ubi0-om-g.patch b/recipes/qi/files/0002-gta02-add-kernel-params-to-boot-from-ubifs-ubi0-om-g.patch
deleted file mode 100644 (file)
index d2e7517..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From 843dbaa59d56b7c042662f48ed68bd41960635dd Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Tue, 5 Jan 2010 12:44:25 +0100
-Subject: [PATCH 2/2] gta02: add kernel params to boot from ubifs ubi0:om-gta02-rootfs
-
----
- src/cpu/s3c2442/gta02.c |    5 +++--
- 1 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/cpu/s3c2442/gta02.c b/src/cpu/s3c2442/gta02.c
-index 0347f61..48ee245 100644
---- a/src/cpu/s3c2442/gta02.c
-+++ b/src/cpu/s3c2442/gta02.c
-@@ -733,8 +733,9 @@ const struct board_api board_api_gta02 = {
-                       /* NOTE offset below is replaced at runtime */
-                       .offset_blocks512_if_no_partition = 0x80000 / 512,
-                       .filesystem = FS_RAW,
--                      .commandline_append = " rootfstype=jffs2 "
--                                            "root=/dev/mtdblock6 ",
-+                      .commandline_append = " rootfstype=ubifs " \
-+                                            " ubi.mtd=6,2048 " \
-+                                            " root=ubi0:om-gta02-rootfs ",
-               },
-       },
- };
--- 
-1.6.6
-
diff --git a/recipes/qi/files/rootfstype.ubifs.patch b/recipes/qi/files/rootfstype.ubifs.patch
new file mode 100644 (file)
index 0000000..4775c16
--- /dev/null
@@ -0,0 +1,45 @@
+From 9313360da422929181bfb3339137caaa4400195f Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 5 Jan 2010 12:44:25 +0100
+Subject: [PATCH 1/2] gta02|gta01: add kernel params to boot from ubifs ubi0:rootfs
+
+---
+ src/cpu/s3c2410/gta01.c |    5 +++--
+ src/cpu/s3c2442/gta02.c |    5 +++--
+ 2 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/src/cpu/s3c2410/gta01.c b/src/cpu/s3c2410/gta01.c
+index 4686fa2..a2fce11 100644
+--- a/src/cpu/s3c2410/gta01.c
++++ b/src/cpu/s3c2410/gta01.c
+@@ -305,8 +305,9 @@ const struct board_api board_api_gta01 = {
+                       .block_read = nand_read_ll,
+                       .offset_blocks512_if_no_partition = 0x44000 / 512,
+                       .filesystem = FS_RAW,
+-                      .commandline_append = "rootfstype=jffs2 "
+-                                     "root=/dev/mtdblock4 ",
++                      .commandline_append = " rootfstype=ubifs " \
++                                     " ubi.mtd=4,512 " \
++                                     " root=ubi0:om-gta01-rootfs ",
+               },
+       },
+ };
+diff --git a/src/cpu/s3c2442/gta02.c b/src/cpu/s3c2442/gta02.c
+index 0347f61..48ee245 100644
+--- a/src/cpu/s3c2442/gta02.c
++++ b/src/cpu/s3c2442/gta02.c
+@@ -733,8 +733,9 @@ const struct board_api board_api_gta02 = {
+                       /* NOTE offset below is replaced at runtime */
+                       .offset_blocks512_if_no_partition = 0x80000 / 512,
+                       .filesystem = FS_RAW,
+-                      .commandline_append = " rootfstype=jffs2 "
+-                                            "root=/dev/mtdblock6 ",
++                      .commandline_append = " rootfstype=ubifs " \
++                                            " ubi.mtd=6,2048 " \
++                                            " root=ubi0:om-gta02-rootfs ",
+               },
+       },
+ };
+-- 
+1.7.0.2
+
index fb8bbe0..65995a6 100644 (file)
@@ -6,5 +6,5 @@ do_configure_prepend() {
 }
 
 SRC_URI_append = "\
-  file://0002-gta02-add-kernel-params-to-boot-from-ubifs-ubi0-om-g.patch;patch=1 \
+  file://rootfstype.ubifs.patch;patch=1 \
 "
index 3364054..a9c8215 100644 (file)
@@ -1,7 +1,8 @@
 require qi.inc
-PR = "r0"
+PR = "r1"
 PR_append = "+gitr${SRCREV}"
 
+SRCREV = "c38b062a609f1442e6a9e13005cfbdfd59a5ac0d"
 SRC_URI = "\
   git://git.openmoko.org/git/qi.git;protocol=git;branch=master \
   file://sanitize-makefile.patch;patch=1 \