glamo-dri-tests: new recipe from SHR
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:33:02 +0000 (09:33 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:57:56 +0000 (09:57 +0100)
recipes/xorg-util/glamo-dri-tests/glamo-dri-tests_git.bb [new file with mode: 0644]

diff --git a/recipes/xorg-util/glamo-dri-tests/glamo-dri-tests_git.bb b/recipes/xorg-util/glamo-dri-tests/glamo-dri-tests_git.bb
new file mode 100644 (file)
index 0000000..0e6d731
--- /dev/null
@@ -0,0 +1,17 @@
+DEPENDS = "libdrm virtual/libx11 libxext"
+
+PV = "1.0.0+gitr${SRCPV}"
+
+SRC_URI = "git://git.bitwiz.org.uk/glamo-dri-tests.git;protocol=git;branch=master"
+
+inherit pkgconfig
+
+do_compile_prepend() {
+       export CROSS_CFLAGS=`pkg-config --cflags libdrm_glamo`
+}
+
+do_install() {
+        PREFIX=${D}/usr make install
+}
+
+S = "${WORKDIR}/git"