Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org...
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Tue, 3 Nov 2009 20:45:24 +0000 (21:45 +0100)
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Tue, 3 Nov 2009 20:45:24 +0000 (21:45 +0100)
recipes/autofs/autofs.inc [new file with mode: 0644]
recipes/autofs/autofs_3.1.7.bb
recipes/autofs/autofs_4.0.0.bb
recipes/autofs/autofs_4.1.4.bb

diff --git a/recipes/autofs/autofs.inc b/recipes/autofs/autofs.inc
new file mode 100644 (file)
index 0000000..badadb5
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Kernel based automounter for linux."
+SECTION = "base"
+LICENSE = "GPL"
+INC_PR = "r4"
+EXTRA_OEMAKE += "'RANLIB=${RANLIB}'"
+
+inherit autotools
+
+do_configure_prepend () {
+       if [ ! -e acinclude.m4 ]; then
+               cp aclocal.m4 acinclude.m4
+       fi
+}
+
+do_install () {
+       install -d ${D}${mandir}/man5 ${D}${mandir}/man8 \
+                  ${D}${sbindir}
+       oe_runmake 'INSTALLROOT=${D}' install
+}
index 05481ed..10840d8 100644 (file)
@@ -1,18 +1,4 @@
-DESCRIPTION = "Kernel based automounter for linux."
-SECTION = "base"
-LICENSE = "GPL"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v3/autofs-${PV}.tar.bz2"
-
-inherit autotools
+require autofs.inc
 
-do_configure_prepend () {
-       if [ ! -e acinclude.m4 ]; then
-               cp aclocal.m4 acinclude.m4
-       fi
-}
-
-do_install () {
-       install -d ${D}${mandir}/man5 ${D}${mandir}/man8 \
-                  ${D}${sbindir}
-       oe_runmake 'INSTALLROOT=${D}' install
-}
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v3/autofs-${PV}.tar.bz2"
+PR = "${INC_PR}"
index 6033b8a..b08d6aa 100644 (file)
@@ -1,17 +1,4 @@
-DESCRIPTION = "Kernel based automounter for linux."
-SECTION = "base"
-LICENSE = "GPL"
+require autofs.inc
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/old/autofs-${PV}-1.tar.bz2"
-
-inherit autotools
-
-do_configure_prepend () {
-       if [ ! -e acinclude.m4 ]; then
-               cp aclocal.m4 acinclude.m4
-       fi
-}
-
-do_install () {
-       oe_runmake 'INSTALLROOT=${D}' install
-}
+PR = "${INC_PR}"
index 2f998ab..0ec818a 100644 (file)
@@ -1,8 +1,4 @@
-DESCRIPTION = "Kernel based automounter for linux."
-SECTION = "base"
-LICENSE = "GPL"
-
-PR = "r3"
+require autofs.inc
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
@@ -14,8 +10,9 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2
           file://auto.net-sort-option-fix.patch;patch=1 \
           file://autofs-additional-distros.patch;patch=1 \
           file://no-bash.patch;patch=1"
+PR = "${INC_PR}"
 
-inherit autotools update-rc.d
+inherit update-rc.d
 
 INITSCRIPT_NAME = "autofs"
 INITSCRIPT_PARAMS = "defaults"
@@ -24,13 +21,3 @@ INITSCRIPT_PARAMS = "defaults"
 CFLAGS += "${LDFLAGS}"
 EXTRA_OEMAKE = "STRIP=/bin/true"
 PARALLEL_MAKE = ""
-
-do_configure_prepend () {
-       if [ ! -e acinclude.m4 ]; then
-               cp aclocal.m4 acinclude.m4
-       fi
-}
-
-do_install () {
-       oe_runmake 'INSTALLROOT=${D}' install
-}