libmokoui2: add patches from SHR
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:38:40 +0000 (09:38 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:58:02 +0000 (09:58 +0100)
recipes/openmoko2/libmokoui2/configure.patch [new file with mode: 0644]
recipes/openmoko2/libmokoui2/makefile.am.patch [new file with mode: 0644]
recipes/openmoko2/libmokoui2_svn.bb

diff --git a/recipes/openmoko2/libmokoui2/configure.patch b/recipes/openmoko2/libmokoui2/configure.patch
new file mode 100644 (file)
index 0000000..174c598
--- /dev/null
@@ -0,0 +1,10 @@
+--- libmokoui.old/configure.ac 2009-06-10 12:42:32.000000000 +0200
++++ libmokoui2/configure.ac    2009-06-10 12:42:43.000000000 +0200
+@@ -28,7 +28,6 @@
+ if test $enable_python != no ; then
+     AM_PATH_PYTHON(2.3.5)
+-    PKG_CHECK_MODULES(GNOME_PYTHON, gnome-python-2.0 >= 2.10.00)
+     AC_SUBST(PYGDK_CFLAGS)
+     AC_SUBST(PYGDK_LIBS)
diff --git a/recipes/openmoko2/libmokoui2/makefile.am.patch b/recipes/openmoko2/libmokoui2/makefile.am.patch
new file mode 100644 (file)
index 0000000..79f0a48
--- /dev/null
@@ -0,0 +1,19 @@
+--- libmokoui.old/bindings/python/Makefile.am  2009-06-10 12:42:32.000000000 +0200
++++ libmokoui2/bindings/python/Makefile.am     2009-06-10 12:51:45.000000000 +0200
+@@ -1,13 +1,12 @@
+-
+-PY_DEFS=`pkg-config --variable=defsdir pygtk-2.0`
+-PYTHON_INCLUDES=-I/usr/include/python${PYTHON_VERSION}
++PY_DEFS=${PKG_CONFIG_SYSROOT_DIR}`pkg-config --variable=defsdir pygtk-2.0`
++PYTHON_INCLUDES=-I${PKG_CONFIG_SYSROOT_DIR}/usr/include/python${PYTHON_VERSION}
+ CLEANFILES = \
+       mokoui.defs \
+       mokoui.c
+ mokoui.defs: ../../libmokoui/moko-finger-scroll.h
+-      python /usr/share/pygtk/2.0/codegen/h2def.py ../../libmokoui/moko-finger-scroll.h > mokoui.defs
++      python ${PKG_CONFIG_SYSROOT_DIR}`pkg-config --variable=codegendir pygtk-2.0`/h2def.py ../../libmokoui/moko-finger-scroll.h > mokoui.defs
+ mokoui.c: mokoui.defs mokoui.override
+       pygtk-codegen-2.0 --prefix mokoui \
index 58f4b56..176f775 100644 (file)
@@ -1,12 +1,19 @@
 SECTION = "openmoko/libs"
-DEPENDS = "gtk+"
+DEPENDS = "gtk+ python-pygtk"
+
 PV = "0.1.0+svnr${SRCPV}"
-PR = "r2"
+PR = "r5"
 
 inherit openmoko2
 
+SRC_URI += "\
+       file://configure.patch;patch=1 \
+       file://makefile.am.patch;patch=1 \
+       "
 LICENSE = "LGPL"
 
+EXTRA_OECONF += " --enable-python"
+
 do_configure_prepend() {
         touch gtk-doc.make
 }
@@ -14,4 +21,6 @@ do_configure_prepend() {
 do_stage() {
         autotools_stage_all
 }
-
+FILES_${PN} += "${libdir}/python2.6/site-packages/mokoui.*"
+FILES_${PN}-dbg += "${libdir}/python2.6/site-packages/.debug/"
+FILES_${PN}-dev += "/usr/share/vala/vapi/"