mplayer: redraw XV colourkey on every expose
authorKoen Kooi <koen@openembedded.org>
Thu, 1 Oct 2009 12:12:04 +0000 (14:12 +0200)
committerKoen Kooi <koen@openembedded.org>
Thu, 1 Oct 2009 12:12:04 +0000 (14:12 +0200)
This fixes embedding into gnome-mplayer

recipes/mplayer/files/vo_omapfb.c
recipes/mplayer/mplayer_svn.bb

index 2d83b1c..cb4daff 100644 (file)
@@ -201,7 +201,7 @@ static void x11_check_events(void)
 
     if (e & VO_EVENT_EXPOSE || e & VO_EVENT_RESIZE)
     {
-/*        vo_xv_draw_colorkey(drwX, drwY, vo_dwidth - 1, vo_dheight - 1); */
+        vo_xv_draw_colorkey(drwX, drwY, vo_dwidth - 1, vo_dheight - 1);
         omapfb_update(0, 0, 0, 0, 1);
     }
 }
index e3ea607..7c61cd0 100644 (file)
@@ -34,7 +34,7 @@ RCONFLICTS_${PN} = "mplayer-atty"
 RREPLACES_${PN} = "mplayer-atty"
 
 PV = "0.0+1.0rc2+svnr${SRCREV}"
-PR = "r13"
+PR = "r14"
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_armv7a = "1"