NeoLight: new recipe (version 1.4.0 from svn)
authorValery Febvre <vfebvre@easter-eggs.com>
Wed, 17 Mar 2010 15:47:51 +0000 (15:47 +0000)
committerMartin Jansa <Martin.Jansa@gmail.com>
Thu, 18 Mar 2010 13:49:26 +0000 (14:49 +0100)
NeoLight turns your mobile device into a flashlight.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/openmoko-3rdparty/neolight_svn.bb [new file with mode: 0644]

diff --git a/recipes/openmoko-3rdparty/neolight_svn.bb b/recipes/openmoko-3rdparty/neolight_svn.bb
new file mode 100644 (file)
index 0000000..8568072
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "An application to turn your mobile device into a flashlight"
+HOMEPAGE = "http://code.google.com/p/neolight/"
+LICENSE = "GPLv3"
+AUTHOR = "ValĂ©ry Febvre <vfebvre@easter-eggs.com>"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+
+SRCREV = "16"
+PV = "1.4.0+svnr${SRCPV}"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = "svn://neolight.googlecode.com/svn;module=trunk;proto=http"
+S = "${WORKDIR}/trunk"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}/neolight ${datadir}/applications/neolight.desktop ${datadir}/pixmaps/neolight.png"
+
+RDEPENDS += "python-edbus python-elementary"
+
+do_compile_prepend() {
+       ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/data ${S}/data/neolight.edc
+}