mono-native 1.2.5.1: fix up mono native compile and make mono depend on it
authorHenryk Ploetz <henryk@openmoko.org>
Thu, 27 Sep 2007 20:24:22 +0000 (20:24 +0000)
committerCliff Brake <cbrake@bec-systems.com>
Thu, 27 Sep 2007 20:24:22 +0000 (20:24 +0000)
packages/mono/mono-native_1.2.5.1.bb
packages/mono/mono_1.2.5.1.bb
packages/mono/mono_1.2.5.inc

index 2670d3f..09223dd 100644 (file)
@@ -1,10 +1,21 @@
 require mono_1.2.5.inc
-PR = "r0"
+PR = "r1"
 DEPENDS = "glib-2.0-native"
 
+SRC_URI += "file://mono-fix-libdir-path.patch;patch=1"
+
 inherit native
 
 #do_stage_prepend() {
 #      install -m 755 ${S}/mono/monoburg/monoburg ${STAGING_BINDIR}
 #}
 
+do_fix_libtool_name() {
+       # inherit native will make that all native tools that are being
+       # built are prefixed with something like "i686-linux-",
+       # including libtool. Fix up some hardcoded libtool names:
+       for i in "${S}"/runtime/*-wrapper.in; do
+               sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+       done
+}
+addtask fix_libtool_name after do_patch before do_configure
index c0a4cfb..e1f3f1b 100644 (file)
@@ -1,14 +1,8 @@
 require mono_1.2.5.inc
 
-#DEPENDS = "mono-native glib-2.0"
-# for now, we skip the mono-native build -- just install
-# mono using your distro package manager for now
-# after we get the target version working, we'll worry
-# about the native package for systems that don't have mono
-# installed
-DEPENDS = "glib-2.0"
+DEPENDS = "mono-native glib-2.0"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI += "file://configure.patch;patch=1"
 
@@ -17,6 +11,8 @@ do_install_append() {
        cp ${S}/mcs/class/lib/monolite/* ${D}${libdir}/mono/1.0/
 }
 
+EXTRA_OECONF += " --disable-mcs-build "
+
 PACKAGES =+ "mono-dll"
 FILES_mono-dll = "${libdir}/mono/1.0/"
 
index 5164b05..aeca713 100644 (file)
@@ -7,7 +7,6 @@ SRC_URI = "http://go-mono.com/sources/mono/mono-${PV}.tar.bz2"
 S = "${WORKDIR}/mono-${PV}"
 
 inherit autotools
-EXTRA_OECONF = "--disable-mcs-build"
 EXTRA_OECONF_arm = "--without-tls"
 EXTRA_OECONF_mipsel = "--without-tls"