rename packages/ to recipes/ per earlier agreement
[openembedded.git] / recipes / zip / zip.inc
diff --git a/recipes/zip/zip.inc b/recipes/zip/zip.inc
new file mode 100644 (file)
index 0000000..8d04bd5
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Archiver for .zip files"
+SECTION = "console/utils"
+LICENSE = "Info-ZIP"
+
+SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip${@bb.data.getVar('PV',d,1).replace('.', '')}.tar.gz"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
+               'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
+               'BINFLAGS=0755' 'INSTALL_D=install -d'"
+
+do_compile() {
+       oe_runmake -f unix/Makefile generic
+}
+
+do_install() {
+       oe_runmake -f unix/Makefile prefix=${D}${prefix} \
+                  BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
+                  install
+}