Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedde...
[openembedded.git] / recipes / webkit / webkit-gtk_svn.bb
index 9892672..64c031d 100644 (file)
@@ -1,11 +1,9 @@
 DESCRIPTION = "WebKit browser engine, GTK+ edition"
-DEPENDS = "libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
+DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
 
 SRCREV_FORMAT = "webcore-rwebkit"
 
-# Yes, this is wrong...
-PV = "0.1+svnr${SRCREV}"
-PR = "r8"
+PV = "1.1.15+svnr${SRCREV}"
 
 SRC_URI = "\
   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -19,8 +17,8 @@ SRC_URI = "\
   file://Makefile.shared \
   file://autogen.sh \
   file://configure.ac \
-  file://symbols.filter \
   file://GNUmakefile.am \
+  file://gtk-doc.make \
  "
 
 S = "${WORKDIR}/"
@@ -33,8 +31,11 @@ EXTRA_OECONF = "\
                 --enable-debug=no \
                 --enable-svg \
                 --enable-icon-database=yes \
-               --with-http-backend=soup \
-               "
+                --with-http-backend=soup \
+#                --with-unicode-backend=glib \
+                --with-libsoup-gnome=yes \
+"
+
 EXTRA_AUTORECONF = " -I autotools "
 
 # Dolt gets used on x86 and ppc and hardcodes 'libtool'
@@ -54,7 +55,7 @@ do_compile_prepend() {
             ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
         fi
         cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
-        cp dftables ${S}/Programs/        
+        cp dftables ${S}/Programs/
        cd ${S}
 }
 
@@ -67,5 +68,5 @@ FILES_${PN}launcher = "${bindir}/GtkLauncher"
 FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
 FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
 FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
-
+FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html ${datadir}/webkit-1.0/images"